VCMI 0.7 - Bug Reports

#1 - Game crashes at launch on my machine:

FYI - I didn’t clean my Heroes folder of previous version files yet. I copied 0.7 (downloaded half an hour ago - so it must be the updated archive) over a working version of 0.69. If others don’t experience this crash, I’ll uninstall everything and then try a clean 0.7 install.

Can you paste several last lines of VCMI_Client_log.txt?
VCMI should work even if extracted over previous version.

Oh, one more thought.
Old savegames (from 0.69 and earlier) might not be recognized properly and cause crashes of 0.7. Check if you have any VCMI games (H3 saves are ignored) in the /Games subfolder and try removing them.

I think you’ve got it! :mrgreen: I copied back over one of my 0.69 saves, 0.7 crashed on start-up. Removed the save, 0.7 started up fine. =) It would explain why clean installs worked and overwrites of VCMI files didn’t, though for a slightly different reason than a remainder of older VCMI required files. It would also explain why we had all those bugs when upgrading from 0.68 -> 0.69.

Great job - trial and error succeeds! :slight_smile:

Best regards,

#2 - Spell books tend to get placed in all empty War Machine slots. Sometimes when entering battle the spell book is open immediately and then the game crashes (tested with a Rampart hero without a spell book in the spell book slot).

#3 - Horde buildings can be built twice - once gives the horde bonus and shows the horde building on the screen, but then it is still available a second time from the town construction screen - second time requires the upgraded creature dwelling. However building it a second time doesn’t seem to do anything at all, but still costs resources. =)

#4 - Rampart’s Treasury should require Miner’s Guild before the Treasury can be built.

#5 - Sometimes in scroll bar slider screens (such as buying troops, re-distributing troops, using Marketplace) the scroll bar gets stuck and just moving the mouse causes the slider to move. In a town’s Marketplace, if this happens it causes a game crash (if using the Marketplace more than 2 or 3 times).

#6 - Right-clicking on heroes in Tavern reasonably often causes a crash.

Right-click on Tavern hero:

After crash, screen showing before closing the crash dialog:

Best regards,

#7 - Wrong animation for Priest (Kapłan), they shot with arrows not balls

#8 - “Obozowisko”, “Młyn wodny”, “Obóz najemników” not add resources / skills when i get it (winodw appear)

#9 - When i bought monsters without set how much ( set 0 ) and I don’t have money or needed resources and I click buy i get crash

#10 - archangels animation in battle is very slow

#11 - cant capture opponent’s castle

It’s because I haven’t found appropriate animation. It would be nice if you could find it.

AFAIR it’s not implemented yet…

Indeed. As Steven confirmed, once I removed the old VCMI saves, the application could start. Alas, it seems some other remaining files from previous VCMI installation are still causing that L14 crash I had in 0.69. I’ll remove H3 completely and then try a clean install.


Not reproducible for me.
There is issue with wrong displaying horde buildings in the hall interface but it shouldn’t be possible to be built horde building twice.
To build it second time, you need to have an upgraded dwelling first. But when you upgrade dwelling, you receive upgraded horde building for free and it is shown as built.


Hopefully fixed.

Partially reproducible (only a release version), hard to debug. I will investigate it further.

Not reproducible, works for me.
Can someone else check if this bug is occuring?
“obóz najemników” = “mercenary camp”
“młyn wodny” = “watermill”
“obozowisko” = “campfire” [IIRC]

Not reproducible, I don’t understand what do you mean by “needed resources” (0 creatures don’t need any resources). Can you priovide steps to reproduce this issue?

I think I may have reproduced this issue (or something similar). I got crash on leveling, when hero has all his skills expert of one on the expert level. This problem (less than two skills to choice in level up window) has been just fixed.
Btw instead of reinstalling H3, it should be enough to extract VCMI package into the new folder and provide it H3 files it use (Data/.lod and Data/.snd should be enough IIRC) and maps. Lod archives are not modified by VCMI in any way.

I think that he thought "I have no resources to buy any1 and have tried to buy 0, then crash"
I think that recruit button should be disabled during it’s set of 0 to buy

Yes, you are right. :slight_smile:

Best regards,

Well, it should be and maybe I’ll implement that but VCMI even more shouldn’t crash in such situations.

Not implemented, it’s huge feature (siege battles with its moats, walls, turrets, etc).

Hmm… I guess something else is still needed. I did the following:

  • Install H3C
  • Install WoG 3.58f + Script Update
  • Create empty VCMI folder in a different location
  • In the VCMI folder I created “Data” folder, in which I copied the 6 .lod files and the 2 .snd files from the H3+WoG folder
  • Copied “Maps” folder from H3+WoG into the VCMI folder
  • Unzip 0.7 into the VCMI folder
    Launching VCMI_client after that leads to a Visual C++ Runtime Library error. In case it helps identifying what else is missing, I attached here the log.

I know this is not very relevant for your testing, but it would be interesting if there would be an easier way to “reinstall” VCMI w/o having to reinstall the whole game. But if you think you can’t find an easy answer to this, I’ll just put the 0.7 in the main Heroes folder like before, and resume the testing [size=75](I wouldn’t have had more time for testing today anyway - big day tomorrow at job so I gotta prepare… cheers!)[/size] (677 Bytes)

Please, check if creating /Games subfolder fixes the problem. It’s not present in package and VCMI tries to scan it for savegames, it’s probably the reason of crash.

That was it. Thanks! :slight_smile:


I also ran into the same bug as dikamilo, however it’s unfortunately not reproducible. As it happened only once, I’m only 90% sure these were the steps leading to it:

  • I started a map with Castle on Impossible
  • Random resource given was gold (1000 I think)
  • I went in the town to recruit Pikemen (I think from Guardhouse, not Castle, but I’m not sure)
  • I pressed on “Maximum” and then “Recruit” and then I got a crash
    "Stupid" me, I forgot to save the log file or make a screenshot, but I rushed to try to reproduce it by restarting VCMI. But I wasn’t “lucky” anymore. Same map, same random resource start (until I got gold again), but no way to reproduce it. I’ll keep trying to reproduce it while doing other tests, but so far about 10 attempts failed.

Now, in regards to majaczek’s post, I would like to detail a bit what still needs to be improved in the Recruit screen: [size=75](Heroes 3 Complete capture)[/size]

#12 - Scroll bar functionality:

Should be disabled when no creatures available to recruit (regardless of player’s resources)
Should be disabled when not enough resources for at least 1 creature (gold or even special res. for high level creatures) - even if there are creatures available for recruiting
And just to confirmed it’s still hanging to the mouse cursor (as reported above by Steven, or earlier in 0.6x by me)

#13 - Maximum button:

Should be disabled when no creature available to recruit
Should be disabled when player does not have enough resources to buy at least 1 creature
When hovering the mouse over the enabled button, info text “Maximum” should be displayed in the bottom bar of the Recruit window (so no info text when the button is disabled)

#14 - Recruit button:

Should be initially disabled, when we open the Recruit window.
It should become available once we select at least 1 creature to recruit (by scroll bar or Maximum button).
If we move the scroll bar back to the extreme left, it should get disabled again.
(Basically it should be disabled at all times when the amount of creatures in “Recruit box” is “0”)
When hovering the mouse over the enabled button, info text “Recruit” should be displayed in the bottom bar of the Recruit window (so no info text when the button is disabled)

#15 - Cancel button:

When hovering the mouse over the button, info text “Cancel” should be displayed in the bottom bar of the Recruit window (as in the screen capture above). Cancel button should be always enabled, so no need of hiding info text in case of disabled button.


No issues with the three map locations for me, so it would be great if dikamilo could give more details (i.e.: are they always reproducible? or only on certain maps, or with certain heroes, maybe depending of the values they have for Primary Skills already?)

But while testing this, I found other bugs:

#16 - Hero is pretty badly centered, especially close to the edge of the map. In the screenshot below, it was not me scrolling the map so much to the edge, it’s how the map got auto-centered when I selected the hero:

#17 - In the same screenshot above, please see the incorrect path arrow next to the hero. IIRC that arrow was fixed at some point during 0.6x, but I see it’s back.

#18 - And the totally missing arrow I reported in 0.68 or 0.69:

H3C vs VCMI 0.7

#19 - Hero “walking over” other hero on a predefined path. This is not easily reproducible. I had it happening only 6 or 7 times out of about 20 attempts, and so far only with Mercenary Camp as destination, and only with diagonal or partly diagonal paths.

How to (try to) reproduce it:

1 - Move one hero 2 tiles away, on diagonal, from Mercenary Camp
2 - Set hero path to Mercenary camp
3 - Move second hero in the middle of the diagonal path of the first hero
4 - Select first hero and send him on the predefined path


  • It happens also for paths longer than 2 tiles, it just seemed there’s a higher probability on short paths, but I might be wrong
  • Maybe it works also with straight only paths, it just never happened to me (in all my attempts, at least the start or end of the path were in diagonal, when the bug occurred)
  • Could be that it’s not related to Mercenary Camp, but I had over 10 failed attempts to reproduce it with other destinations

EDIT: After fighting with the PrintScrn button while trying to reproduce the bug a few times, I finally managed to take a successful capture or the overlapping moment. In the case captured, it was a path starting on the diagonal, but the overlapping happened on the final straight line, as destination was Mercenary Camp just above (however the hero was coming from the diagonal):

#20 - This was already discussed for 0.68, but just a reminder to finish with the path issues: formula still needs to be improved, as we keep having very often the case that hero can still move 1 tile as per movement bar, but cannot execute that move on the diagonal (never the case in H3C).

Several bugs with the (combination of) selections in the Advanced Options screen:

H3C vs VCMI 0.7 [size=75](after changing starting town to Castle, then return to Random)[/size]

The screenshot is taken in the Advanced Options for the map Barbarian Breakout, but there are similar bugs with all other maps.

#21 - Left/right arrows are shown next to all icons, even if some options are blocked from being edited. For the blocked options, nothing happens if we click on the arrows, but arrows should not be there at all.

#22 - Starting hero for Red and Teal players should be Random, not None. Only after selecting a starting town for Red or Teal, the Starting Hero icon changes to Random. And it remains Random, even if I change the starting town back to Random (as I did for Red in the screenshot above).

#23 - The right arrow of the Starting Bonus does not work for some maps.

#24 - The Starting Bonuses available are often incomplete: sometimes only gold, sometimes only gold and artifact (even though town is selected), sometimes only gold and resource but no artifact, etc.

The available bonuses should be:
§ Gold and Artifact always!
§ **Resource **whenever a town has been selected:

  • Wood/Ore for Castle, Necropolis, Stronghold and Fortress
  • Mercury for Inferno and Conflux
  • Crystal for Rampart
  • Sulfur for Dungeon
  • Gems for Tower

#25 - The Starting Bonus gets reset every time we change the town. It should be only the Starting Hero being reset to Random.

The behavior of selected Bonus should be as follows:
§ Gold: can be selected at any time, even when no town is selected (i.e.: Random), and should not change when we change the town selection.
§ Artifact: can be selected at any time, even when no town is selected (i.e.: Random), and should not change when we change the town selection.
§ **Resource **can only be selected when a town is selected, but:

  • once a resource is selected, if we change town, the choice for Bonus Resource should remain - only thing to change, when the case, being the resource type, depending on the selected town
  • if we scroll left/right in the list of towns until we reach Random, only then Bonus Resource gets unselected, and we have Random Bonus again
  • the reset to Random Bonus is absolute - selecting a town again should not trigger the automatic selection of the resource (as it would happen if we would only switch between 2 towns while Bonus Resource is already selected).

These problems have been resolved shortly after 0.7 was released. Next version won’t have them.

Very strange, I’ll try to find why this happens.

Resolving this problem has been delayed. It’s on our TODO list but with low priority. Do you think it’s urgent?

Implemented, thanks for clear description. :slight_smile:

Fixed (bug affected only RoE maps where generating hero at main town wasn’t optional).

I’ve fixed it for fixed castles and no hero cases. I hope I’ll fix it for fixed hero case soon.

Starting bonus issues will be checked.

possible bug:
improper handling oneweek bonuses

in code last changed for oneweek appear oneday
(code for day 7 in changeset 710)