Map editor


#81

Uploaded alternate debug build “temp.txt” (see instruction in release notes). Was it helpful?


#82

Yeah it works now (with debug version from package).


#83

It seems to be impossible to start a game as a player without town.

Player main town / main hero are not saved.

It is impossible to edit secondary skills for hero (but let’s say it’s a missing feature).


#84

What happened when I put new spells into Pandora:

EDIT: nevermind, same happened when I deleted Pandora and just have spells mod enabled.


#85

So the problem is in graphics card drivers (also builtin windows opengl will not work on any os version - they are all crap) - package has software opengl lib from MESA.


#86

In pandora? Posiible, but absolutely non-intuitive :stuck_out_tongue: (It is grid editable with Insert-Delete)


#87

Just checked. It works for my red hero, but not the blue one:


#88

Not editable until “customize” checked - in this case there is visual bug - disabled grid is not grayed.

BTW. Pandora will use same reward format and gui as SeerHut. I do not like current version.


#89

I tell you.

Hero 1 - has seondary skills.

Hero 2 - has no secondary skills, checked or not. There is nothing I could click or edit. ALso it is reproductible since I loaded map today.
Unfortunatelly it uses a number of mods so you can’t open it easily.




#90
  1. empty grid is still editable - click grid, then press Insert
  2. empty default skills for new hero is a bug I`m working on now.

#91

Ahh, you meant Insert key - this is far from intuitive when there’s no “insert” text anywhere in the window :stuck_out_tongue:


#92

:slight_smile:


#93

New release 0.1.5

Special build #2 for testing features from PR 200

New features:

  • Heroes pool
  • New design of hero secondary skills
  • Incremental objects search

#94

Added Windows build with PR200 (and some other stuff like new templates) for everyone:

dropbox.com/s/fanxgbcf2v6zc … 0.rar?dl=0


#95

You can merge it with 0.1.5 editor (just ignore “gamepath.txt” & “zlib1.dll” zlib1 is just a copy vcmi one, gamepath.txt is not needed on windows if editor is in same folder).


#96

I tried to run map editor, but encountered a problem - main window just after appearing freezes completely, and tiles aren’t rendered at all. AFAIR previous version worked good for me.
editor.zip (703 Bytes)


#97

What about “loading progress” window?
Also screenshot will be good to see

upd. If previous version worked, try to remove shipped custom “opengl32.dll”


#98

Getting rid of that dll solved the problem on my side, thanks.

Loading progress was visible, just the main form froze after appearing. In attachment I marked area that wasn’t rendered at all.



#99

New release 0.1.6

Special build #3 for testing features from PR 200

Various fixes and improvements


#100

I have a problem with map I created, looks like editor has quite big memory leak during saving as a vmap file. Beside this rendering of all chests seems blinking.
VCMImap.h3m (68.5 KB)