0.73c - development version

Good news everyone! :wink:
New development build is ready. It brings many fixes and new features. We hope it’ll help us to fix most annoying issues before upcoming 0.74 release.

DOWNLOAD LINK: download.vcmi.eu_073c.7z

Some major changes (possibly introducing bugs) to be tested:

  • partially done sieges. Walls are present and blocking movement, turrets are shooting. Walls are destructible, though catapult and missile animation are not working. Please report crashbugs and misplaced wall parts.
  • redone stack order algorithm
  • redone stack queue. New queue graphics for high resolutions. Now ‘Q’ button toggles the queue. Thanks to Dru for the graphics!
  • improved pathfinder. It now supplies GUI with information about accessibility of tiles and cost of movement. That allowed implementation of most of adventure map cursors.
  • redone creature animation handling in battles.
  • creature banks

All things marked as 0.74 in spreadsheets.google.com/ccc?key= … pLe4raNAWA should be working.

Please also report misplaced battle obstacles and obstacles with wrong blockmap.

[size=150]KNOWN ISSUES[/size]
(follow the thread links for full descriptions)

Crossed out bugs are fixed (or most likely fixed) is SVN version.

0.73 [forum.vcmi.eu/t/vcmi-0-73-bug-reports/193/1)
#04 Crash when hitting F4 in 1600x1200 resolution - different than the F4 crash in lower resolutions reported before.
07 - Sound\Music level does not affect videos.
11 - Exchange between subterra gates does not working
12 - Graphic glitch: After receiving some long server messages (from previous bug) I’ve switched between 2 heroes. After these, only part of message disappeared.
#18 Bug towns without fort in map window are [after load] shown as town with fort.
#29 If hero has expert Air Magic, the Magic Arrow in Spell Book is shown with expert Earth Magic.
#31 Crah on missing entry in video.vid
#37 - Wrong Bloodlust animation (see screenshot - looks a bit like Hell Hydra’s self-healing, though still different somehow)
#48 - Monsters shadow isn’t drown where there is shadow+selection color
#54 - Start a map with Castle town and all buildings in it including the Grail. Right-click some building, like the Grail, and while the message is shown move the mouse off the building. With high probability you won’t be able to click on Castle building after that.
#55 - Spaces in the beginning of line in map description does not showing.
#63 No message about preventing spell casting during battle if you use “Orb of Inhibition”
#64 No info in status window if you collect guarded resources.
#68 - Incorrect display of the mouse cursor during enemy’s turn in battle (frozen shaded hex i/o mobile arrow)
#69 - Placing artifacts back in backpack (or swapping), if you have more than 5 artifacts there, does not put the artifact in one of the 5 visible slots where you clicked. You’ll need to scroll for it to see where it went.
#70 Creatures’ dwellings do not require FORT to be built if there is already built first lvl dwelling (except CASTLE town).
#71 Bug with sailing - boat can sail through the edge of the land, noticed before, but I thought it didn’t affect the game. Now it seems to be bug.
#75 - Minor issue: we can exit the client interface w/o scrolling the map if CTRL is pressed, but if we access any application while we are out (e.g.: open a screen capture tool), when we come back, even if CTRL is still pressed, the map scrolls when we pass over the Client edge (thus we lose focus on the exact image we wanted to capture for example).
#77 (minor discrepancy, perhaps intended so) In the same screenshots, we can see that VCMI capitalizes the first letter of the resource name, while H3 doesn’t. Personally I don’t have a problem with it, but perhaps the English natives on the forum can give their opinion whether that is or not an issue at all.
#78 Rampart Town Hall upgrade is missing some huts that should be added to the town screen: #79 If we build upgraded dwellings before the hoard structure, the graphical part of the hoard structure appears together with the upgraded dwelling:
#79 If we build upgraded dwellings before the hoard structure, the graphical part of the hoard structure appears together with the upgraded dwelling:
#80 - Build A New Ship screen issues:
#81 - Ships do not correspond to their alignments.
#82 - After a ship is built in town, we should not be able to re-open the Shipyard screen until the ship leaves the “harbor”.

0.72d [forum.vcmi.eu/t/vcmi-0-72d-development-version/190/1)
#1 Crash when trying to start the game selected by default on top of the list, after sorting the scenarios by map size:
#04 Small bug with battle screen. [size=75]it’s related to positions of obstacles so probably Ivan has fixed it[/size]
#06 saving settings for battle options, not implemented saving the setting of animation speed during the battle. And if you start new map also there is default switched on grids.
#09 Strange AI battle behavior:
#12 - In system options there is some problem with hints - it looks like VCMI can’t find appropriate text.
#14 - I can retreat my only hero from battle, even though I have no castle. Game continues, but freezes on pass turn command.
#15 Bug if you want to get into subterranean gate but hero movement is just finished.
#17 Bug if you free hero from prison it is shown in information screen as first hero from the list
#22 - The yellow & blue (when hover) glow animations for creatures in battle should not fade out completely.
#26 Flying creatures are flying *through the other creatures on the battlefield
#28 Wrong Battle Casualties reported:

0.72c [forum.vcmi.eu/t/vcmi-0-72c-development-version/182/1)
#3 Luck animation is too short and probably also too low.
#4 Animation sound for Fortune is not working yet.
#14 Identical with the above, the scroll arrows should also be disabled/grayed out in the Marketplace window, when the from/to resources are not selected yet.
#27 - Fairly minor, however a part of H3 functionality. When a hero picks up a resource pile, hero information does not return automatically after a little while (until you change to another hero or town then back to the original hero).
#28 - Sound does not play when picking up an artifact. Also no terrain music yet.
#29 Custom creature animation in battle does not work for the active stack (the one with the glowing yellow border around).
#36 Killing a stack of our own during its turn with a spell, leaves a ghost image of the stack on the battlefield: [size=75] fixed, or at least seems to be fixed[/size]
#41, because AI should try to go after the shooter or the flyer, unless the pikemen would be reachable in less number of turns)
#42 Monolith bug - you can block the monoliths.

0.72b [forum.vcmi.eu/t/vcmi-0-72b-development-version/181/1)
#11 Event message windows still don’t support large texts correctly
#15 Game crashes at first action taken after we press F4. We had F4 issues before, first in 0.68 (#4 - solved) and then 0.71#47 (which reported F4 issues when VCMI was running in parallel with H3, but this time we have issues even when only VCMI is running).

0.72 [forum.vcmi.eu/t/0-72-bugs-and-issues/170/1)
#10 morale animation shown on wrong place
#31 battle I don’t like that already found issue about haste/slow affection on battle movement order not yet fixed and add from my own : the queue (hotkey Q) shows even more strange info
#41 when message in ingame console is too long it overlaps the infobox, and when the message disappears infobox is not refreshed
#43 blue glowing border around selected creatures restarts every time when cursor moves (should be only on selecting creature)
#44 I see bug #47 from 0.71 reported problems caused by F4 when running both VCMI and H3.
#47 - bug with hero advancing
#48 - Target creature loses stack size box from the moment the enemy shoots at it, or even starts to walk/fly towards it:
#73 : AI doesn’t recognize the front hex of a 2-hex creature
#74 : Enemy creatures should have their hex shaded if they are within the attack range of the active creature (melee+range).
#76 the infobox remains frozen on the last frame of the new day animation

Bugs have been added to the Sourceforge tracker:
sourceforge.net/tracker/index.p … 9&status=1

As usual, please check if the list is correct. I removed some not reproducible, old bugs. If they appear again, please re-report them.


Thanks for the new build! :slight_smile:

#1 (Main Menu) Clicking on the L button when no L-maps in list crashes the game.


I reproduced it by removing also the XL maps from the Maps folder, so I guess it’s valid for all sizes. As the empty list is displayed just before the crash, I suspect it has sth to do with trying to default-select the first game in the list after the filter is applied.

Crash log attached.
2009-09-20_Select L when no L-maps.7z (79.9 KB)

Great news. Thx.

But is this possible to make sorting on vcmi status
i.e. If you choose to show only features implemented in 74 ver it shows nothing.

Zamolxis, link “Missing features & functionalities” in yours signature is not working because of double http at the begining

Fixed. With my browser (Chrome) I was having no issues opening the link as it was, so I didn’t notice it before. Thanks! :wink:

#2 - Only the Main Menu window is centered, not also the Adventure Map, which on higher resolutions goes out of the screen in the lower and right side.

I believe that’s what Warmonger was referring to when he asked to have the window centered after launch. As he mentioned the 1280x960 resolution, I guess he meant the map launch i/o client launch.

Anyway, it’s good we have the client centered in the beginning now, but we’ll also need the Adv.Map centered. However, as some of us may try at some point resolutions higher than what our screen supports, I guess the condition should be: “centered, but with the upper-left corner of the client not further than the upper-left corner of the screen”. :wink:

EDIT: It would be great if you’d manage to fix this for the next build. After a while it’s getting a bit annoying to have all maps starting 50% outside of the visible area (can’t even see the starting hero, or anything else of the right panel, before manually moving the client window).

The creature banks list goes as follows:

00 Cyclops Stockpile
01 Dwarven Treasury
02 Griffin Conservatory
03 Imp Cache
04 Medusa Stores
05 Naga Bank
06 Dragon Fly Hive
07 Shipwreck
08 Derelict Ship
09 Crypt
10 Dragon Utopia
11 Hunting Lodge
12 Snow-covered Grotto
13 Palace of Martial Spirit
14 Citadel of Pacification
15 Monastery of Magicians
16 Library of Legends
17 Transylvanian Tavern
18 Home of the Bat
19 Lost Bottle
20 Grotto
Without pyramid.

  • Pyramid :wink:

Config for WoG banks is not entirely handled.

Creature bank thread

Okay, I’m running unfortunately into quite a number of bugs, some a bit annoying, so I guess this calls for another dev version before 0.74. I’ll try to remember them all, as every time I restart to see if they are reproducible or take a better screenshot, I am noticing new bugs (so I hope I won’t lose track of some of them).

#3 - For heroes at town gate, if there is an object in front, they can leave diagonally, but I cannot set attack path without performing some other actions in between.

Load the VCMI_Tests map attached, pick treasure chest with Neela, but not the Scholar. Then try to attack Rissa. For me it is not possible. I have to either first leave the town, or pick the Scholar - only afterwards I can set attack path on Rissa. You can see in the screenshot that I can get out to the place where the chest was, but my mouse is on Rissa - and I was clicking on her, but the path was not changing:

EDIT: After further tests, I noticed that it’s may not be the obstacle in front of town (only), as if I select another hero, then Neela again, I am afterwards able to set attack path from the same position as the above screenshot.

And now most (if not all) other bugs can be reproduced by attacking Rissa following the above.

#4 - Not a bug per-se, but the way the new high-res stack queue toggle is implemented (screen re-center) is maybe not the most fortunate. When I saw the battlefield recentering after the first toggle, sth didn’t feel right. I pressed Q several times more and I almost got a bit dizzy by having the field and the creatures repositioning themselves every time (though the effect may be accentuated by the fact that the repositioning is not synchronized - see bugs below). Perhaps it would be better if the stack queue would just open on top, w/o having the battlefield changing its position.

EDIT: After some more tests, I realize the re-center may be have seemed necessary for x768 resolutions (& similar). But actually for anything above x800 resolutions there’s place enough, and for x768 there would also be place if we move the battlefield just a bit lower.

#5 - There are some minor graphic glitches in the upper area (“the sky”) of the battlefield background. Not sure if related to the implementation of the new stack queue:

But the bigger problem is the fact that disabling the new stack queue makes several battlefield objects to lose focus:

#6 - Disabling stack queue makes creatures lose focus. As seen above, all creatures get placed just above their hex.

#7 - If I hover over Spell Book, I get the “not accessible” mouse pointer, and the battlefield hex above gets shaded. However I can click on it to open the book.

#8 - Casting spell seems to be focused almost 1 hex below the actual hex of the creature, which means almost 2 hexes away from the place where the creature graphics is placed. In the screenshot above, I wanted to cast Lighting Bolt on the enemy Gremlins. I could not cast it on the creature, nor on the hex below it. Only when I went even lower, somewhere at the same level with the head of the enemy Gargoyle, I was able to hit the Gremlins with the spell.

#9 - The Lightning Bolt casted above had no animation.

#9b - Possibly related, in a different battle, casting Magic Arrow on a creature in the left side of the battlefield, generated the animation in the middle of the battlefield. So my guess is that spells may be totally out of focus on high resolutions (I play on 1440x900), which may be the reason why I didn’t see the Lightning Bolt at all above.

#10 - Going back to the battle with Rissa, just before (or after?) the Lightning Bolt I had pressed Wait for one of my creatures. As a result, after the Lightning Bolt, none of the creatures on the battlefield was selected. Toggling stack queue didn’t help either. I just tried to click somewhere to have something happening, but the game crashed. Crash logs attached. It seems it’s only reproducible if we use Wait+Cast combinations.


UPDATE/CORRECTION: Bug #10 is caused by the Cast+Wait combination (in that order, so not Wait+Cast like I said above).

I’ve also managed to reproduce #10 and do r-click on a creature w/o crash:
The bug still occurred - pressing Wait after Cast caused the Gargoyle to lose its turn w/o other creature getting that turn. Notice also the stack queue which disappeared when I right clicked on the Gargoyle (before the r-click it still showed it was its turn, even though no movement was allowed). The game crashed only when I tried to cast a second spell during the same turn. #10_New_Crash_Logs added.
2009-09-21_Cast+Wait+TryingToCastAgain.7z (97.5 KB)
2009-09-20_NoneSelectedAfterBolt+Crash.7z (2.61 KB)
2009-09-20_VCMI Tests.h3m.7z (9.82 KB)

And some other bugs:

#11 - In a different battle, Ice Bolt had no effect on the enemy creature, but it also made me lose the turn of my active creature. Not reproducible (I tried to recreated the situation with Aislinn in the attached map, but didn’t reoccur).

#12 - Wight’s regenaration animation taking place at the beginning of the battle with no reason, and in the wrong spot. In the attached map, it happens strangely only with Aislinn (attacking the Sprites or a hero), but not with Septienna attacking the Wraiths. Maybe because Wraiths have the 1st turn?

#12b - And related, in Septienna’s battle with the Wraiths, we can see our Wights regenerate also after being killed. I have the strong feeling this was reported somewhere, but I can’t find the log. If so, sorry for duplication. EDIT: Fount it. It was 0.73#74 , referring to Wraiths. Either the fix did not make it to the package, or it did not include the Wights.

#13 - Wight’s regenaration animation seems to have the wrong graphics (unless for some reason intended so?). In VCMI is greenish, in H3 it had transparent-blueish color.

#14 - Stacks killed in retaliation, fall down before the retaliation animation. Can be reproduced in Septienna’s battle with the Wraiths.

#15 - Spell book button not disabled after spell cast (for the remaining of the turn) or if hero has no spell book. Here again I have the feeling this was reported and IIRC even solved at some point, but I can’t remember where (I searched for it, but maybe I used the wrong keywords :p)
2nd VCMI Tests.7z (9.88 KB)

Fixed. Paths info was updated only on hero move and switching heroes, not after just removing (picking) object.

I tried making queue simply popping up at the top of battle window but that didn’t look good for me. Either the window seemed to be too high when the queue was open or too low when it was disabled. So I’ve decided to keep it centered.
Unfortunately it was last minute change and I didn’t tested it enough. We’ll see how it looks without all these bugs in the next build.

It’s not related. Fixed.


After changing a bit the map above to check sth about Wraiths, I found another big bug (see 3rd VCMI Tests map):

#16 - 2nd Wait command on a creature during a turn is handled badly.

To reproduce:

  • Load 3rd VCMI Tests map attached and attack with Septienna
  • Watch the 6 funny regeneration animations at battle start :stuck_out_tongue: (if you don’t get 6 like me, then it gets even more interesting as further investigation is needed)
  • Wait on Bone Dragon & Black Knight
  • Attack Wraiths (which meanwhile came close) with your Wraith & Wight, then move Walking Dead
  • Wait on Black Knight, then Wait on Bone Dragon, Wait on Bone Dragon, Wait on Bone Dragon, Wait on Bone Dragon, Wait on Bone Dragon,… (if you reproduce it, you’ll see what I mean) :smiley:
  • Then move Bone Dragon 1 hex, and watch it remain stuck in flying animation, while the Wraiths fly in and attack it (this being the 2nd part of the bug).

Hopefully all the above are easily reproducible. This could be related to the #10 Wait+Cast bug reported above.
3rd VCMI Tests.7z (9.9 KB)

There is a critical bug in AI that makes impossible to end the turn.
(My fault, I’ve incompetently tried to block its adventurous part.)
To avoid this problem, please put this file into you AI/ subfolder: download.antypika.aplus.pl/GeniusAI.dll
I’ve also updated the package on the server, so if you downloaded build after this post was published, you don’t have to do anything.

Sorry for trouble.

Yep. That was it. The more I play, the more I run into more situations like this: :slight_smile:

http://i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/090920_KeyToVictory.jpg [size=75](after hero just picked up a resource pile in front of the wood)[/size]

We have a “leftover” of bug 0.71b#25 (pain sound in battle after game load). As its behavior has been restricted and the SourceForge item closed as fixed, I’m gonna raise it as new bug:

#17 - After game load, we have the same pain sound in battles after the casting of any damage spell.

and in general:

#18 - After game load, it seems we lose all creature sounds during battles (moving, attacking…)

#19 - In Hero Meeting window, when we click on the Catapult, it should give the pop-up saying “This item can’t be traded.” In 0.73c we get the same info pop-up that we would get in the Hero screen: “The Catapult must be equipped.”

#20 - War Machines can’t be exchanged yet (this sounds familiar, so apologies if it was already reported)

#21 - There is small delay in passing an artifact from one hero to another, in the sense that it first appears in the new slot and only a moment later it actually disappears from the original slot. And it has the same effect on the related bonuses. E.g.: in any of the VCMI_Tests maps attached above, take Sir Mullich to meet with Neela. And have him pass the Badge of Courage to her. You’ll see she gets it immediately, together with the morale bonus, but only half a second later the badge icon disappears from Sir Mullich’s slot, together with the morale bonus.

#22 - Closing Main Menu client from the upper right window button or with Alt+F4 leads to a crash:


Crash logs attached:
2009-09-21_ClosingMainMenu.7z (79.7 KB)



SO ! BUGS in 73c :::::

#23-SERIOUS if u move horse/boat cursor out of map(broun textured field) and click - game crashes - it could be a pathfinder outofrange wrong check (i`ve checked with 73 - no such problem, so probably a cursor-implementation bug)
#24 very wrong estimated damage in battle - 4 titans - 16-32est and vs 6harpies done 446 dam, 6 archers - 117-176est and done 13 dam vs 6 harpies second round - 4 titans - vs harpies - 15-30 est and done 476dam 49gargoyles vs harpies 0-0 est !!!
#25 wrong creature fight order - now in siege - first round catapult had no turn(or it could be it’s the last one - speed 0, however in H3 it shoots before all creatures) and first turn was gargoyles’ and second - titans’ : in queue is shown - second round - first(or last in 1st round) - catapult then titans then gargoyles, but when it started all was again like in 1st round
#26 probably not yet implemented - Native Terrain(NT) in siege - gives bonuses for creatures to which NT of town is native(ie centaurs get bonuses when fighting in Castle siege) and this hapens irregardless where the town is located - rampart on swamp land in siege will have grass: my siege vs necropolis was not on dirt (necro NT) and necro creatures haven’t bonuses , but castle creatures had bonus when was a siege of Castle which was staying(trigger yellow point) on grass
#27 AI doesn’t evaluates wall in siege and melee fighters just stand in castle, but it is not yet implemented, i feel

#28 Map scrolling not working anymore if hero is selected. CTRL+Arrows move hero should scroll the adv. map. In 073 was ok.
If town is selected it works but very strange. (once I got crash but without dmp file).

#29 Refer to sound problems. There is also problem when you push NEW GAME, after first start it has long pause an multiple sound effects, other time is ok, and other there is no sound at all. *

*[size=75]I added a log number, because from your description it seems to be different than previous sound related bugs. When uncertain, I guess it’s safer to give a log number. Better to have a dupe than not to have a tracing log #. :wink:


That fix is both in the package and include Wights. It just does not include animation (it prevent only from adding health points, I haven’t tested it before claiming the success because the fix was very small, obvious and seemed to be enough [additional condition for being alive before applying regeneration]). Now it’s fully fixed.

Probably fixed (damage was calculated for different stacks), or at least more accurate. If it reoccurs in future releases, please re-report.

#30 Game crashes when attacking Creature Bank. Debugger points BattleQueue.

pos.h = bg->h;

EDIT: Actually it happens also when engaging neutral stack, so I guess the problem may be general.

#31 Pathfinder can’t find a way if the road is blocked by Event. Previously it did.


#33 - The Capitol of the conquered town is not destroyed if we already have one.

This is also related to 0.72#2 - Multiple Capitols allowed if set up from MapEditor. As H3 had the “1 Capitol per player” rule, I’ve posted some suggestions on how to handle possible fixes for both 0.72#2 & 0.73c#32 HERE.

On the other hand, I strongly support keeping the possibility of having more Capitols (through conquering or Map Editor) as a mod because, well, I could always use more money… :smiley:

The Imps not attacking Gnolls may or may not be related to a bug reported some time ago, regarding AI not attacking the creature placed just in front of it (though I can’t find that report right now). To be investigated - and we can keep this 0.73c#32 referring mainly to that.

The other two are however general, and it would be nice if they can be solved soon (one because it’s pending for quite some time, and the other because it’s kind of annoying and was introduced only now with 0.73c):

  • Quantity of units wrong placed / unreadable. This was reported long ago as 0.7#71 and is now the oldest logged item in SourceForge. I’ve posted a detailed description of how these stack boxes should be displayed at the bottom of my post HERE.

  • Endless wait. This must be strongly related to 0.73c#16. I guess you just discovered a loop between 2 creatures of the same speed, while I had it only for 1 creature. That means it impacts all of the same highest speed creatures from our army.