VCMI for Android


#301

HarryPhoon,
Thanks, it works as you described.

Fay, SXX,
no new auto builds any more? :cry:


#302

I’ll work on restoring builds once I finish with our internal code formatting changes.


#303

SXX,
No problem,
Thanks!


#304

The xyz install helper page is down and in-app instructions fail to help me launch. Anyone mind helping me?
I just copied the whole game directory from pc to phone in the folder that the app suggested. App can’t find “Data”, it says.


#305

Managed to start the app now. When choosing SD card as file location, the app search on internal storage/Android instead.
However the app now crash whenever I try to start a game. Loading screen kills the app.


#306

What version of HoMM3 do you have?? If the app loads fine now then there has to be something with the data.


#307

Homm3 complete,without vcmi or wog.
However while it might be the data files, I find it odd that the app creates files in the wrong folder


#308

Can you upload logs from VCMI?? They should be stored vcmi-data/cache.

What do you mean by this??


#309

Logs are uploaded below.
By “this” i mean: When i start the app, i can chose “Data installation location” as internal storage, SD card, or specified dir. From what i gather: When chosing SD card in the app, launching the app creates files NOT on the SD card but on the internal storage (directory: int.storage/android/data/is.xyz.vcmi/files). When chosing internal storage no files are created anywhere, and i haven’t tried specifying directory.

My phone is Samsung S7, and my Heroes 3 files are directly downloaded from Gog.com.
I’ve not tried using wog files.
Seems like i’ve got the same problem & phone as Octavion0223.
VCMI_Client_log.txt (75.6 KB)


#310

That’s the old app (the one on google play) and not the updated one ( builds.vcmi.download/branch/develop/Android/ ). The current version of app writes data to <external storage*>/vcmi-data/

  • (where “external storage” is whatever system returns as “external storage directory”, so either actual sdcard, or internal memory if sdcard isn’t available)

#311

Thanks! I chose the newest of the four links there, it wrote to internal storage but that’s no problem for me.
This new app works fine - I’ve managed to sucessfully start a game, so for now, I’m more than happy:)


#312

Alright so I’ve tried a few games with the newest app version and found some bugs, don’t know if they are new or well known stuff for you guys:

  • Random map templates fail to create 5 player maps.
  • all random 4 player maps include 3 towns in starting areas and an enormous amount of monsters between regions
  • war Machine are off: catapult is an artifact you conquer from rival heroes and first aid tent and ballista are units in the army. Visiting the blacksmith causes the app to crash
  • There are no “space” button for revisiting places
    I’ll keep posting bugs here if it’s to any help :slight_smile:

#313

This is weird. It’s means that assets are still using “config” from older VCMI version.

Is “python3.5 ./update_internal_assets.py” failed to do it’s thing?


#314

Don’t know how to check that


#315

Don’t worry about that. I shouldn’t be quoting your post.

It’s was message to @Fay.


#316

Not sure exactly what could cause it, but config in the apk should be the most recent (the last config change that I can see is BLACK_MARKET_MONTHLY_ARTIFACTS_CHANGE in defaultMods and it is correctly included in apk).
(btw, it’s possible to easily check what configs/mods are inside apk: unzip apk file -> open “assets” -> unpack internalData.zip -> profit)

The one thing that could be a problem here is the data migration from xyz’s version. I haven’t tested it a lot so maybe config gets migrated and skips update from internal zip file.

@Damodred If that’s the case, unistalling->reinstalling the app should help (or system settings -> about vcmi -> “clear data”).


#317

Didn’t understand that asset/apk file stuff but that wasnt ment for me?
Before I installed the newest version, I uninstalled the xyz version, and then I moved the game directory from pc to phone so I think it shouldn’t be any cross over data from the old version.


#318

Hey guys. Really appreciate what you are doing. Thanks for your efforts.

I’ve just installed for the first time vcmi from the link below, version of 22 jul.
builds.vcmi.download/branch/develop/Android/
I placed h3 files in local vcmi-data directory, the launcher has some problems with mods (which I have none installed), as I see some JSON parsing errors with mods.
When I press “Start VCMI”, screen blanks off for a sec, then brings me back to launcher screen.

Any ideas what could go wrong? Maybe my fault in configuring vcmi?
Screenshots are here imgur.com
VCMI_launcher.log.txt (2.77 KB)
VCMI_Client_log.txt (7.44 KB)


#319

burunduchok

That is normal at the moment. Normally that button should work as a shortcut to download mods. Or something like that. If there was some problem with mods it should appear at the top of the mod list.
Still not sure why it doesn’t start.

Fay
There’s some reference to xyz’s VCMI in the launcher log burunduchok provided.


#320

It’s weird, both logfiles look correct… no idea why the game doesn’t start. Mayybe there’s some problem/crash that’s not caught by launcher (it should save crashes to the logfile; I’ll try to check if it actually does).

This is okay. We changed app package (id) to is.xyz.vcmi so that we can update existing google play app at some point (it needs both the same package and signing certificate).