VCMI for Android


#281

Sorry, I tried to merge some of the CMake projects locally, but failed. Still unsure why it’s fail to build now because I added CAndroidVMHelper into the main CMakeLists.txt of our lib. :frowning: .


#282

I don’t really understand git and Travis but to me it seems unnecessary to use submodules as a way to update VCMI for daily builds. Wouldn’t it be better to update the repository itself?? And shouldn’t be the submodule present in the vcmi-android first so that Travis can update it?? Just a rough guess.

Edit: Nah, I’m blind. The submodule is present. No idea why it gives error.


#283

It’s gives error simply because I broke it. I tried to actually merge some of Android build configuration into our main CMake files, but failed.

Once I find time to install everything needed for Android build to my own machine I’ll fix it one way or another.


#284

Hi there ! How can i play expansion WOG on VCMI for android ? I can’t find WOG mod folder anywhere to put it on android.


#285

I think you have to install it first on your PC and then copy the data into vcmi-data folder in android.


#286

Sorry, I don’t really have time for development recently. I try to read this topic periodically though.

Wow, that really looks strange. That definitely didn’t happen for me. At the moment I’m not sure how it’s possible, but I’ll check when I’m able to.

Hmm, okay. I might need to check what I can actually do with SDLs keyboard handling.
I think that the ability to show/hide keyboard is a feature of your keyboard app (that shows up when suggestions are displayed(?)). I don’t have anything like this in the default google keyboard.

After a quick check – I don’t get why it has problems during linking, but after adding VCMI_ANDROID define in both lib.cmake and SDL_android_main.cpp, the project complied on my side. (probably some problems with the order of file including?)

Yeah, vcmi on android generally tries to follow the same folder structure as the desktop one – mods can be copied from desktop version to /vcmi-data/Mods/ and then enabled via mods menu in launcher.


#287

Nope. Not possible to enable mods via the launcher. I have like 5-6 mods in it. Doesn’t show up in the launcher at all


#288

Well, in that case I need more info, because it definitely should work. Launcher checks for /vcmi-data/Mods//mod.json existence to determine if that’s a valid mod. If you confirm that mods are placed correctly on your device, then I’d love to see the launcher logs (/vcmi-data/cache/VCMI_launcher.log) after opening mods screen.


#289

Here you go
VCMI_launcher.7z (1.28 KB)





#290

Something is definitely wrong, because it should display vcmi essential files as an entry in mods list (even if you don’t have any actual mods added). So, as I said, launcher logs would be appreciated, because I can’t really say anything specific what goes wrong without details.


#291

Here is a zip for the cache
cache.zip (360 KB)


#292

According to the vcmi_launcher.log the problem is caused by the New Old Commanders mod. Try to put it away and try again. I don’t use that much mods but the same thing caused me Resourceful AI mod. You have to move away the “bad” mods and then the rest will show up. But I don’t know why is it caused.


#293

As error shows - it is caused by invalid JSON file that belongs to particular mod.


#294

Yeah, that mod’s mod.json is not valid (extra comma near the end; removing the mod or the comma should help). I guess vcmi itself uses some less strict json parser and ignores these errors.
On the other hand, I probably shouldn’t abort everything when single mod wasn’t parsed correctly. :stuck_out_tongue:


#295

Yeah - VCMI JSON parser is not too strict. I think the best way would be to display mod that causes problem and mark it with some error icon or whatever. If you do not display faulty mod at all then people may think that they install it incorrectly etc.


#296

So, the problem is with additional commas in json files? Ok, I can upload fixed version at mod wiki site. Now are two broken mods for android: New Old Commanders and Resourceful AI mod. I removed two commas from them - tell me, please, if everything is ok now.
New Old Commanders:
www102.zippyshare.com/v/7OklzkBA/file.html
Resourcefull AI mod:
www102.zippyshare.com/v/gB13xmuG/file.html


#297

Both seem fine now. imgur.com/a/F9qFa. Thanks for the fix.


#298

Fay,
Is it possible to make some mouse right click? Long tap for example.

I have one save that crash in Android 6 after auto-battle and manual battle, but don’t crash auto-battle and crash manual battle in Android 7 & PC (Ubuntu).
Android 6 - youtu.be/pV1LRh6ELhg
Android 7 - youtu.be/UBAIezJkn8A
Autosave_4.7z (345 KB)


#299

Sorry for asking a question that has surely been asked before but I can’t find the answer and I really want to play D:

I can launch the game and the menus function perfectly. But whenever I attempt to start a scenario, random map, or campaign map it crashes during the loading screen. I have a Galaxy S7, Wat do?


#300

SkyRE,
there should be right click already. At least on my device it works in touch mode (or with swipe). You have to hold two fingers (the first one on the object and the second one elsewhere).

octavion0223,
Not really sure about that. I would try to copy in the game data once again, check that core mods are allowed and that should be it. I think it could be caused by the game data. Give it a try :slight_smile: