VCMI for Android


#321

Maybe the crash is caused by insufficient RAM. Saw something like that on my girlfriend’s 1GB phone when I tried to run Kodi.
gsmarena.com/lenovo_tab3_7-7951.php

EDIT: burunduchok
Could you try to free your RAM as much as possible and then try to run the game??


#322

Just tried to re-download heroes3 files from another source.
Also freed RAM, as HarryPhoon suggested. Unfortunately, nothing changed as result.
Black screen just for a moment, and back to launcher menu.
Nothing new in logs, imo.



VCMI_launcher.log.txt (4.37 KB)
VCMI_Client_log.txt (7.29 KB)


#323

One more thing with the launcher: when I select screen resolution (1024x600), then press “Start VCMI”, after a glitch it returns back to 800x600. Even if I explicitly write in settings.json the desired resolution, after “Start VCMI” it’s back to 800x600, also rewritten settings.json.


#324

The thing with resolution happens even to me but that should be caused by faulty VCMI core mods. You can also try to download the latest version (the 23 July version) to make sure it happens in both versions. If the problem persists than you can I think just wait. Maybe Fay will find the solution.


#325

HarryPhoon, Yes, today i’ve installed latest version, everything the same.


#326

** burunduchok**
Try to download this file and put the mods into the Mods folder. It should fix your resolution problem.
dropbox.com/sh/fwor43x5xrgz … s/vcmi.zip


#327

HarryPhoon, Thank you, resolution selection box works just fine for me now.
Is there a possibility to turn on “very verbose” debug mode in VCMI, to find why it can’t go further?


#328

Maybe adding this node to settings.json will work:

"logging" : {
		"console" : {
			"threshold" : "debug"
				}
		}

#329

Fay,
I would like to point out few things that are in my opinion urgent right now for android-vcmi.
When the VCMI app is installed it doesn’t come with mod for different resolutions. I think even the additional ability sprites for units are missing but not so sure about that right now. They should be provided already in the apk or there should be at least some links to the files.

In-game session could be made a bit more pleasant. First of all the app doesn’t support fullscreen. If there should be a back arrow it could be implemented as a floating button somewhere in a corner.
And when the chosen resolution doesn’t fill entire screen then the artifacts could be covered by a single coloured layer or some kind of sprite so that it doesn’t look so bad.

Thank you :slight_smile:


#330

All latest builds crashing after battle end in companies.


#331

I have the same problem. Also I have constant crash when entering the tavern. Sometimes when the quick combat is on everything goes fine, but sometimes I have crash.


#332

maybe vcmi config folder is outdated on android… i would try using one from recent windows daily build


#333

Very interesting. I have a bug of battle on the windows build too. But the tavern works correctly.


#334

I can not run the game in the last builds. The message “Could not find or extract vcmi data from app resources” comes out. But the files in the “/data/data/is.xyz.vcmi/files/vcmi-data/” directory exist.
P.S. Is solved. There were incorrect file permissions. But crash in tavern and after combat remained.


#335

running on arm exynos and with elevated previleges with the symptom of crashing at the end of the first fight.

impressive though i just was so excited it even worked. Like exult and ultima vcmi look sjust as promising simply amazing great job i dont think its that neeeded on arm or anything but a big thread such as this may be otherwise.

though. vcmi is an amazing client thanks


#336

I experienced that the AI never buyed creature dwellings. Was on an 8 player map. is that a well known bug? Got some error messages on AI turns: “player was 2 expected 3” or something like that.


#337

Damodred
That probably isn’t related to this thread but to the official developement.


#338

What’s going on with dailies for Android? Haven’t been updated since August 13th


#339

It’s build system need to be adjusted for current CMake configuration since I changed many things here. I’ll certainly try to integrate Android builds into upstream code one day, but so far I didn’t have time for that.


#340

Wow, a lot has changed on the forums.

Do you want me to look into failing android builds?