VCMI 0.97 released

OKay, it was reproduced with ban_mod from my topic. In earlier builds these error was absent. And it occurs on test maps only, RMG works without std towns.

But if I disable ban_mod, I still got a crash (these maps worked in previous versions).
I upload these maps with the screenshot of error.
It is reproducible not only my mods, HOTA mod Cove also crashes game during load.
Just enable Cove and run this map.

Seems like something is broken.

And forgot to ask:
Fly (and Flying Ability) is still disabled and not working. Is someone forgot to turn it on? Or this is because its still not finished? (29.4 KB)


I was thinking about ressurecting that thread when I’ve found upscaling mentioned in the changelog about two weeks ago.

How to turn it off?
Or fix this bug

If any files are missing, they should be printed out in console. Please submit report here.

Is Ubuntu PPA still supported? It seems there is no update yet.

If You want to “fix” that bug (or rather I should call it lack if some graphic files), You simply download these files I’m including to “Mods\vcmi\Data\stackWindow” folder.

Btw. sorry for including these files directly, because I don’t quite know if I’m acting against law. If yes, please edit my post :wink:

You are trying to tell me there are some missing files in the package? 10 days after 0.96c? Great.

VCMI 0.97 Package updated. Please try new creature window now.

Files restored in git.

Don’t be worried :wink: Please notice that those two files are required only by WoG mod, but even if You would put them into proper WoG directory, VCMI wouldn’t see them, so instead You have to put them in main VCMI data folder, which is (in my opinion) incorrect, because those two files shouldn’t be there anyway…

This is not true. You don`t need WoG mod to use WoGs features in engine such as stack artefacts and creature experience.

Ah, so You’re putting it this way… Ok :wink:

Is this … n_on_Linux still actual?
vcmibuilder seems to not have options --vcmi --wog and --downoad

That page was not updated for new release. Will try to do all these release-related in a day or two.

As of 0.97 VCMI no longer needs any of these options so they were removed from vcmibuilder. WoG can be installed from Launcher and “vcmi core files” can be found here: … s/
(will upload as mods into repository soon)


How can I install this?
When I launch VCMI_launcher I get an error in the console: Failed to open file C:…\modSettings.json. I think that might be caused by the special characters (á) in my Windows user name…

Also I have the GOG version of Heroes 3 Complete.

Yes, it might be the case. For sanity use only latin characters for username account. Please let us know it it fixed the problem.

Congratulations, good job! But can you make Debian package and update links, please? On wiki page there are still only for 0.96 version.

vcmi 0.97 is now present in debian unstable (

…however those builds won’t work with current Debian Stable.

I encountered some issues with compilation of new packages - Debian uses too old version of libboost. I’ll try to fix compilation and build packages on weekend. Sorry for delay.

Updated main page header - we now have much more to be proud of :wink: