VCMI 0.73 - Bug reports

This map was “Free for all” but the map kind isn’t important. This bug is on every map.
If you start any new map mostly everything is ok, but if you load any save all towns are shown as Castles.
You can load my test map autosave. All cities except player Tower should be towns (without fort).
test map (88.1 KB)

OK, got it. It’s a saving issue.
I often miss them, since I usually make tests on the freshly started game.

apropos accumulating creatures (and guards): could you do the engine support this but need a change in config file (only) - it would be one of first implemented wog hardcoded features. also nice would be ability to change the time avaliblence of objects (like in the WOG script make some OncePerHero objects to be visitable them once per month per hero)

I Know - it’s a feature request but the first part is binded with bug - which could turn into feature


Fixed / implemented.


Not reproducible for me, such bug can be caused by non-english game files. Are you using non-english version of the game? Does extracting English files ( )to the Data/ Subfolder fixes the issue?

It is a original game graphic that was not used in H3. It does nothing, I’ve restored it for “flavour”.


Probably fixed.

It’s a matter of changing between ‘=’ and ‘+=’ in the code handling dwellings. When support for hard-coded options will be developed, it should be easy to provide.

#76 Gold piles with size predefined in MapEditor are not multiplied by x100 in game (see the resource piles next to Sir Mullich in the attached map):

VCMI: vs H3:

#77 (minor discrepancy, perhaps intended so) In the same screenshots, we can see that VCMI capitalizes the first letter of the resource name, while H3 doesn’t. Personally I don’t have a problem with it, but perhaps the English natives on the forum can give their opinion whether that is or not an issue at all.

[size=75]And I also posted an enhancement suggestion for the text displayed in these info messages here[/size].
VCMI Tests.h3m (9.61 KB)


That was fast! :smiley:

And two more bugs that can be easily reproduced by loading the VCMI_Tests.h3m attached to my post above:

#78 Rampart Town Hall upgrade is missing some huts that should be added to the town screen:

VCMI: vs H3:

[size=75](I suspect this is similar to #34 reported by pHOMM, indicating various town screen elements not included in some upgrades…)[/size]

#79 If we build upgraded dwellings before the hoard structure, the graphical part of the hoard structure appears together with the upgraded dwelling:

  • Upg. Griffin Tower comes with Griffin Bastion
  • Upg. Dwarf Cottage comes with Miner’s Guild
  • Upg. Dendroid Arches comes with Dendroid Saplings
  • …and so on. I haven’t tested them all, but I suspect it’s general.

The other way around we don’t have an issue - building hoard building first does not build upg. dwelling as well.

[size=75](I’m pretty sure this is the cause of the bug reported by majaczek as 0.72#1, which was not kept in the logs - I guess because it was not clear how to reproduce it)[/size]

Some Shipyard related bugs / issues which can be easily reproduced by loading the same VCMI Tests map attached few posts above:

I’m going to give this a log number, as 0.72d#10 was reporting something different, and use this occasion to report all related issues.

#80 - Build A New Ship screen issues:

VCMI: vs H3:

#80.1 - Screen title is wrong (reported by Boulie above), including wrong font size and color

#80.2 - Screen subtitles are displayed in the Town screen i/o Build Ship screen

#80.3 - Buy Ship button is missing the yellow frame in the lower part

#80.4 - The window is missing the Shadow effect in the lower and right side (more a missing feature, but with the screenshot above, it was better to report it here)

#80.5 - Resource cost for ships not yet showing (another missing feature, also reported by Ivan as bug 0.72d#10)

#80.6 - “Resource cost” text is displayed in a different font color (I guess the original H3 one is better…)

« »
#81 - Ships do not correspond to their alignments.

In VCMI all Build Ship screens display the same boat, and the built boats are the same. However H3 has 3 different boats:

#81.1 - The “default” Ship. It’s the one that we have now in VCMI. This is the default H3 boat that we should be getting at Castle and from the Adv.Map Shipyards.

#81.2 - The “Ghost” Ship, which should be given at Necropolis:

#81.3 - And the Vessel (or Craft?), which should be given at Fortress:


a) Conflux did not come with a ship of its own. The Shipyard screen was showing the Necro Ship, after buying it the Castle Ship was popping on the Adventure Map, while the cartoonish ship that was created in the town screen looked nothing like either of the two. As that didn’t make much sense (one of the rushed elements of the AB release), I guess in VCMI we need to make a decision on it. The Necro ship definitely has no place there (it looks like either a Ghost ship, or else a burned out ship, which could also suit Inferno or Dungeon at best, but that’s it). So the choice is between the Castle and the Fortress ship. The Castle one would be okay, unless we want to associate the 3 ships with the 3 alignment groups - Good/Evil/Neutral - in which case Conflux should get the same boat as Fortress. Or else design a new ship tailored for the alignment. :slight_smile: But that’s already modding I guess. :stuck_out_tongue: :question:

b) Summon Boat. I ran some tests in H3, and the spell does not seem to be associate with hero’s alignment: hero summons always the closest empty boat and if no boat on the map, then they summon the Ghost Ship (I guess it somehow makes sense as it’s summoned out of nowhere). This is FYI - I guess we can still decide if we want to associate boats with alignments or not. In case we would, when no boats on the map (or 2 equally far), heroes would summon a certain preferred boat. But that’s just an idea, we can also leave things like in H3 from this perspective.

c) H3 was providing the same boat type (Castle) on the Adventure Map for all town shipyards. So even if Necro & Fortress were displaying their boats in the Buy Ship screen, after exiting town, the Castle ship was in front of it. This was IMO a minor bug in H3, and not an intended feature, so I don’t think we need to repeat in VCMI. But same as the other points, I guess this is a decision for the devs.

[If anybody has other info regarding NWC’s further purposes for the 3 boat types, please share]

« »
#82 - After a ship is built in town, we should not be able to re-open the Shipyard screen until the ship leaves the “harbor”.

So after we buy the ship, it appears in the town screen and in the default place in front of the town. Going in and out the town as long as the ship does not move from that spot should not change anything: ship would still show in the town screen and we shouldn’t be able to open the Shipyard window. Once the ship moves (hero boards & leaves, summoned or scuttled), the ship disappears from the town screen and we should be able to open Shipyard window again to buy a new boat.

#82b - Possible H3 bug: In H3, when there was a boat in town, clicking on Shipyard was doing nothing (no error msg of any kind, not even in the subtitle bar).
SUGGESTION: I believe in-town shipyards should behave exactly like Adventure Map shipyards when a boat is blocking them, that is to display the pop-up saying “Cannot build another boat”

« »
#83 - The in-town boat at Castle is missing its lower half in VCMI:

VCMI: vs H3:

« »
And just to complete the list of all other ship(yard)-related problems, we also have from previous reports:

0.72d#11 - Heroes on coast cannot interact with heroes in ship (also reported as 0.73#47)
0.72d#13 - Ships built in town are not placed on the coast, but 1 tile further in the water (hence unaccessible)
AdvMap Shipyard incorrect functionality - reported as missing feature #71 - full description of desired behavior HERE.

I actually prefer a slightly modified accumulation option where creatures don’t accumulate until the dwelling is captured by someone (and if the owning player is vanquished and the dwelling goes unowned again, it stops accumulating). This makes for more balanced game play while still giving the main benefits of creature accumulation (you aren’t forced to visit an external dwelling you own every week to pick up the creatures or lose them).

I know this is really a future mod or script behavior but just thought I’d mention it anyway. :slight_smile:

(The script to make accumulating dwellings behave this way exists but I think it was another post-3.58f script that was unfortunately never released to the general public.)

Grammatically, it shouldn’t be captialised. However, I actually prefer the way it looks with caps (based on that screenshot). So personally, I don’t think it’s a big deal either way. :slight_smile:

These have been fixed in the development version. Screenshot


Fixed or at least much improved thanks to Ivan :slight_smile:


That and most of other issues with creatures animations during battles have been most probably fixed by Tow Dragon.

#84 Reproductible error when killing last stack of Cyclops in Stockpile, debugger points this line:

On the other hand, once they work again, it would be nice if InfoWindow displayed its components in two equal rows if their amount exceeds 5.

Not reproducible for me.


AFAIR fixed


The code responsible for creature animations in battles has been completely reorganized. If this is still present, it has completely different cause (think of it as if it were fixed).

Perhaps again one of those bugs that occurs only after loading a game? :slight_smile:

EDIT: Anyway, it seems to be from a dev version only, as I tried it in 0.73 (to see if it’s reproducible) and Cyclop’s Stockpile is not supported yet. Like this I actually also noticed it’s missing from the vcmi-status sheets in GoogleDocs, together with other similar map objects. // EDIT2: Hmm… or is it simply included in the “Creature Banks” category? :stuck_out_tongue:


Hi GrayFace,

I know it’s long time since your report on this, but should you still visit this place in order to notice this, could you please explain what is the actual bug you’d like to point out? I see the creatures have in battle a shadow and, when the case, a yellow glow selection frame. I see a discrepancy in the way the yellow glow behaves, but I don’t see a discrepancy between H3 and VCMI in regards to the shade.

I guess I’m either missing something, or else this has been fixed in the meantime, as part of some changes not triggered by this bug report.

But if this is still an issue, it’d be better if it’s clarified. Feel free to answer here or on the bugtracker.


EDIT: Please disregard. I got a msg from GrayFace clarifying what the bug is about. I’ll prepare some screenshots and upload them on Mantis.