VCMI 0.99 released

“Mods” directory of vcmi mod is duplicated as a “mod”:

Содержимое папки … \vcmi-099\Mods\vcmi\Mods

12.03.2015 14:46 bonusIcons
01.08.2015 16:45 defaultTemplates
12.03.2015 14:46 extraResolutions
01.08.2015 16:45 Mods

Vcmi map icon (“ScSelC.json” + “mapFormatIcons” directory) is missing.

I didn’t quite follow this, could you point me to it?

Console warnings at launcher start. Present in 0.98f, not present in daily builds.



These files are in git.

github.com/vcmi/vcmi/blob/devel … cSelC.json
github.com/vcmi/vcmi/blob/devel … /vcmi1.png

BTW for anyone who’s visiting us just the first time you can follow project on social networks too:
facebook.com/VCMIOfficial
twitter.com/VCMIOfficial
plus.google.com/b/1034471203474 … 7426041519

And not really social networks:
steamcommunity.com/groups/VCMI
reddit.com/r/vcmi/
moddb.com/engines/vcmi

There also page in Russian:
vk.com/VCMIOfficial

Package fixed - mods and map icon.

Map icon has wrong files.
“ScSelC.json” - is XHTML junk (saved web page?)

should be:

{
        "basepath" : "mapFormatIcons/",
	"images" :
	
		{ "group" : 1, "frame" : 0, "file" : "vcmi1.png"}
	]
}

“vcmi1.png” - wrong directory should be in “mapFormatIcons/” subdirectory

Well congratz on releasing 0.99 sadly when i tried it, it crashed so that was not fun. Full clean install and installed only hota and hd menu mod and it just crashed so am i having bad luck or is there a miss somewhere?

Just one question do you guys test if before releasing it?

Try latest daily build:
vcmi.arseniyshestakov.com/windows/
My firend told me, that in version 0.99 launcher didn’t launch. In daily builds version all it’s ok (he has old PC with Win XP).

Fixed again. For some reason git doesn’t want to update these files for me.

As usual, everything works here. What is the error message?

The error message is:
cannot open interprocess memory
reason: 0xe06d7363 uknown exception at 0023:76;ba9,6c2
thread id: 3784.
crash info.

Did you run as admin?

yes and still a crash

Restart system, there is is bug with boost if uptime is too long.

Restart likely wouldn’t help. At least it’s not help to @povelitel at all. Proper solution would be to get rid of shared memory completely here since client able to shutdown server without it.

Issue on bug tracker here: #2560

Only real workaround is start VCMI_Server.exe separately (it’s will not NOT crash) and then VCMI_Client.exe with “-d” or “–donotstartserver” flag. Then client will just use what’s given.

Also release shipped with SDL 2.0.3, which is not that stable. For me 2.0.4 works much better.

Also this release shipped with opengl32.dll, which causes game to misbehave, for example on my PC it causes problems when switching between fullscreen and windowed mode.

avg internet security 2016 doesn’t like vcmi_server.exe and still remove it… :neutral_face:

Yes, it does for me as well. But it should allow you to choose ignore it :bulb: