VCMI 0.98 released


#21

This is a bug. Please report it on bugs.vcmi.eu/my_view_page.php


#22

I found this just a few weeks ago, and then Gog had their H3 sale so it was a given to re-live the adventures of this epic game. And well done on creating the project! Awesome job!

A few questions come to mind. Any idea on how long after a release the ppa:saven-ivan/vcmi -Ubuntu repository is updated. Is anyone maintaining easy to install releases for Mac. And what does VCMI stand for?

Keep up the good work!


#23

Hi. Sorry for this delay. I’ll try to do something with PPA tomorrow. Meanwhile you can install daily builds from this PPA:
launchpad.net/~vcmi/+archive/ubuntu/ppa

Let’s just say that project founders were great fans of Tolkien :unamused:


#24

People ask this again! xD
By the way, I always wondered why would you make it something hard to pronounce, or remember, it wouldn’t attract too many people. But I think I heard somewhere that it’s supposed to be pronounced veece-me? :stuck_out_tongue:


#25

Any update on Android? Won’t even launch now on my LG G4 5.1


#26

Please, somebody help me: i see all the menu in Russian, i just installed VCMI and downloaded all the features and mods (i couldnt download Tarnum 2).

How can i make the menu in English, please? :bulb:


#27

Disable WOG russian translation mod. (BTW it should be disabled bu default)


#28

Yes it should, but this feature doesn’t work for some reason.


#29

I already tried that but didnt work… is all Russian.

But another issue: i tried to play in Russian, and i can play the old maps, in RoE, SoD, AB modes, but i cant play a random map, and i cant acces the wogifi options. It just not work, like is no sensible button there.

Any advice?


#30

Also there is still two copy of that mod in repo. One should be removed.


#31

wogifi button in not a button, its just a part of WoG graphics.


#32

Since only 0.95 is available in the PPAs for the Ubuntu 12.04 LTS (which is supported till 2017), I tried to compile it from source. After getting all the dependencies, updated gcc to 4.8, I get these errors:

/home/calmarius/stuff/source/vcmi/vcmi/lib/filesystem/CFilesystemLoader.cpp: In member function ‘std::unordered_map<ResourceID, boost::filesystem3::path> CFilesystemLoader::listFiles(const string&, size_t, bool) const’:
/home/calmarius/stuff/source/vcmi/vcmi/lib/filesystem/CFilesystemLoader.cpp:130:8: error: ‘preferred_separator’ is not a member of ‘boost::filesystem3::path’
if (bfs::path::preferred_separator != ‘/’)
^
/home/calmarius/stuff/source/vcmi/vcmi/lib/filesystem/CFilesystemLoader.cpp:136:15: error: ‘preferred_separator’ is not a member of ‘boost::filesystem3::path’
if (c != bfs::path::preferred_separator)
^

Maybe the required boost version is too low?

Anyway should I expect a deb for Ubuntu Precise or is it not supported anymore?

EDIT: Boost 1.48 doesn’t have that property in the Path class. It seems the required minimum Boost version is 1.50. README.linux should be updated.


#33

You can call it unsupported. Packages from vanilla Precise are too outdated to compile VCMI. Main reason is that this allows to use new features like C++11 and new features from boost.

And to provide .deb’s for 12.04 we’ll have to provide all dependencies - new gcc, new boost, possibly - new SDL 2.0. And that’s too much work for me.

Will do. Thanks for notice.

“supported” is a stretch. For Canonical support usually means bugfixing. They are not porting back new releases, they are not porting back non-essential bugs, etc. Even with “new” 14.04 I have a few bugs that were fixed but were not backported to 14.04. And I’m talking about kernel/X bugs - part of Ubuntu “supported” by Canonical.


#34

Hi ! Any news about update to 0.98 on Google Play ?


#35

See the last 3 posts in this topic [forum.vcmi.eu/t/how-do-i-create-higher-res-interfaces/153/1).

Also it is probably better to post about Android version in that topic.


#36

I have some bug.
Game crash after end day.
vcmi 0.98 + patch aa00fdbd0e99b2beec382c7677a64d962b748dcb
Fedora 23

Newgame_Autosave_5.tar (425 KB)


#37

Hello! If you decide to report bugs please find out how to build VCMI from git or use some repository (if there’s any) with newer version. Stable version you currently playing was based on May 8 code so it’s really old already.

Also please post reports on bug tracker:
bugs.vcmi.eu/

Thanks!


#38

something not seen reports.


#39

How can i use vcmi for android?


#40

For when a 0.98 .deb for Jessie? :slight_smile:

Not really comfortable compiling from source. http://r11.imgfast.net/users/1112/86/44/25/smiles/364394463.gif