VCMI 0.98 released


#64

Secondary skills in VCMI are hardcoded.


#65

Uh, quite surprised here. I never tried to change anything but always thought VCMI was completely open.


#66

Open mean that you can sent pull request that introduce option to load these values from JSON. :wink:


#67

Sry if it’s a silly question, first time I’m here. I tried installing the addon to both not-recommended HoA, and the recommended clean Heroes3 Complete. First, I didn’t found for some reason GNU/Linux version, though the «about page» says it have to be here. Okay, so I tried running the Windows one, however it does always crash. UPD: immediate crash when starting any of VCMI_client.exe, and VCMI_launcher.exe:

...
wine: Unhandled page fault on read access to 0x00000004 at address 0x7e48b22d (thread 0009), starting debugger...
...

FWIW both Heroes3 Complete, HoA, and HoA with HD patch are working fine for me. wine-1.9.2 (Staging), WindowsXP emulation.

Does anybody experiencing this? Should I report a bug? And where’s btw GNU/Linux executables?


#68

It’s was always crashing in Wine as far as I remember.

Yep, but to Wine bug tracker. This is unlikely our problem.

Stable builds (and outdated, more crashy one):
launchpad.net/~saven-ivan/+archive/ubuntu/vcmi
Daily builds:
launchpad.net/~vcmi/+archive/ubuntu/ppa

Sadly I don’t think it’s there for newer version of Ubuntu, but 16.04 should have VCMI in official repository.


#69

Cool, thank you very much! Indeed, the newer Ubuntu have the game in the repository. packages.ubuntu.com/search?keywo … ection=all

Sadly I’m at 14.04.3 atm, but I’ll use your second link; thank you!


#70

I did have it running on ubuntu some time ago, worked without problem, but installation was a bit tricky, IIRC had to get core files somewhere else on the forums and not from install page.


#71

No, no, nothing tricky. There’s a page on installing wiki.vcmi.eu/index.php?title=Ins … n_on_Linux

In short, it’s just adding PPA *(not needed for newer buntu), installing vcmi package, and either copying data files from the original Heroes to /usr/share/vcmi, or making it a symbolic link pointing to the installation directory of Heroes. Piece of cake :stuck_out_tongue_closed_eyes:

EDIT: actually, symlink not the «vcmi» directory, but its subdirectories, because there’s already some data after VCMI installed.


#72

I recall I had to get core files from somewhere else, probably link has been fixed since.

Anyway, once installed ran flawlessly without crash. :slight_smile:


#73

By the way, I don’t actually think the crash is a Wine problem. It’s too quickly evolving project, and being used with too much different applications, so if you’re say it was never working before, not just now… I think it rather have some not/partially implemented function returning a fail, while the game expect it to always succeed, which lead to crash. I see just before the crash a bunch of these «fixme’s», perhaps they’re cause it:

fixme:msvcp:_Locinfo__Locinfo_ctor_cat_cstr (0x32f970 1 C) semi-stub

But I don’t know what’re those functions, so it is perfectly possible that otherwise the game wouldn’t even work, and then it’s the Wine problem :slight_smile:


#74

There is special install script available called vcmibuild. Also you don’t need to touch /usr/share/vcmi at all, just ~/.local/share/vcmi/.


#75

Hey guys,

Is there any torrent link to download v0.98?
I’ve tried to get it few times from download.vcmi.eu/vcmi_098.rar but every time used to get broken archive (most probably there is something with my internet connection, then with file itself).


#76

Just dig a bit more of internet. May be it will be useful for someone else.

VCMI_098 can be downloaded also from here:

magnet:?xt=urn:btih:F50ECCBA7DBBD5E2FCB71EA3D572F38CDC38B430&dn=vcmi_098.rar&tr=udp%3a%2f%2ftracker.openbittorrent.com%3a80%2fannounce&tr=http%3a%2f%2fretracker.local%2fannounce&tr=udp%3a%2f%2ftracker.publicbt.com%3a80%2fannounce&tr=udp%3a%2f%2ftracker.ccc.de%3a80%2fannounce

#77

I can download VCMI from our server with no problem.

Either way, we had a number of updates since 0.98. The latest in VCMI 0.98g


#78

Pressing the update button for HotA, yet… I can press it 40 times over, it won’t update


#79

Reported as a regression in bugs.vcmi.eu/view.php?id=2343


#80

Should now be fixed.


#81

Warmonger, Warmonger,

Does anyone have a guidance to tell us how to make the VCMI works well on windows please?

i am trying to compile the vcmi, but i don’t know how to make it work with data which i download from download.vcmi.eu/core.zip


#82

hi, can you tell what happend to the android version? cause it been over a year since 0.98 has been released on every other platform but it is still stuck on 0.97


#83

Android version of VCMI isn’t officially supported.