VCMI 0.88b - development version (r2707)

as promised, here is a development build 0.88b:
[size=150]DOWNLOAD LINK [/size]
Resolved reports:
Development log:

I’m quite happy with the progress. We have a few new features like Commanders, long-awaited pregame support for higher resolutions and most of missing battle spells. But we’ve also done numerous minor fixes and improvements, listed in changelog below and mantis generated changelog.
This release also features new graphics for creature window that were contributed by fishkebab. Thanks!

Depending on number of found bugs and changes in the trunk, further development builds may follow. The 0.89 release is scheduled on June 1st.

Many thanks to all the developers and testers! And please give this build a try! :slight_smile:

For those who interested - package that will make VCMI look like this: … s-menu.png

Extract this package into VCMI data folder:

I can’t start any game after resolution change and VCMI restart (dmp attached). I hope it isn’t my heroes installation fault :wink: . (120 KB)

Thank you for the report. Could you attach a client logfile and possibly also a screenshot showing console output?
The crashdump tells us what happened on its moment but it’s not very useful, if we don’t know what events led to that.

dmp stacktrace:

>	VCMI_client.exe!CStatusBar::CStatusBar(int x=8, int y=723, std::basic_string<char,std::char_traits<char>,std::allocator<char> > name={...}, int maxw=-1) Line 1053	C++
 	VCMI_client.exe!CAdvMapInt::CAdvMapInt() Line 1035	C++
 	VCMI_client.exe!CPlayerInterface::init(CCallback * CB=0x0f4303bc) Line 147	C++
 	VCMI_client.exe!CClient::newGame(CConnection * con=0xfb54cbc6, StartInfo * si=0x002fd7e8) Line 385	C++
 	VCMI_client.exe!startGame(StartInfo * options=0xfb54cbc6, CConnection * serv=0x00000000) Line 800	C++
 	VCMI_client.exe!CSelectionScreen::startGame() Line 839	C++
 	VCMI_client.exe!CFunctionList<void __cdecl(void)>::operator()() Line 62	C++
 	VCMI_client.exe!CAdventureMapButton::clickLeft(boost::logic::tribool down={...}, bool previousState=true) Line 311	C++
 	VCMI_client.exe!CGuiHandler::handleEvent(SDL_Event * sEvent=0x807b1727) Line 251	C++
 	VCMI_client.exe!CGuiHandler::handleEvents() Line 151	C++
 	VCMI_client.exe!CGPreGame::update() Line 493	C++
 	VCMI_client.exe!CGuiHandler::run() Line 361	C++
 	VCMI_client.exe!boost::`anonymous namespace'::thread_start_function(void *)	C++

Looks as if statusbar picture was missing, that should show on console output.

The 7z file has a couple extra/unused files:

  • config/ressources.json
  • MP3 and MP3/snd1.wav

And when I run the current svn version the data files from0.88b, I get a crash with:
Cannot find file: ZM181NPC

Thanks for info, I’ll remove them.

You should have ZM181NPC.DEF in h3sprite.lod — it’s a commander’s def for Fortress.
Can you see any other Commander in the battle (playing with non-Fortress hero)?

Thanks Tow. I added one more file from the Wog archive, and it’s all working now.

Now happens something veeery strange. I tried to run VCMI on my notebook as before (to make a screenshot), and after the “3DO” intro my notebook just restarted! Initially I thought that restart was not related, but it happens every time i run VCMI. I don’t think it can be my notebook fault, it never happened before. Can anyone explain that? I never thought something like that could even happen. In attachment I include the only file VCMI creates - Client log.

EDIT: On my PC it didn’t happen, i think it can be related to different heroes version (installation), but anyway system reboot shouldn’t happen i think.
VCMI_Client_log.txt (14.9 KB)

do you have same system and system version on laptop and PC?
it seems it’s some engine bug which should just crash VCMI on bugless system, but once system failed to kill VCMI properly (a system bug) it just crashed (please enable bluescreen diagnostic if you use windows - in newer version it is disabled by default).

Try again and check “dieing message” of system - if windows die without bluescreen (with feature not disabled) - it seems more hardware than software bug (even drivers should crash without ommitting bluescreen).

If you are on linux let configure kexec enviroment (a kernel executing another kernel) as it is only way to capture all diagnostic of kernel crash or kernel panic (do you have set automatically reboot on kernel panic? if it is a kernel getting the bug it should rather panic than reboot).

Do you have some weird machine? if having old or not fully compatible CPU it may not suport some additional to x86 instructions (trying to execute unknown instruction may generate unmaskable interrupt, or just one badly implemented on your system - it may also go wrong on hardware level - CPU going in BAD state and rescuing itself by reset - just like you put down the charging and fastly put it up).

Note since it seems more like hardware problem (unless you have system dieing reporting disabled) it may be connected with overclocking or generallly overheat - check if Laptop isn’t hot, if holes are not covered and if it isn’t dusted inside - else it may be some loose connector or partially faulty piece of hardware.

Remove settings.txt as well - it is unused since 0.88 (just deleted it on svn)

BTW - shouldn’t chain lighting marked as implemented in list? It has a bit incorrect effect but mechanics is already in.


Yes, i have exact the same system on both computers (Windows 7 x64).
No, it’s nothing “weird”. It’s just amd based machine (phenom x3).
Additionally, by “restart” i mean system reboot, not bluescreen (just like “restart” option in start menu).

Thank you for feedback. Restart certainly should not happen under any circumstances. If application does something really bad it’s a duty of operating system to kill such application. And that usually happens, appearing as a crash. I guess there’s something wrong on your side that causes crash to reboot machine, but it’s also no accident that only VCMI does that.

Please tell if:

  1. Your VCMI installation works on PC?
  2. If yes (so we know that the game files are OK), please try copying whole H3-with-VCMI folder somewhere onto notebook. Does it work?
  3. It may be also somehow related to installation dir, Win7 doesn’t like if application writes files in subfolder on system drive. (though it depends on user account settings) If 2) still fails, try putting folder in “My documents” or somewhere you’re sure that app can access.
  4. You wrote that error appeared after changing resolution. Try deleting settings.json file from config subfolder. That should reset resolution and any other changes you’ve introduced.

Done and done, thanks.