VCMI 0.73 - Bug reports

VCMI 0.73 has special (still somewhat experimental) crashhandler. When VCMI crashes it should show its window and create special .dmp file with information that might be helpful for us in identifying the problem. Please upload the .dmp file if it’s present with logs when reporting a crashbug.

[size=150]KNOWN ISSUES[/size]
(follow the thread links for full descriptions)

[size=75][There are a lot of them but it doesn’t mean that this release is especially buggy. It has been just better tested :stuck_out_tongue: ][/size]

Crossed out bugs are fixed (or most likely fixed) is SVN version.

0.72d [
#1 Crash when trying to start the game selected by default on top of the list, after sorting the scenarios by map size:
#04 Small bug with battle screen.
#06 saving settings for battle options, not implemented saving the setting of animation speed during the battle. And if you start new map also there is default switched on grids.
#07 Crystal Dragons can walk over Obstacles & other Creatures.
#08 2-hex Nomads are regarded as 1-hex creature when it comes to possible movement
#09 Strange AI battle behavior:
#10 - Resource cost for ships is not showing.
#11 - Heroes on coast can not interact with heroes on ship (like exchange, probably battles as well)
#12 - In system options there is some problem with hints - it looks like VCMI can’t find appropriate text.
#13 - Building a ship from city - ship is placed in wrong place (2 tiles on south)
#14 - I can retreat my only hero from battle, even though I have no castle. Game continues, but freezes on pass turn command.
#15 Bug if you want to get into subterranean gate but hero movement is just finished.
#16 Bug - harpies are not able to fly behind the other units. [size=75](I hope it’s fixed as I’ve changed a lot of code in this part of engine)[/size]
#17 Bug if you free hero from prison it is shown in information screen as first hero from the list
#18 Splitting stock in meeting screen and between garrisoned heroes - if you want to separate one unit from one hero stock to another hero and you push “1”, there automatically apears quantity equal 2.
#22 - The yellow & blue (when hover) glow animations for creatures in battle should not fade out completely.
#23 - Imps can fly to/through battle obstacles. [size=75]This seems to work fine… unfortunately save fiel attached to bugreport is no longer supported[/size]
#26 Flying creatures are flying *through the other creatures on the battlefield
#27 Ballista cannot shoot if there’s an enemy creature next to it
#28 Wrong Battle Casualties reported:

0.72c [
#3 Luck animation is too short and probably also too low.
#4 Animation sound for Fortune is not working yet.
#10 Ellipsis is handled as 3 separate characters by VCMI, while it should be considered one single character.
#14 Identical with the above, the scroll arrows should also be disabled/grayed out in the Marketplace window, when the from/to resources are not selected yet.
#15 Similar to the above two, the Split Stack button (Town screen, Hero Screen, Meeting screen) should be disabled/grayed out when no creature is selected.
#20 Pregame - Starting hero displaying details
#21 Small graphic glitch above file date, after moving up and down selecting different games in the Load Menu:
#22 Grand Elves attack twice also in melee (like Crusaders:). They should only shoot twice, not also stab twice. :slight_smile:

#25 The graphics of the Surface View button still need to be adjusted for the 1024x768 interface:
#26 This is minor, but still: Resource values in the Trade area of the Marketplace window (“Qty to trade”) are not perfectly centered. They are about 1mm to the right, as compared to H3 (if you Alt+Tab between a H3 and VCMI Marketplace, with resources selected, you’ll see the difference)
#27 - Fairly minor, however a part of H3 functionality. When a hero picks up a resource pile, hero information does not return automatically after a little while (until you change to another hero or town then back to the original hero).
#28 - Sound does not play when picking up an artifact. Also no terrain music yet.
#29 Custom creature animation in battle does not work for the active stack (the one with the glowing yellow border around).
#31 H/next hero button – should switch between heroes with path left not without
#36 Killing a stack of our own during its turn with a spell, leaves a ghost image of the stack on the battlefield:
#40 Wrong stock queue in the battle if there are creatures with the same speed first attack all creature the attacking hero then opponent,
#41, because AI should try to go after the shooter or the flyer, unless the pikemen would be reachable in less number of turns)
#42 Monolith bug - you can block the monoliths.

0.72b [
#7 - If we attack with multiple creatures on the same target, after any attack, we have to move the mouse cursor away, then back on the target to get the correct sword/arrow pointer.
#11 Event message windows still don’t support large texts correctly
#15 Game crashes at first action taken after we press F4. We had F4 issues before, first in 0.68 (#4 - solved) and then 0.71#47 (which reported F4 issues when VCMI was running in parallel with H3, but this time we have issues even when only VCMI is running).
#16 Game crash (system freeze) when I tried to start the custom “Just testing” map attached. It’s not reproducible, so I’m attaching the logs as well.
#21 ‘H’ key on Adventure map centers on the 1st hero in the list (even if he’s out of movement points). Instead, it should select/center the next hero in the list with movement points left. That also means that if no hero has movement points left, H should do nothing.

0.72 [
#10 morale animation shown on wrong place
#11 battle crashbug when trying attack from side where tile is occupied unit moves and crashing when is next to destination tile [size=75]Probably fixed in SVN but needs more testing[/size]
#17 - Attacking (2-hex) monster from behind bug,
#31 battle I don’t like that already found issue about haste/slow affection on battle movement order not yet fixed and add from my own : the queue (hotkey Q) shows even more strange info
#41 when message in ingame console is too long it overlaps the infobox, and when the message disappears infobox is not refreshed
#43 blue glowing border around selected creatures restarts every time when cursor moves (should be only on selecting creature)
#44 I see bug #47 from 0.71 reported problems caused by F4 when running both VCMI and H3.
#47 - bug with hero advancing
#48 - Target creature loses stack size box from the moment the enemy shoots at it, or even starts to walk/fly towards it:
#49 - Large stack numbers don’t fit very well in the boxes:
#59 Sorting by other categories works, but only ascending. A second click on the column header should sort in descending order.

#73 : AI doesn’t recognize the front hex of a 2-hex creature
#74 : Enemy creatures should have their hex shaded if they are within the attack range of the active creature (melee+range).
#75 : New crash when attacking a Green Dragon that used (Wait+)Defend in the previous round.
#76 the infobox remains frozen on the last frame of the new day animation
#77 : New Crash when enemy Champions tried to attack friendly Centaurs from below.

Bugs have been added to the Sourceforge tracker: … 9&status=1

For features requests and missing functionalities there is a separate thread:

[size=84]True. The game is more playable than ever. Lots of small bugs are a sign the major issues are solved so that we can test enough to find all the small details. :slight_smile: Like these two here below:[/size]

#01 The VCMIEAGLES cheat does not reveal the map (I’ve also added the logs, though probably redundant): [size=75](notice the screenshots we can take in the 1600x1200 resolution) :)[/size]

#02 The VCMIISTARI does not give a Spell Book to the heroes who don’t have one (like WOGSARUMAN does in WoG)

[size=84][All other VCMI cheats are tested and working fine][/size]

[size=84]FYI - for the other testers - in case you missed it in the Changelog , here are the VCMI cheats implemented so far:[/size]

[size=84]For those not used with the WoG cheats, click here for the complete list & descriptions.[/size]
090801 - Cheats (3.41 KB)

#03 Some creatures offer to join for an amount of gold that the player does not have. If the player accepts, a message saying “you do not have enough gold” pops up. If the player checks ok, it pops up again forever, halting play indefinitely.

#04 Crash when hitting F4 in 1600x1200 resolution - different than the F4 crash in lower resolutions reported before.

I’m attaching here below the logs (including the .dmp files I had after the crash):

For 0.72b#15 - in 1024x768 resolution the game goes in full screen without a crash. It only crashes once we try to perform any action in the game. After the crash, both log files are updated, as well as VCMI_client.exe_crashinfo.dmp. VCMI_server.exe_crashinfo.dmp however remains unchanged (based on the file date/hour).

For 0.73#04 - in 1600x1200 resolution the game crashes already when we press F4. Only the log files are updated. Both VCMI_client.exe_crashinfo.dmp & VCMI_server.exe_crashinfo.dmp remain unchanged.

If you check the date/time of the files in the 1600x1200 F4 Crash logs archive, we have the following:

VCMI_Client_log.txt & VCMI_Server_log.txt - updated 02-08-2009 @ 1.42 AM - time of the crash in 1600x1200 mode
VCMI_client.exe_crashinfo.dmp - updated 02-08-2009 @ 1.26 AM - time of the crash in 1024x768 mode
VCMI_server.exe_crashinfo.dmp - updated 01-08-2009 @ 23.55 PM - no idea what generated this file, as I don’t remember other crashes than the F4 tests (might be interesting for you guys to look into it)
090801 - 1024x768 F4 Crash (170 KB)
090801 - 1600x1200 F4 Crash (170 KB)

#05 - I’m getting weird mixed-up electronic “music” playing sometimes when the main menu opens or in towns. It’s not causing a crash, but does sound very strange. Has anyone else experienced this issue?

Best regards,

[size=75]*Edited to add log # and to to confirm that I’ve also had the issue, I think after Alt+Tabbing while I was in Town screen. And the weird mixed-up electronic/metalic “music” remained also after exiting the town screen. Unfortunately I forgot to save the logs when it happened. Will do next time.


#06 - Zero division at level-up, this time via tree of knowledge.
This bug occured also on previous release, but now I’m certain it’s not my fault.
Levelup crash dump.rar (50.8 KB)

I’ve attached map where this bugs can be tested:

07 - Sound\Music level does not affect videos.

08 - Number of creatures defending dwellings is completely random. (Should be 3 for 7th level, 6 for 6th level… Golem factory have 9 Golden and 6 Diamond).

09 - Recruit message in Golem Factory differs from H3. There is problem with title as well.

Heroes 3:

10 - Some strange linking between subterranean gates: both underground gates leads to south one on the surface.

11 - Exchange between subterra gates does not working, Active hero appears on right side (not like in the “normal” exchange).I’ve receive message:
System message: Server encountered a problem: Cannot exchange stacks between these two objects!
Also, place 2 heroes on both side of subterra gates, take third hero and start exchange. VCMI crashed. Logs+new dumpfile attached.

12 - Graphic glitch: After receiving some long server messages (from previous bug) I’ve switched between 2 heroes. After these, only part of message disappeared.

13 - Pressing “Up” key in the console before entering any commands - crash.

By the way - It would be nice to have in next releases possibility to move hero with arrow keys.
Arrogance-dwellings.h3m (9.32 KB)
Exchange.7z (106 KB)

#14 Spacebar with selected hero which we want to enter the town in which another hero is garrisoned causes that heroes switch in town.
BTW: It is nice that spacebar in town causes switching heroes :wink:

#15 Crash while trying to move VCMI window. Not reproducible. (attached logs)

#16 Bug/feature? if you choose town on Adventure Map window the map centres on that town but mouse cursor doesn’t follow the town. So it is immpossible to make double click to enter the town quickly.
EDIT: It’s feature. The same way map window act in HoMM

#17 Bug/feature if you select last stack in meeting screen or in town there is no possibility to unselect the stack, ESC works as exit from town and appears: “System message: Server encountered a problem: Cannot take the last stack!”.

#18 Bug towns without fort in map window are shown as town with fort.

#19 Bug if you are in town and you buy new hero map behing the town screen moves to other location :question: Strange, because the new place seems to be chosen at random.

#20 Not possible to exchange the war machines. “System message: Server encountered a problem: Cannot move war machine!”
crash while moving vcmi (138 KB)

This part acts exactly like in HoMM3.

#21 - If you try to split stack (with split button):
Select any unit, click on button “split” click on your unit again.
VCMI crashed. Logs attached.
Splitting.7z (130 KB)

Probably, that’s why I’ve added info “feature” but if it is normal so shouldn’t appear “system message”

#22 Crash during saving game. Can not save the game so end turn is also not possible. (attached logs and autosave)
EDIT: After this incident I have problems with other saves also. Only save from day:1 is ok.

#23 You can buy the same heroes in tavern.

#24 Cannot hide hero to garrison if the same kind of creatures are splitted.You have to join it for one stack before.
“System message: Server encountered a problem: Cannot make garrison swap, not enough free slots!”

#25 Bug Lizard Den dwelling accumulates creatures. I don’t now yet what about other working dwellings and its guards.
EDIT: Griffin Tower/Archer’s Tower/Guardhouse also accumulate creatures. So probably all others, too.

#26 In resolution 800x600, if you end turn with scrolled down the heroes list at the beginning of next turn the list is still scrolled down even though first hero is selected.

#27 Spells act on creatures immune to spells ie. Black Dragons.

Refer to bug ver.072d#10 - the title of the shipyard is “Thieves guild window”. Should be “Build A New Ship”

BTW: Some problems with “vcmi handler”: should appear in the front of the game not in background, and if you close the handler there is problem because the game doesn’t close and X is not working also, you need to kill process in the cmd console.
EDIT: In first moment after handler apppear game looks ok but you can’t do anything. So you can just exit the game by system options but appears message:
“Connection has been requested to be closed.
Disaster happened.
Reason: 0xe06d7363 - UNKNOWN EXCEPTION at 001b:7C812AFB
Thread ID: 254 [596]
Crash info will be put in 00000430”

*EDIT2: After crash #22 I had problems with other saves of this map “All for one”. So I started it one more time. After new start everything was ok. Also the towns without fort were shown correctly, but after loading save with the new “version” of this map the bug returned. Probably crashes/bugs no 15, 18 and 22 could be caused by some mistakes in the map or because something was wrong with the map starting/loading. Someone else could test also this map or confirm if the problem with villages (18) has been noticed in other maps. *
EDiT3: I’ve tested the bug #18 with another map, and it repeated, so it is VCMI bug.
loading crashed (170 KB)
crash during (205 KB)
crash during (154 KB)
crash at the end of (50.3 KB)

I tried to fight enemy hero visiting castle on arrogance3
that as it uses no castle screen may be lack of feature
that as I cant get empty castle too
but that as i see enemy crosbowmans shoot from hero place (ie. like spell) instead of his place is evidently a bug
first i thought it was invisible ballista but now i see it’s on archer’s turn :mrgreen:


I’ve observed it too. Well, that’s probably better than crash but… :frowning:

It happens sometimes in battle too…

My guess is that the electronic music playing may have something to do with starting or ending a track…

Best regards,

#29 If hero has expert Air Magic, the Magic Arrow in Spell Book is shown with expert Earth Magic.

#30 If hero is in the town or other building and you want to check which hero is that you see the town guard or properties of the building. So the hero layer is behind the buldings layer, ie:

Hi there!

I haven’t been for a long time because i haven’t internet there where i was

For those who remembers that i’m translating russian heroes 3 manual called FizMiG into English i say that it’s in progress, stay tuned )

#31 I have edited video.vid file, and launching hotuploaded vcmi i got crash where console says
Smack cannot open 3DOLOGO.SMK
Disaster happened.
Reason: 0xc0000005 - EXCEPTION_ACCESS_VIOLATION at 001b:00494D63
Attempt to read from 0x0000000C
Thread ID: b18 [2840]
Crash info will be put in 000000F8

however there are other console messages after this, it’s probably how crashhandler works, but if not I wrote this for U

so vcmi needs to check presence of videofiles in video.vid pack and other packs with resources

BUUUT i`m not fallen hopeless to launch VCMI, some changes in VCMI via hex-editor made him alive and launchable ))) please note that i inserted instead of old videos names new ones not erasing any other data

#32 a nice bug (different maps, incl. arrogance, settings of downloaded package of VCMI), actualy mistake heroes from start have unbelievable stats-9 digits long, each one type of hero has different values (i.e. all of knight heroes have same defence)

#33 just minor : zombi retaliated my griffin (they stood back-to-back), he just reversed and right after reversed back and then griffin was hit, so no attack animation noticed,the same for some other units they do not show attacking animation for me only wounded animation, u know like standing 2 units together and first one is hit and then other is hit, weird for me, u know i’m sure no such bugs were in 0.72

#34 some strange in graphics:
#34.1 - in fully-built fortress(arrogance) i see strange waterwheel which is not present in heroes 3,
#34.2 - in stronghold spinning part of cyclops cave is hidden in one place by rocks
#34.3 - in necropolis if u compare blacksmith u will see differences(in front/under th blacksmith there some thombs in h3) and between wraithhouse and skeleton house there are differences, also if u hover a skeleton house u will see that un h3 yellow border interrupts(for other buildings and towns same) and in VCMI it’s like a space around building which erases the background

[size=75]*Edited as #34 seems to report different town screen (possible) bugs, so I’ve split them.


#35 After you load saved game the dwellings stop working.

[size=84]Please use Inteus in the attached map to reproduce all bugs reported in this post.[/size]

#36 - Inteus starts with his default Bloodlust, even though I removed it from Map Editor.

#37 - Wrong Bloodlust animation (see screenshot - looks a bit like Hell Hydra’s self-healing, though still different somehow)

#38 - Battle obstacles are still misplaced (regardless of resolution or terrain - see also screenshot)

I was under the feeling this was reported as solved (at least I don’t seem to find it in the logs). But it’s easily reproducible:

  • Tested on Rough, Swamp & Subterranean, but probably valid for all
  • Tested on 1024x768 & 800x600, but probably valid for the other resolutions as well
  • If you load the attached map, you’ll see the creatures can walk through the obstacles
  • As seen in the screenshot, the placement of Subterranean obstacles is always in the hexes above them, however on other terrain the wrong placement does not follow the same “rule”

#39 - Psychic & Magic Elementals are seen as 2-hex creatures:

  • See the empty hex in front of the Psychic E. If I try to move the Magic E. up behind him, he will go around that empty hex
  • See the “Bloodlust” animation - casted on the hex in front of Magic E.
  • We can also r-click in the hex in front of them for creature info
  • If you try to move them to an extreme right hex, they will stop 1 hex before the end of their available (shaded) movement
  • Their attacks from front & side-front are from 2 hexes away (reported as fixed in 0.71b/c, but apparently it came back)
  • When they attack from behind, they suddenly move 1 hex to the right in the moment of the attack

VCMI Tests.h3m (9.03 KB)

[size=84]You can attack Rissa with Neela in the map attached above to reproduce these:[/size]

#40 - Gremlins don’t always use the retaliation animation

#41 - Gargoyle’s attack animation is incomplete: they only open their wings, but they don’t hit with the claws

#41b - Stone Golems tend to use some sort of “footwork” instead of their fists as retaliation animation. :slight_smile:

[size=84]…and I suspect other creatures have issues with the battle animation as well (do these fit more in the “missing functionalities” section, or shall we continue to report them as bugs?)[/size]

EDIT: I just noticed that the missing retaliations bug was already reported by pHOMM as #33. Hopefully the above is still relevant though, as the issues are slightly different (or they just seem so): one has no retaliation animation, another incomplete, and a third creature wrong animation (and inconsistent). But perhaps it’s all related. I also changed the last log # here to #41b. #42 was duped below by Boulie, however his bug is more relevant.

Maybe we can create separate thread concern only battle bugs/“missing functionalities”. I’ve noticed many problems during battle but I’m not sure if I should write about it before we’ll get oponents AI. Probably then we will have much more notes. Maybe first we should just take care about Adventure Map’s crashes/bugs?

I’ve recently fixed some problems with two-hex creatures in battles (mostly crashbugs). I hope there remain just graphical glitches and missing features. I’ll try to consecutively fix & implement them. I don’t think creating separate thread for bugs / missing functionalities for battles is necessary, especially when so many battle bugs are reported in general bug threads. I think a better idea would be a list of most wanted things to be done in this area, both bugfixes and new features. It would help me focus on most important things.