Vcmi 0.71 bug seeking thread

#68 Garrisoned heroes cannot buy spell book.

#69 Not sure if this was reported before: When we don’t have enough spell points left for certain spells, the spell book still displays them as “available”. We can also still select them. Only when we try to cast them on the target creature nothing happens.

EDIT: See difference in H3 screenshot:

#70 On Day 1 of Week 2 of Month 2, one of the 2 heroes which were offered at the Fortress Tavern in the beginning of the week was Jenova, Level 1 Ranger, with only 1 Centaur in the army. This should not happen unless we already purchased a hero or if she would be a retreating hero, which was not the case.

If it is of any use, this happened on the same map as the saved game attached two posts above (the save was from day 1 of the previous week). However it seems not reproducible: I also reloaded the above game and played until Day 1, Week 2, Month 2, but this time both heroes in the Tavern had normal stacks.

if u accidently press “spacebar” when it is enemie turn client crashes :-/

when hero has no spellbook and he is garrisoned in town, event u go to magic guild, it still doesn’t show that u need to buy book. and for original h3 it pops up :slight_smile: or it just opens magic guild, but no pop up about buying magic book

I tried to reproduce that while fighting some fliers (Archangels), which take long time to cross the battlefield, and I got a pretty funny behavior actually. Here’s the full bug description, and I’m also giving it a log number:

#71 Pressing spacebar in battle during enemy’s turn may cause duplication of enemy animation, and always ends up in game crash. In my case, I pressed spacebar about 20 times while the Archangel flew across the battlefield to get to my Pikemen. The result was that after striking the Pikemen down, the animation was repeated fully about 20 more times (I guess as many as I previously pressed Spacebar): Archangel reappearing in original hex, Pikemen “alive” again, flying across, striking Pikemen down, and again same cycle over and over again. Eventually the game crashed, freezing the battle while Archangel was striking the Pikemen.

I’m attaching the logs in case they might be of use.
Spacebar on enemy turn (3.53 KB)

Interesting… we just didn’t think anybody would press spacebar while it’s supposed to do nothing.

I agree with the “interesting” part. :slight_smile:

This “Action replay” bug might actually be quite a cool feature, if only it wouldn’t lead to a crash. :slight_smile:

I’ve investigated that replay “feature”, but it’s not reproducible in the newest version - although I’ve encountered and fixed another bug while testing ;]. Anyway thanks for report.

#72 Garrisoning or Un-garrisoning a hero causes all other heroes on the Adventure Map to loose their preset paths (always).

This may be related to the same “Spacebar” bug, but as it’s not really matching your bug description above, I’m gonna report it just in case:

#73 Spacebar to enter town crashes the game (always).

#73 seems to have been fixed.

Tow, I think it’s time to release a new version. A lot of these bugs have been fixed already.

If everything goes fine, I’ll post development build on Sunday. If no giant and disastrous bugs are find, the “big” release will go on 1 June.
All features I wanted to implement (artifact support system, map events) are done enough. Tow Dragon’s stack bonus system seems to be mostly functionable.
There still is a crashbug probably related to playing music that bothers me. I’ll soon post info on it in the sounds thread.

Uhm… it works… but not exactly in the way I’d like it to work. I’d like to move spell effects to this system. And then implementing many new spells and creature abilities would be trivial. I think I could finish most of it in one week. I hope it won’t introduce new bugs.

Tow Dragon, the ranged attacks don’t work anymore.

Fixed hopefully.

This behaviour has been changed due to other changes.

I’m not sure if I understood correctly but it should be fine now.

Seems to be fixed.


Seems to be fixed.

well it DOES in h3 :wink: it “defends” when you are in battle :wink: that why i used it there also.

I was talking about it’s behaviour while it’s opponent’s turn. I don’t think defending next to be moved stack would be good.




Some issues still pending from this thread (= unresolved bugs which are also not logged in SF or more recent topics, plus a couple of unclear items):

@pHOMM: It’s not very clear to me what #43 describes. Is it by any chance the same with what I reported long ago as 0.63b#15 ? If yes, then it’s not an issue anymore (now, in 0.72d)

#59 - Unresolved. Seems to be related to 0.71#51 above, which is the same with 0.72b#7. Once that is solved, this needs to be rechecked.

#60 - @Ivan: Are you sure it was the Centaur attacking the Skeleton, and not the Skeleton retaliation (in which case it would be a very known bug occurring when 2-hex creatures are attacked from certain angles)

#61 - The “Isles of Illusion” map attached to your post is full of unreachable objects. However I’m not sure if that’s the cause of the crash - especially now in 0.72d, when VCMI crashes (ALWAYS) when we scroll to it already, while in your bug description you mention it was crashing on startup (?)

#63 - Not a bug. I’ve logged it in the list of missing functionalities.

#62 & #64 - Both seem fixed. @pHOMM - you can double check and confirm, in case I misunderstood the bug description (?)

#67 - The main bug is solved (being able to continue the battle during r-click). Only detail remaining is that cursor during r-click does not change to the neutral arrow as in H3. But I have mixed feelings about “fixing” this last bit: I kinda like that in VCMI the cursor of the possible action on that stack remains during r-click (maybe you can leave it until you get new reports about it).

#69 - Unresolved (in 0.72d). // EDIT: Ignore - this one is already logged in SourceForge.

#60 - You are right - this is that very known bug :slight_smile:

#61 - In 0.71 crash on startup occurs ALMOST always. But even in the case of successful launch:

#63 - This is one of my first report. Only some time later I’ve found list of implemented items.


Probably fixed, as I’ve never encountered this issue.
(if not please re-report this)


Fixed by onion_knight.

Implemented by Warmonger.

I can confirm it’s fixed. I couple of weeks ago I scanned this thread to see if there are still bugs reported here which are neither fixed nor reported in SF. This was one of them. And I did my best to reproduce it but it didn’t happen again. :slight_smile: