VCMI 0.55 Released!


We’re releasing a new version of our glorious project. It brings several bugfixes and improvements.

For information about our project look here.

Our project isn’t really playable now, but it gives you an idea of progress we have made so far. We’re hoping that you’ll like it. Please report all the problems in the appropriate board. We hope you’ll help us develop the project - details are available here.

Changes since 0.54:

  • Sprites/ folder works for h3sprite.lod same as Data/ for h3bitmap.lod (but it’s still experimental)
  • randomization quantity of creatures on the map
  • fix of Pandora’s Box handling
  • reading disposed/predefined heroes
  • new command - “get txt” - VCMI will extract all .txt files from h3bitmap.lod to the Extracted_txts/ folder.
  • more detailed logs
  • reported problems with hero flags resolved
  • heroes cannot occupy the same tile
  • hints for most of creature generators
  • hints for creatures on the map
  • some minor stuff

Download link:

Extract the package into your main Heroes folder.
WoG 3.58f is required. We strongly recommend using English version.
If you have older version of VCMI you have to overwrite them.

Many thanks for Steven Aus for helpful suggestions and catching bugs. I’d also like to give thanks to Kulex for testing.



I unpacked the files in the game folder, but it crashes when I try to start it. Just so I’m not mistaken, it’s the VCMI.exe that I have to start, right? If yes, perhaps I should try a reinstal of the H3C+WoG, because maybe there are too many script updates installed over the past year.

PS: by any chance do you know if it’s gonna be only WinXP compatible, or are you having in mind other platforms as well?


Spam removed.

Reinstallation may fix the problem, but when exactly crash happens? Before you can choose scenario or while it is loading?

We are going to provide Linux builds of VCMI, Mac builds are considered too.


In the very beginning, when I try to launch the application:

[size=75]PS: always let me know if I should shrink my images[/size]


The console window interests us, so it would be much better to see it in the foreground of the screenshot. (or you can just paste the console output)
But, as far as I can deduce, it’s a problem probably with .txt files.
Do you have any .txt files in the Data/ folder? What language version do you have?

You may also try to extract files from attached package into your Data/ folder - they will work for sure (and they’ll help if this is in fact problem with .txts). (But they’ll also affect your H3, so you should probably remove them after testing). (332 KB)


Hello Tow,

I still have the same problem as with 0.54 and it seems to be the same as Zamolxis reports. The Console now says:

Initializing screen, fonts and sound handling: 140
Loading .lod files: 31
Scanning Data/ and Sprites/ folders: 0
Preparing first handlers: 0

So something has changed to the amount of .lod files since my last post. I have copyed your .txt files from your downloadable .zip into my MAINHEROESFOLDER/Data/ folder. Still it does not work.

You said in this version might be a utility to extract the language files. I can’t find it.
I will PM you as well.
Thanks for your help in advance!


The output shows that something wrong must be with PLAYERS.PAL file (h3bitmap.lod archive). It’s really strange… but it’s the only file loaded between “Preparing first handlers” and “Preparing players’ colours” logs.

Try to copy my PLAYERS.PAL file into Data/ folder. Does it help?

Link to the file:


Well, we are making progress:

Initializing screen, fonts and sound handling: 125
Loading .lod files: 31
Scanning Data/ and Sprites/ folders: 0
Preparing first handlers: 0
Preparing players’ colours: 0
Preparing more handlers: 312
Initializing colours and flags: 157
CPreGame: loading txts: 0
CPreGame: main menu initialization: 0

And then the debugger comes up…


Really strange, your files must be modified by something. If you have any modifications (except WoG) you may try removing them. If it still doesn’t work I recommend reinstalling H3:WoG.


Hm, I can’t find the game anymore. I just saved my folder over the years. So I guess I will have to buy it again. Biggest problem: From all the offers with a reasonable price (below 15€!) I can’t see which language it is. Does anyone know if there even a german version existed??? Only the english version will work, right?


Most probably there was a German version, but you need English for WoG. :wink:

BTW, I checked the console window as suggested, and I guess I found the answer myself: some files from the original installation (which happened more than 1 year ago) disappeared meanwhile:

I’ll reinstall everything the following days… been pretty busy again lately.


Looks like a few files ‘disappeared’ form your h3bitmap.lod file. Reinstallation should fix that, but it looks strange.


You can buy practically any language version, it’s easy to change it by simply putting language files into Data folder.

PS. You really should check your PM :slight_smile:


I just wanted to say that I have reinstalled everything and now it works perfectly! :wink:


doesn’t work vista the programing

i don’t use right mouse

nothing battle

nothing town buy creatur and any building


I don’t understand… what doesn’t work? Vista?

If you meant graphic cursor - it’s not done.

Battles are not done.

Buying creatures is not done. Building structures in towns is not done.


[size=150]It is a work in progress.[/size] But it has the potential to be fantastic, as it won’t be limited to 256 creatures, 9 towns and 155 heroes, for starters. However if you want a playable game right now, you should stick to WoG 3.58f with script updates.

However, you are very welcome to help in testing VCMI 0.55, or future versions when they become available. :slight_smile:

Best regards,

[size=75] Added: 2008-03-10, 07:03 ][/size]
I can verify that VCMI 0.55 can work in Vista (Home Premium).


I think you idea is wonderfull and I wait the results, it promise to be exeptionnal.
I have not understood, should I launch the game with VCMI.exe? Because, it is not starting by me. It only close the window and a second one opens but close immediatly, so that I can’t read the message. Were is the debugger?
I’ll try to help you as I can.
Good luck!



Does any error message shows?
Can you check the console output?
If console window closes immediately you may run VCMI using command prompt, then you’ll be able to check the output.
What language version of H3 do you have? English?
Any additional mods

Thanks :slight_smile:


Thank for paying attention to my problem. I have Heroes 3 with wog 3.58f. Since it is a long time I have installed it, I don’t remember if I have installed a mod.
Here is my error:

Initializing screen, fonts and sound handling: 593
Loading .lod files: 47
Scanning Data/ and Sprites/ folders:0
Preparing first handlers: 0

I don’t know how I can help because I don’t really understand how do you do exactly, but I know a little programming and 3D. If you need something you can ask me.