Nowe zamki - feedback

#1

Witam was wszystkich! VCMI bawię się już od ponad roku, i muszę przyznać, że możliwość grania nowymi miastami przyciągnęła mnie do tego projektu.

Moja stara instalacja VCMI przestała działać (a konkretnie nie dało się uruchomić żadnej gry na random map - pokazywało, że wybrane ustawienie nie pasuje). Nie wiem dlaczego tak było, może jakaś aktualizacja na laucherze to sprawiła, nie wiem.

Postanowiłem więc wczoraj zainstalować VCMI na nowo, na Heros III Complete, versja 4.0 (wcześniej też miałem na tym). Zgodnie z przeczytaną radą na tutejszym forum, tym razem nie instalowałem modów przez laucher, tylko wypakowywałem je do folderu “Mods”. Wszystko też ściągałem z tej strony: https://wiki.vcmi.eu/Mod_list W ten sposób zainstałem “VCMI essential files”. Co ciekawe, już od samego początku mam zainstalowanego HoTA (launcher pokazuje wersję 1.3.11). Ściągnąłem więc wersję 1.3.21 i wypakowałem do folderu “Mods” - okazało się, że nie mogłem zupełnie odpalić gry, a laucher wciąż pokazywał wersję 1.3.11. Nie wiem więc na jakiej zasadzie instaluje się HoTA, może wy mi pomożecie. W każdym razie usunąłem 1.3.21 z “Mods” i wszystko działa, a ja mogę cieszyć się Cove, aczkolwiek nie jest to najnowsza wersja.

Teraz przejdę do poszczególnych modów na zamki:

  1. Forge. Wcześniej używałem wersji 1.2, i działa elegancko, na obecnej instalacji też hula (mialem jeszcze instalkę na kompie). Problem jest z wersją 1.3.1 - gra próbuje się uruchomić, lecz błyskawicznie się wyłącza, także konsola, lecz nie pokazuje żadnego błędu. Po prostu nie da się uruchomić gry.
    Co do wrażeń z gameplayu (w wersji 1.2) - bardzo fajny i ciekawy zamek, wreszcie po latach dodany do Herosa. :slight_smile:
  2. Bastion/Pawilion. Wcześniej grałem na modzie ForgottenTales_v1.01, i na obecnej instalacji też działa dobrze. Wydaje się jednak, że mod “Pavillion town (2.60)” jest najnowszą wersją tego zamku. Niestety, efekt był dokładnie taki sam, jak z Forge 1.3.1 - uruchomienie gry staje się niemożliwe.
    Gameplay - ciekawy pomysł na zamek, niestety w mojej wersji parę funkcji nie było jeszcze odblokowanych.
  3. Grove - zarówno wcześniej, jak i teraz mam zainstalowany “Grove_TE_v1.0”. I działa bez zastrzeżeń.
    Gameplay - bardzo fajny zamek, dużo strzelających jednostek. Ciekawy pomysł i fajne urozmaicenie do Herosa.
  4. Abyss - używam “NewAbyss_v0.72”, i od zawsze sprawuje się dobrze.
    Gameplay - dość dziwny pomysł na zamek, ale jego “inność” przyciąga. Jednostki i budynki wydają się być wyważone.
  5. Preserve - wcześniej używałem v1.1, a teraz używam 1.1.5. Obie wersje działają bez zarzutu.
    Gameplay - pomysł na zamek może nie jest aż tak porywający jak w przy opisywanych powyżej, lecz wciąż jest to fajny i dobry projekt. Zaletą też jest dobra jakość techniczna, i zmiany poczynione w nowej wersji są jak najbardziej na plus. Pod względem samego gameplayu podobnie gra się jak Fortecą (przynajmniej z początku).
  6. Asylum - wcześniej grałem na wersji v1.01, i jakoś ten zamek nie przypadł mi do gustu. Dziwne jednostki i grafiki, oraz wywalane błędy, spowodowały, iż dałem sobie spokój. Teraz zainstalowałem jednak nową wersję 1.05 i muszę powiedzieć, że autor poprawił sporo rzeczy. Dam temu zamkowi jeszcze jedną szansę.
  7. Cathedral - dzisiaj próbowałem po raz pierwszy, lecz niestety, gdy gra się uruchamia, to pojawia się czarny ekran i… tyle. Dałem więc grę do paska i okazało, że wyskoczył jakiś error, a w konsoli było czerwono. Może znacie przyczynę problemu?

Pozostałych zamków na razie na testowałem, ponieważ w większości wydawały się być w wersjach “alpha”. No chyba, że polecacie jakieś dopracowane i stabilne zamki, działające przynajmniej tak dobrze, jak te opisane powyżej, to chętnie spróbuję. :slight_smile:

Przy okazji zgłaszam, że gdy próbuję odpalić grę na random map, tak żeby było dwóch żywych graczy w sojuszu, na sojusz samych komputerów, to nie da się tego zrobić - pokazuje, że wybrane parametry nie pasują do mapy. Musiałem więc ustawić czterech graczy i dwa teamy, i włączać grę tak długo, aż w końcu byłem w drużynie z kumplem (wiem, że wyraziłem się tutaj niejasno, ale mam nadzieję, że rozumiecie co mam tutaj na myśli - jeśli nie, to zrobię screena). To jest to, co warto poprawić (a może to tylko u mnie jest ten błąd?).
Z kwestii technicznych: Windows 10, Heros z VCMI zainstalowany na dysku D bez sytemu operacyjnego (system na dysku C, dysk D - na gry, muzykę, zdjęcia itd.).

Próbowałem też instalować “VCMI Project builds” z najnowszych dat i przy próbie odpalenia jakiejkolwiek gry, pokazywało menu z łączeniem się pod grę sieciową (ip oraz port). Wbrew radom, jakie tutaj wyczytałem, wcale nie wyłączało się po kilkunastu sekundach (ba, nawet po kilku minutach). Wersja z 3 kwietnia 2018 w ogóle nie chciała się uruchomić.

Ps. długi post wyszedł, ale mam nadzieję, że coś wniesie. :slight_smile:

#2
  1. Która wersja VCMI działa u ciebie poprawnie i testowałeś na niej mody?

  2. mody z launchera są w C:/…(folder dokumentów)/my games/VCMI/ - jest to do wyboru w launcherze VCMI w drugiej zakładce

  3. Najnowsza wersja VCMI działa poprawnie, jak ekran z IP i portem nie znika to znaczy, że coś jest u ciebie nie tak. Może ostatnie linijki z konsoli VCMI coś podpowiedzą.

  4. Miasto highlands/bastille jest w miarę OK jeśli chodzi o jakość

  5. Polecam przetestować tą wersję VCMI - https://ci.appveyor.com/project/vcmi/vcmi/builds/25965276/job/8bjcudwqtbdhggc8/artifacts, te ze strony z dziennymi buildami chwilowo mają parę uciążliwych bugów, niedługo ich nie będą mieć.

  6. Random map generator do poprawnego działania wymaga zainstalowania moda VCMI essential files - ze stronki, nie z launchera

#3

Cześć Dydzio, dzięki za rzetelną odpowiedź. :slight_smile:

  1. Wersja 0.99, ściągana z VCMI wiki, dokładny link: https://wiki.vcmi.eu/Installation_on_Windows

  2. Faktycznie, miałem w tym folderzę HoTA, oraz VCMI essential files. Usunąłem oba mody z tego folderu w dokumentach, i dałem do folderu “Mods” w głównym folderze gry. Działały poprawnie. Spróbowałem więc wypakować wersję 1.3.21 HoTY, i niestety - jakiekolwiek próby uruchomienia gry kończą się tym, że gra z marszu się wyłącza. Póki co wróciłem do starej wersji HoTY 1.3.11.

  3. Jak mogę skopiować te linijki z konsoli?

  4. Sprawdziłem i dobrze działa u mnie. Wydaje się być fajnym zamkiem, będę musiał pograć. :slight_smile:

  5. Przetestowałem tą wersję. Niestety dalej wychodzi ekran z IP. Próbowałem dwa sposoby instalacji:
    a) Zainstalowałem builda na “gołym” Herosie
    b) Zainstalowałem najpierw v0.99 + essential files, a dopiero potem na to builda.
    W obu przypadkach efekty były te same.

  6. Essential files pobrałem z VCMI wiki (https://wiki.vcmi.eu/Mod_list) i wkleiłem do folderu “Mods” w głównym katalogu gry. Podobnie zresztą, jak wszystkie inne mody.

Problem z random map w moim przypadku polega na tym, że gdy ustawiam ilość graczy i sojuszy na mapie, to mogę operować tylko opcjami “ilość graczy ludzkich lub komputerowych”. Jeśli próbuję majstrować coś przy “gracze tylko komputerowi”, lub “drużyny tylko graczy komputerowych”, to nie da się nawet uruchomić takiej gry - zawsze wyskakuje powiadomienie, że nie można uruchomić gry z taką konfiguracją. Domyślam się, że przy poprawnej bazie (dobry Heros III), oraz poprawnej instalacji VCMI z dobrego źródła, taki błąd nie powinien się pojawić?


Takie moje ogólne spostrzeżenie jest następujące: najprawdopodobniej mam VCMI oraz mody z dobrego źródła, oraz instaluję je we właściwy sposób. Problem więc może być w samym Herosie III, w systemie operacyjnym lub antywirusie. Z tych trzech wziąłbym najpierw samego Herosa pod lupę. Jaka jest najlepsza wersja Herosa III polecana przez załogę VCMI? Złota edycja, platynowa, kompletna? Czy może jeszcze jakaś inna konretna?
Bo antywirus nie robi żadnych problemów zazwyczaj, a używam Eset Smart Security.

#4

Wersja 0.99 ma już prawie 3 lata i nie polecam w nią grać. Wiele modów już jej nie obsługuje. Osobiście mogę polecić tą wersję co zalinkowałem.

Co do konsoli to można wykonać jej zrzut ekranu. Tymczasowo wyłącz antywirusa na czas uruchomienia VCMI + uruchom VCMI jako administrator, zobacz czy pomoże na twój problem.

Nie ma “polecanej” edycji heroes 3 - ważne, by zawartość z Shadow of Death była dostępna. Polska złota edycja i wersja “complete” z goga działają bez problemów. Co do problemu z random mapą to nie jestem w stanie odpowiedzieć na pytania dotyczące starej wersji 0.99 - od czasu jej wydania w VCMI naprawiono ponad 220 błędów.

#5

Ogólnie odradzam mody autorstwa planetavrila, szczególnie te, które ważą dużo MB. Chłopak bierze mody innych autorów, zbiera je w ‘expansion’ + dołącza parę swoich rzeczy, ale już kompletnie nie dba ani o przetestowanie takiego rozwiązania ani o aktualizację submodów.

I jak dydzio napisał wcześniej - sporo modów jest niekompatybilnych ze starą wersją 0.99 - daily buildy to jest to!

Tak, generator map VCMI nie potrafi ustawiać sojuszy. Potrafi tylko ustawić ilość graczy człowieka i AI. Czasami zdarzy mu się jakiś sojusz ustawić, ale robi to na zasadzie przypadku. Tak, to spora niedoskonałość gerenatora vcmi.

W niektórych przypadkach przyczyną było to, że nazwa twojego komputera zawiera znaki inne niż ‘angielskie’. Czasami odpalenia z prawami admina pomagało. Czasami.

#6

Spróbowałem uruchomić VCMI w wersji, którą mi przesłałeś. Wyłączyłem antywirusa, oraz uruchomiłem grę “jako administrator”. Efekt był ten sam co zawsze: przy włączaniu jakiejkolwiek rozgrywki, wyskakiwało menu z IP oraz portem.
Coś u mnie nie działa print sceen, ale udało mi skopiować zapis z konsoli (wywala mi błąd zawsze, gdy po raz drugi próbuję uruchomić jakąś rozgrywkę, czyli: uruchamiam VCMI -> włączam rozgrywkę -> menu z portem -> daję anuluj -> włączam jeszcze raz rozgrywkę -> wtedy wywala błąd).
Oto zapis:
Starting…
VCMI 0.99 f8c294ad0b0183539fc92f55152fb2eaa923f063 (client)
Creating console and configuring logger: 20 ms
The log file will be saved to “C:\Users\So┼éczer\Documents\My Games\vcmi\VCMI_Client_log.txt”
Initialization: 12 ms
Data loading: 283 ms
Mod handler: 2 ms
Mod filesystems: 37 ms
Basic initialization: 336 ms
Initialized logging system based on settings successfully.
[log level] ai => not set
[log level] animation => not set
[log level] bonus => not set
[log level] global => trace
[log level] mod => not set
[log level] network => not set
Error: campaign movies was not found!
Error: campaign music was not found!
Loading settings: 360 ms
Found 5 render drivers
direct3d
direct3d11
opengl (active)
opengles2
software
Check display mode: requested 1366 x 768; available up to 1366 x 768
Created renderer opengl
Initializing screen: 339 ms
Initializing video: 2 ms
Initializing screen and sound handling: 295 ms
Bonus type handler: 8 ms
General text handler: 19 ms
Hero handler: 14 ms
Artifact handler: 4 ms
Creature handler: 4 ms
Town handler: 2 ms
Object handler: 1 ms
Object types information handler: 2 ms
Spell handler: 3 ms
Skill handler: 2 ms
Terrain view pattern handler: 3 ms
Template handler: 4 ms
Initializing handlers: 67 ms
Initializing content handler: 0 ms
[cc61ac6a]Original game files
[6f973505]VCMI essential files
[a2c08213]Creature bonus icons
[d2df1d04]Default templates
[04aba660]Extra resolutions
[f3308f7c]Analogy
[b0b628cd]Clash of Dragons
[ee7f755e]Coldshadow’s Fantasy
[72776f3e]Golden Ring
[624a6077]HD Mod RMGs
File CONFIG/DEFAULTTEMPLATES/CROSS3 is not a valid JSON file!
At line 1, position 0 error: Not a valid UTF-8 file

            [9817b72e]Jebus Cross
            [21d59f47]OH3 RMGs
            [e56fa989]Upgrade
    Parsing mod data: 450 ms

no original data in loadMod(neutral) at index 9
[DONE] Original game files
[SKIP] VCMI essential files
[DONE] Creature bonus icons
[DONE] Default templates
[SKIP] Extra resolutions
[DONE] Analogy
[DONE] Clash of Dragons
[DONE] Coldshadow’s Fantasy
[SKIP] Golden Ring
[SKIP] HD Mod RMGs
[DONE] Jebus Cross
[SKIP] OH3 RMGs
[DONE] Upgrade
Loading mod data: 299 ms
Resolving identifiers: 19 ms
No templates found for 38:1
No templates found for 49:1
No templates found for 79:7
No templates found for 90:1
No templates found for 100:1
No templates found for 103:1
No templates found for 113:1
No templates found for 172:0
No templates found for 186:0
No templates found for 189:0
Handlers post-load finalization: 42 ms
All game content loaded in 811 ms
Initializing VCMI_Lib: 883 ms
Screen handler: 6 ms
Main graphics: 161 ms
Message handler: 5 ms
Initialization of VCMI (together): 2084 ms
System nie może odnaleźć określonej ścieżki.
Error: server failed to close correctly or crashed!
Check C:\Users\Sołczer\Documents\My Games\vcmi\server_log.txt for more info
Disaster happened.
Reason: 0xc0000005 - EXCEPTION_ACCESS_VIOLATION at 0023:00,E96,456
Attempt to read from 0x0A,4F0,00C
Thread ID: 1500
Crash info will be put in VCMI_client.exe_crashinfo.dmp
System nie może odnaleźć określonej ścieżki.
Error: server failed to close correctly or crashed!
Check C:\Users\Sołczer\Documents\My Games\vcmi\server_log.txt for more info

Myślę nad tym również, żeby ściągnąć sobie Herosa z tego goga. Mam Herosa, którego instalowałem u kumpla kiedyś. Może świeża instalacja samej gry coś pomoże?


No cóż, przynajmniej już wiem, że problem z generowaniem sojuszy, nie leży po mojej stronie. :slight_smile:
Ale z tą nazwą komputera, to teraz mnie zszokowałeś. Mój profil w Windowsie zawiera w nazwie literę “ł”. Aż mi się nie chce w to wierzyć, ale jeśli rzeczywiście polskie znaki mają wpływ, to właśnie może być przyczyna problemów. Czy zmiana nazwy użytkownika (tj. wywalenie polskich znaków z niej), może coś zmienić, w sytuacji, gdy system operacyjny jest zainstalowany od ponad 3 lat, i przeszedł już wiele aktualizacji?

A, moda planetavrila odinstaluję tak szybko, jak tylko daily buildy zaczną u mnie działać, i zainstaluję wtedy najnowszy Bastion/Pawilion. :slight_smile:

#7

A więc właśnie, przy menu z portem nie powinno się przyciskać ‘anuluj’ (wtedy 100% błąd), tylko samo okienko z portem powinno zniknąć po kilku-kilkunastu sekundach. A ktoś kiedyś pisał, że jemu nie znikało, i problem okazała się niestandardowa litera w profilu komputera. Nie mam pojęcia czy zmiana nazwy profilu to łatwa zmiana czy trudna - sam takowych literek nie mam…

#8

System nie może odnaleźć określonej ścieżki.
Error: server failed to close correctly or crashed!
Check C:\Users\Sołczer\Documents\My Games\vcmi\server_log.txt for more info

Jeżeli nie zamykasz okna przyciskiem anuluj i nie działa to na 95% obstawiałbym na dzień dobry problem ze ścieżką.

Czy idzie to obejść bez zmieniania ścieżki - nie wiem, być może zmiana wszystkich ścieżek możliwych do ustawienia w launcherze gry z dokumentów na inny folder by pomogła

#9

Panowie, jest postęp. Stworzyłem nowy profil użytkownika w windowsie, zainstalowałem VCMI i wszystko jest tak jak powinno być. :slight_smile: Okiento z ip i potem wyłącza się po paru sekundach i mogę swobodnie przejść do ustawiania mapy.
Dydzio, tak jak napisałeś, problemem zapewne były ścieżki z folderu “dokumenty”. Nie potrafiłem ich jednak zmienić, w lancherze jest to niemożliwe. Prościej było stworzyć nowy profil użytkownika.

Odkryłem jednak inny problem. Mianowicie, mapy generowane losowo nie zawierają żadnych elementów gry wokół niektórych zamków (mam tu na myśli surowce, skrzynie, potwory, neutralne budynki, inne elementy gry). W ogóle nie tworzą się też góry. Wiecie może, gdzie może tkwić rozwiązanie problemu?
Udzielę parę informacji, które mogę być przydatne. VCMI zainstalowałem w osobnym folderze, i skopiowałem do niego foldery “data”, “maps” i “mp3”. Wcześniej zrobiłem inną instalację: do folderu z Herosem III zainstalowałem VCMI. W obu przypadkach nie generowały się góry, a wokół niektórych zamków było pusto.

Może któryś z modów coś powoduje? Mam:

  • Essential files
  • Hota
  • Forge
  • Pawilion
  • Grove
  • Abyss
  • Preserve
  • Asylum
  • Highlands
  • Catherdal
    Wszystkie ściągnięte z VCMI wiki.
#10

W modzie Pavillion wyłącz submod Desert Objects

#11

Ok, problem rozwiązany, dzięki. :slight_smile: