Experimental Snap packages for Linux


#1

I got first working Snap package for Linux:

Added instruction on wiki:

There still more work needed:

  • Ubuntu 17.04 only: network or DNS doesn’t work for launcher.
  • Ubuntu: client crashes unless you run it with --disable-shm due to AppArmor.
  • Ubuntu: no sound at all.
  • Fedora 26: music is working, but effects doesn’t.
  • Fedora 26: videos not working.
  • SOLVED: Fedora 26: crashes on server startup when client is running through launcher. I suppose it’s due to port being opened.

Isolation with AppArmor only supported on Ubuntu so other distributions have no problems with it.


#2

I decide try to use Launchpad for Snap builds and find out our PPA was broken for a while. End up that it wasn’t updated because Bazaar import doesn’t support submodules. I tried to solve it by importing it as Git repository since Launchpad now support these, but building still fails since Launchpad doesn’t clone git recursively on build…

Still idea how to fix it.


#3

@sxx we need to package fuzzilite separately even in ppa


#4

Yeah I might try it, but that would require more work on packaging.


#5

At least at some ubuntu versions you can just reuse debian`s fuzzilite


#6

We can’t reuse it. FuzzyLite 4 and 5 are not source-compatible.
So I’ll investigate how to build FuzzyLite separately.


#7

So our PPA is building again. I’ll try to test builds of Snap on it soon.

Only problem is that would require to put snap data into main repository since Launchad tend to refuse to build unchanged source. Though another way to solve it is just auto commit empty commits daily.


#8

So I made it not fail without interprocess memory, but issues with sound still remain.
Other than that packages should be fully functional now.

Oops but yeah I forgot there is another issue: launcher fail to use network for whatever reason on Ubuntu where isolation is enforced.


#9

I’ve tried snap package on my desktop PC (Nvidia 1050, intel Q6600) on Debian 9. Vcmilauncher starts and after clicking start button I get this error:

libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast


#10

Thanks for reporting. I’ll setup Debian 9 VM eventually and see what I can do.


#11

Hello,

This is what I get when trying to run VCMI on Fedora 27 :


#12

VCMI launcher screen looks like this:


#13

And vcmiclient can’t find the H3 data already placed to $HOME/snap/vcmi/current/.local/share/vcmi/


#14

Thanks for reporting. I only tested it on Fedora 26, but once I have time I’ll check 27 release.


#15

Hello, didn’t really know where to post this so I go here. Sorry if not the best topic for it.

I wanted to know if there is a more up to date stable version that could be added to Debian repo, I need the DESTRUCTION ability to work as I’m giving a hand to someone for playtest his mod but I don’t want to use Snappy as daily builds are unstable.

Cheers, Galaad


#16

We do try to keep our daily build stable. There are some issues with my latest landed code in lobby since I not yet have time to finish it, but otherwise gameplay as stable as it might be.


#18

$ snap run vcmi.vcmilauncher
Gtk-Message: Failed to load module “gail”
Gtk-Message: Failed to load module “atk-bridge”
Qt: Session management error: None of the authentication protocols specified are supported
Failed to open file /home/USER/snap/vcmi/234/.config/vcmi/modSettings.json

EDIT Ok I could fix the last error this by replacing modSettings.json with the one from .config/vcmi and while I didn’t go any further at least game launches. I do have the same launcher manager GUI issue than posted above in this thread, maybe this has to do with the first two errors.


#19

Just in case what release of Debian are you using?
So I can test it later on once I have time.


#20

Started playing again and everything seems to work smooth. The launcher visual bug is no biggie as I can still change the settings (just need to know which blank space corresponds to what).
I’m on Debian Stretch.