"Could not create a random map that fits current choice


#1

Hi all. It feels like this must have a really simple explanation, but I can’t find one.

I installed HOMM3 Complete into a new directory. Then I installed ERA 2.46 to that same directory. Then I unzipped VCMI 0.95 to that directory. Then I ran VCMI_client.exe. New Game > Single Scenario > Random Map. No matter how I set the settings, I get the message “Could not create a random map that fits current choices.”

Any ideas?

Thanks,
David[/list]


#2

Heh - just read a reply (AlienX?) to my previous post that notes that random generated maps don’t work with VCMI right now.

What are random premade maps, though?


#3

Well, some random maps (though not playable) used to be generated under various settings, so I’d consider it a bug.


#4

By random premade I mean randomly chosen from standard/fanmade maps :wink:


#5

I have the same error in VCMI 0.98. Random Map Generator just not implemented yet?


#6

This should be sticky information:
Now in VCMI we have six RMG’s.

  1. Analogy allows you to create map size M and M+U and 4 players max (see analogy.json file)
  2. Clash of Dragons allows you to create map size min L+U max XL+U and 2 players (see clashofDragons.json file)
  3. Coldshadows Fantasy allows you to create map size XL+U and players 4-8, “cpu” : “3-6” players (see coldshadowsFantasy.json file)
  4. Golden Ring allows you to create map size M+U and L and players 3 (see goldenring.json file)
  5. Jebus Cross allows you to create map size L+U till XL+U and players 2-4 (see jebuscross.json file)
  6. Upgrade allows you to create map size S+U and M and players 2 (see upgrade.json file)

So, if you want to generate XL+U random map and 3 players, you must eneble Coldshadow Fantasy template or Jebus Cross template in mods manager and DISABLE the others. There’s nothing wrong with map generator, just threre’s so little possibilities.


#7

You don’t need to disable anything, just choose the right amount of players and map size.

For example it is impossible to generate L map with 8 players.

ALso we kindly ask modders to create new map templates (and port the existing ones).


#8

And you are sure that it works properly? Generator created map but without any roads, mines were not guarded even by 1-lvl creatures. I was reading that it will be creating ( in VCMI 0.98 ) better maps ( more playable ) than in normal Heores or in Wog. Maybe i must to change my settings? Or it’s just a project in work, not finished yet?


#9

Roads were added in 0.98c.

Mine guards depend on RMG settings. Rules are identical as in OH3.


#10

Ok. So if I will download 0.98f problem will disappear? 0.98f has all enhancements implemented in older versions? Sorry for question out of topic but only thing that i must to do is to extract VCMI 0.98f to folder with Heroes? Or in Mods Folder?


#11

Here’s the pack of good rmg templates. Maybe someone who is skilled with vcmi code will make new ports…
toheroes.com/h3maps/Random.htm
legendyheroes.uzza.pl/download-templates.html

Info frm main site:
*Installation

We recommend you first make a copy of clean Heroes Complete / Shadow of Death folder. Extract VCMI zip package there.
WoG is not needed. All recommended mods and files can be downloaded via Launcher included in the package.*


#12

That’s mean that there is a possibility even to ownload newversions of VCMI by Launcher? Where can I do it?

Or I must to extract each new version on clean heroes and delete heroes with older version?


#13

need help Old Forge Town ported from v0.96 to v0.98 yadi.sk/d/XhRgZmdCxmSHU random map generator is not working how to fix housing


#14

Lastet build VCMI+Hmm3SOD
Cant create random maps
"Could not create a random map that fits current choices."

UPD
Huuh :slight_smile: At last all works) Do not right install VCMI
what i do

  1. Make copy dir Homm3 complete or SOD
  2. Extract there VCMI 0.99
  3. Extract there too with overwrite last daily builds for Windows
  4. All work good Thanks! :slight_smile:

#15

Could you try to generate any random map with 7 players?


#16

all works exept 7 :stuck_out_tongue:


#17

Same problem with 0.99 here.

Did a clean install with vcmibuilder --gog. Is this a vcmibuilder bug?

If it’s any help, VCMI says:

libpng warning: iCCP: known incorrect sRGB profile
File <unknown> is not a valid JSON file!
At line 21, position 2 warning: Comma expected!
At line 36, position 1 warning: Comma expected!

File <unknown> is not a valid JSON file!
At line 21, position 2 warning: Comma expected!
At line 36, position 1 warning: Comma expected!

which is apparently because of the missing comma at the end of line 20 in repository.json

and later on

No templates found for 38:1
No templates found for 49:1
No templates found for 70:0
No templates found for 79:7
No templates found for 90:1
No templates found for 100:1
No templates found for 103:1
No templates found for 113:1
No templates found for 172:0
No templates found for 186:0
No templates found for 189:0

Also “VCMI essential files” mod is 0.98? The launcher says it is installed already, but I can’t find the files that comes with the VCMI essential files mod anywhere (checked /usr/share/vcmi, ~/.local/share/vcmi and ~/.config/vcmi). I manually downloaded & extracted in under ~/.local/share/vcmi/Mods/, but it didn’t fix the issue.


#18

You need the defaultTemplates mod that you can find in the Windows package… You can’t generate any kind of random map with this template but 4 players Medium for instance works for me.

For VCMI essential files I don’t know what your issue is but the linux package also lacks extraRes and bonusIcons, you can all the same grab them from the windows package


#19

hi!

Could you guys help me how can i use the random map templates? I wanna use hot seat multiplayer (3 player+few AI-s) but i cant seem to figure it out, it always says could not create random map. I can make rmg.json files with the python script tool but dont know where to put it, it doesnt show up on the launcher nor in the game (i tried to make jevus cross work since it has on option of 4 players).

Thanks :slight_smile:


#20

I found the default template mods and added ‘mines’ to it, but it still cant create a random map :confused: is it even possible to play hot seat with more than two players?