"Connecting..." window not disappearing


#1

Hello. VCMI just launched it recently to play again with the modded towns and now it’s stuck on this “Connecting” window. Previously, there was no problems and said window had disappeared after less than 10 seconds.


#2

Suggestions anyone?

Win10, tried a few things; not sure why it get stuck on “Connecting” - I just want to play with the towns/cities. It used to not have a problem connecting…


#3

Are these numbers correct?


#4

They are correct. This window should dissapear itself after few seconds.


#5

Hmm… shouldn’t port be 3030 by default? Can you attach log files?


#6

3030 is the default, but you can select any port.


#7

While it’s “connecting” which it does instantly as soon as I click Single Player, Multiplayer etc, found I can type in the port box but cannot click the check and so far there’s no way for me to stop the insta-connect attempts. logs attached; I do not know how Up-to-date they are though… (Due to having tried a couple things)

closing the Connecting Window and clicking Single Player etc leads to a crash a few secs after it tries to re-connect.

PS., none-VCMI Hota and WoG are in general perfectly fine.

vcmi logs.zip (308.3 KB)


#8

Client log has been cut out, it was still loading. Server was not even started.


#9

Yeah, that’s all it does now… I did wait about half an hour on one try, nothing…


#10

Also logs are on tracing level - it is too much for normal case and very slow. Set loggers to debug or even info level in settings.json.


#11

Mind giving directions for that?


#12

C:\Users\wild_\Documents\My Games\vcmi\config\settings.json


#13

More meant enabling the Debugger… :grinning:


#14

There you find smth like that:

	"loggers" : [
		{
			"domain" : "global",
			"level" : "trace"
		},
		{
			"domain" : "ai",
			"level" : "trace"
		},
		{
			"domain" : "bonus",
			"level" : "trace"
		},
		{
			"domain" : "animation",
			"level" : "info"
		},
		{
			"domain" : "network",
			"level" : "trace"
		}
	]

#15

Interestingly, all it has is:

Blockquote
{
“adventure” : {
“heroSpeed” : 4
},
“battle” : {
“animationSpeed” : 1,
“cellBorders” : true
},
“general” : {
“playerName” : “1”
},
“server” : {
“port” : 3033
},
“video” : {
“fullscreen” : true,
“realFullscreen” : true
}
}


#16

There was reported the same problem before. Error was in filepath.
C:\Users\wild_\Documents\My Games\vcmi\

Daily builds don’t like any other character that english letters in filepath. So “wild_” is wrong, - removing “_” should fix problem with connecting window.


#17

also you have quite old version


#18

it was the stupid port chosen in the settings.json; weird. But yay! Solved.


#19

So what is correct solution?


#20

With settings bug you mentioned port must be default 3030