Can't start any map on VCMI

I didn’t use my laptop for a long time and now I wanted to try VCMI again to check something, but it doesn’t start on any version. It starts but, no maps can be started in any way. I have no idea what it is, I just tried a clean heroes 3+0.98, then I added 0.98b, I also tried really old versions like 0.96 or 0.92.
It seems to me that it may be a problem with my computer or OS or something, but I’m just hoping it’s not that.

Creating console and configuring logger: 38
The log file will be saved to "D:\Users\Nikola\Documents\My Games\vcmi\VCMI_Clie
         Initialization: 54
         Data loading: 612
        Mod handler: 2
         Mod filesystems: 446
Basic initialization: 1117
Initialized logging system based on settings successfully.
Error: campaign movies was not found!
Error: campaign music was not found!
Loading settings: 1176
VCMI 0.98 (client)
Found 4 render drivers
        opengl (active)
Created renderer opengl
        Initializing screen: 1793
        Initializing video: 6
Initializing screen and sound handling: 848
                Bonus type handler: 13
                General text handler: 36
                Hero handler: 20
                Artifact handler: 4
                Creature handler: 6
                Town handler: 5
                Object handler: 4
                Object types information handler: 14
                Spell handler: 12
                Terrain view pattern handler: 11
        Initializing handlers: 135
        Initializing content handler: 321 ms
                [46da28ea] Original game files
                [2c8d50bc] VCMI essential files
                [a3bdb941] Creature bonus icons
                [86df8906] Extra resolutions
        Parsing mod data: 131 ms
                [DONE] Original game files
                [SKIP] VCMI essential files
                [DONE] Creature bonus icons
                [DONE] Extra resolutions
        Loading mod data: 568ms
        Resolving identifiers: 22 ms
No templates found for 49:1
No templates found for 70:0
No templates found for 79:7
No templates found for 100:1
No templates found for 103:1
No templates found for 172:0
No templates found for 186:0
No templates found for 189:0
        Handlers post-load finalization: 115 ms
        All game content loaded in 1163 ms
                Template handler: 1196
Initializing VCMI_Lib: 1326
Loading and transforming heroes' flags: 203
Screen handler: 228
        Main graphics: 131
Initializing game graphics: 374
Message handler: 13
Initialization of VCMI (together): 6385
Blocking buttons from 1
Cannot open interprocess memory.
boost::interprocess::intermodule_singleton initialization failed
Disaster happened.
Reason: 0xe06d7363 - UNKNOWN EXCEPTION at 0023:75,60C,42D
Thread ID: 5708 [5708]
Crash info will be put in VCMI_client.exe_crashinfo.dmp

This is the problem (and it is OS related), but I have no idea why it may happen.

I thought so too. What is interprocess memory?

Well I got many bugs recently.
I hear the folder open sound every time I start windows.
Windows explorer doesn’t refresh when I do anything, like copy-paste, create a folder…
My windows says “it’s not geniune” and since then, my desktop background is always black.
Media player classic freezes completely when I press the “file” tab, but I don’t think the problem is in the player itself.
Some other bugs that I can’t remember as well.
I thought it was a virus so I scanned with my AVG antivirus and McAfee, but it finds nothing.

Today I uploaded a folder on onedrive and I noticed a file called “desktop.ini” inside of it. And the folder was just created, I wanted to check something. Is that a virus maybe?

I know this topic can get away from VCMI, but I would really appreciate any help. :unamused:

“desktop.ini” is normal windows file (it controls folder view), but may be used by viruses.

so it should exist in every folder?
Then I guess it’s not a virus. I will probably install a new windows soon, but I want to delete as many things as I can.

No only in some folders, if it exist in every folder it is most likely virus

Speaking of this virus, can you check running processes in task manager to ensure there is no suspicious process running or something like that (assuming that virus will be visible as a process)?

In case when virus behaves as a service (not visible in task manager), you can try this - it’s an improved viewer of all running services and alike on your machine.

I wonder did you find out what caused problem for you?

Also any chance you was running Windows 7 32-bit back when it’s happen?

So as far as I get from internet problem may occur when boost::interprocess failed to get temporary directory on Windows as it’s use following registry key by default:

SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders\Common AppData

It’s may occur when user modify registry with tools like CCleaner, but can be fixed by system reboot. It’s should be possible to bypass that problem by setting “BOOST_INTERPROCESS_SHARED_DIR_PATH” so boost store shared memory in some other directory on Windows. Will look into it.