0.72 bugs and issues


the error occurs in last build and it’s simple fixup to change one variable name in a code…
could you fix this? PLEASE

#53 - We still have redundant quotation marks in artifact description (a fix is mentioned in the changelog, but either it refers to sth else, or it didn’t make it to the 0.72 package):

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090621-RedundantQuotationMarks.jpg (VCMI)

#54 [size=75](similar to #46 and hardly a bug)[/size] - As seen in the screenshot above, the artifact name is displayed on 4 rows, because the number of maximum characters per row is smaller as compared to H3:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090621-H3HelmoftheAlabasterUnicornc.jpg (H3C)


I found a better example of the result of limiting the number of characters in the artifact name:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090710-GarnitureOfInterference.jpg (VCMI)

Should be fixed now.

ok hero bug fixed…

but new anim for tavern is probably displayed as in wrong format (let be bug #55)
(not whole animation box used, animation is very gray, animation looks like semi-random dots)

EDIT: I have forgotten about another bug
there it is
#56 hero can begin exchange with himself sometimes (if not always) when clicking space

What screen depth do you have set? It works fine for me.

Some issues with the Load a Saved Game screen:

#57 The screen opens in VCMI with the games apparently sorted: first by Number of Players and second by Map Version. In H3, the screen opens with games sorted: first by Map Version and second by Scenario Name.

#58 Sorting by Scenario Name does not work at all.

#59 Sorting by other categories works, but only ascending. A second click on the column header should sort in descending order.

#60 The map save date & time text is more detailed than H3 - which is okay - but perhaps because of the fonts used, it seems a bit too long in terms of occupied space:

http://i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/090628-VCMIMapSaveTime.jpg vs http://i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/090628-H3MapSaveTime.jpg

The real “bug” here however is the square character at the end of the VCMI Save time. It is redundant, unless you are planning to give it a certain functionality in the future. And I’m thinking here of some sort of button in this interface what would order the maps by date/time (the only option I felt was missing in H3). :wink:

#61 If a resource pile is at “0” and we have an event attempting to reduce that pile, not only should the pile not go under “0” (bug fixed in one of the previous versions), but also the event message window should not display that resource anymore.

e.g.: Start of “Adventures of Jared Haret” map on Impossible level, H3 vs VCMI:

i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090628-H3JaredHaretOnImpossibleStar.jpg vs i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/th_090628-VCMIJaredHaretOnImpossibleSt.jpg

32bit desktop and 24bit vcmi (the default)
moreover intros work very well

Found one more issue in the Load a Saved Game screen:

#62 The Load interface opens with none of the Saved Games preselected, but actually with the game that would be first in the list in the New Game screen. We can even press on Load and the new game starts.

#63 Lean To says it’s “long abandoned” at first visit already.

#64 I lost the First Aid Tent in a battle, but hero still had it afterwards. Well, I think it still had it - I only noticed it the day after when I went back to my town to buy a new one, and I got a message that I already have one.

So far I haven’t managed to convince :stuck_out_tongue: any enemy to shoot in my War Machines again, to see if it’s reproducible. As I’m not 100% sure the tent disappeared after the battle, if you guys cannot reproduce it, try also buying a new one after you lose it in battle.

#65 Crash when trying to buy First Aid Tent after attempts to move all creatures into Garrison (very hard to reproduce):


Based on the error msg in the console - “Cannot take the last stack” - I figured the crash may have something to do with the fact that before trying to buy the Tent, I tried in different ways (creature overlap, splits) to move all creatures in the garrison (thus trying to leave the hero with no creatures, which shouldn’t happen). 5-6 attempts to reproduce it failed, until I remember also checking the Mage Guild first time when the crash happened.

Here is what I did the 2nd (and only) time I managed to reproduce it:

  • Load Autosave_2 game (attached below)
  • Go to Tavern and recruit Aeris
  • Move Elves & Dwarves in Garrison
  • Replace Dwarves with Centaurs
  • Open Mage Guild
  • Try to buy Tent
    (which is very close to the steps I took first time when I had the crash)

To my frustration however, I didn’t manage to reproduce it a 3rd time after trying the above steps, so I still don’t know exactly where the bug is. I hope you guys will find the answer in the attached logs.

Not sure if related in any way, but I remember that when I loaded Autosave_2 before the successful attempt of reproducing the crash, the game was 3rd in the list of Saved Games. However after that, next 5 times I went in to load the game, it was always in “its place” among the other Autosaves as below:

090706 - Crash when buying Tent.zip (107 KB)

Removing war machines after they are destroyed is not implemented yet.

Is it possible that you r-clicked on hero in tavern window before recruiting Aeris? Then it would be known bug with crashes after r-click on hero portrait.

Yep. That was it… The console message (which I realize now it was not even an error, as it was in white fonts) misled me to think it had something to do with the movement of creatures to Garrison.

Strange bug… I wouldn’t have thought that right clicking on a hero in Tavern, can cause a crash if we buy a War Machine for another. :-/

Tow, you should release a windows version every week to avoid this kind of problem.
Release early, release often.

And I wonder whether it’s possible to register with MS to get those dumps ?

[size=92]Well, from a tester’s perspective, I admit every new built makes me wanna “give it a try”. On the other hand, every week might be a bit too frequent for me to keep up (can’t speak for the others though). It takes me about 2 weeks to explore a map fully, build my town and my heroes. But we had more frequent releases before - so I guess it’s because of the exams Tow (and TowDragon?) recently had that June was pretty quiet… :slight_smile:

However I took a short vacation next week, which I’m gonna spend at home, resting. Which means a lot of time for testing. So it would be great if you could release a dev version this week-end, as I guess there is quite a number of bugs already fixed. ;)[/size]

It means much work for me with moving bugs to the tracker (I don’t know if it’s localization or the servers are overloaded but it works usually very slow for me…), preparing changelogs and explaining which features are half-done and should not be reported.
I prefer to release new build when we have some new features / important changes done that can be tested as the whole. For now the main developed feature (exchange screen) is still missing one of its important functionalities (exchanging artifacts) and we still have a lot of unresolved issues from 0.72 build. Many of them are related to battles, spells, units abilities what is domain of TowDragon who left us for a several days to enjoy his holidays.

Nevertheless I see your point. There are some annoying bugs in 0.72. I’ll try to check and fix possibly many issues and post a new build by the end of this week.

[size=84]Moving bugs to the tracker can be quite time consuming, I’ve noticed. Nevertheless, I’ll try to help with that sometimes, by adding at least my reported bugs to start with (also because I better know what’s it about). Regarding change logs, maybe it’s not necessary to go too much in detail for development version. We can see in your replies from the previous release thread which bugs have been fixed. So only thing still needed would be shortly mentioning the new features added (and which incomplete). But that, only if you think it could help you. I very much like how the project is organized so far, with the new posts/threads for new releases and all details shared. Wouldn’t wanna push you into changing your approach.[/size]

Issues related to the Fountain of Fortune:

#66 This is probably meant as a feature, but I just wanted to double check: H3 was showing only 1 horseshoe when the fountain was giving +1/+2/+3 Luck bonus. VCMI is showing as many horseshoes as the Luck points gained. I actually like it that I don’t need to open hero screen to see what was the exact bonus, so if you meant it as a feature as well, please disregard this.

#67 This however is a valid issue I believe: H3 used to randomly give -1/+1/+2/+3 Luck penalty/bonus. If I’m not mistaken, the chances of getting 1 of the 4 possibilities were pretty equal. In VCMI however, after 10-15 tries, I got once +3, once +2, but in the rest, a lot of +1 or +0 occurrences. Which brings me to the next “bug”:

#68 I may be mistaken, but I believe H3 Fountain never left the luck unchanged. In VCMI however we get quite often “+0”, and it’s even displayed as such in hero screen:

http://i4.photobucket.com/albums/y104/Zamolxis/VCMI/VCMI%2007/090710-Fountain0.jpg (which I don’t think I ever saw in H3, if the memory serves right)

And somehow related:
#69 - I see Luck is implemented since 0.71, but after playing like 50 battles, I have the feeling I haven’t seen any horseshoe spinning above my creatures, even on heroes with Expert Luck. Is the animation not implemented yet, or was I just unlucky? :stuck_out_tongue:

#70 - After searching through a broken Wagon, I was very happy to find the [size=125]’%s’[/size]. Now I’ll just have to take care I’ll put it to good use. :stuck_out_tongue:

I’ve managed to review issues up to #51. Soon the rest.

For now I’ve disabling saving on first turn after starting new game or loading.


AFAIK this behaviour is same as in H3.

I haven’t reproduced it. Either has been fixed or I had (bad?) luck.
Please check in the next build if this problem is still present and if possible tell how it’s reproducible.

#13 confirmed.

Could you post an example of such map for tests?




Treat it as feature :slight_smile:

Hmm… not a bug imho. Console window is only for testing and debugging purposes, it’s not a part of the actual game. Load command is for future use when it will be possible to load game without closing VCMI (or rather as help for developing that functionality).

Fixed by Tow Dragon.

Fixed by Ubuntux.


Probably fixed.


Not bugs.

AFAIR was fixed. (i’m not sure, please check when the next build is ready)

Seems to be fixed.

May be also a effect of r-click in tavern.

Wow. So many fixes ('guess it’s our turn to say “Thanks. I love you.” :mrgreen:) . I’m very much looking forward to the next release. :slight_smile:

Bug #51 may indeed be caused by r-clicking in Tavern (the “unreproducible” bug suddenly became very reproducible when I tried that:).

There are two other reported bugs for which I was looking for a resolution: #26 (experience needed for level-ups) & #47 (maybe fixed together with #27?) - or are they postponed for the next release?

Something I almost wanted to report as a bug, but then I realized it’s actually meant to be like this, is the message we get after visiting Warrior’s Tomb. I have to say kudos for the way you implemented it. :slight_smile: It was a very good idea to add the morale penalty next to the found artifact (though again, I’d expand the number of chars/row here as well):


#71 : Crash when attacking the L7 monster on tile 33x22 in the All for One map (not reproducible).


As you can see, it crashed in the moment when the battle screen opened, without displaying the creatures or even the frame of the battle screen.

Please check the attached logs, as I wasn’t able to reproduce it. I reloaded the attached saved game 3-4 times, played all other heroes the exact way I remembered I played them before the Sephinroth’s battle (I just don’t remember exactly which objects I may have right clicked), but when I got to Sephinroth, attacking the Angels didn’t recreate the crash. I’m pretty sure I didn’t go to the Tavern on that day to r-click a hero. But anyway, I thought that bug only triggered a crash when picking artifacts on the map (and that does happen, when I pick the Sandals of Saint after defeating the Angels). R-clicking Tavern heroes however did not recreate the crash when attacking the Angels.

#72 : After one of the failed attempts of reproducing the above crash, I ran into a battle bug while fighting the Angels: Dragon failed attack, followed by mouse cursor lost from the client interface; meaning I was not able to click on anything to continue the battle or the game.

Battle steps that led to it:

  • Attack Angels with Sephinroth using the attached game for #71
  • Round 1: Angels move close, Cast Lightning Bolt on Angels,
  • Dragons Wait, Shoot with Elves & Beholders, Harpies Wait
  • Attack with Dwarves (Angels retaliate), then with Troglodytes, Harpies & Dragons
  • Round 2: Angels attack and kill all Elves
  • Cast Lightning Bolt on Angels, Dragons & Harpies Wait, Shoot with Beholders
  • Attack with Dwarves (Angels retaliate), then with Troglodytes & Harpies
  • Then I flied the Dragons in an attempt to attack from below, I had the attack animation, but the attack produced no damage (no “hit” animation/sound on Angel) and then also the mouse cursor disappeared from the interface, with no way of bringing it back to continue the game


By following the above steps, I didn’t manage to exactly reproduce it, mainly because AI did not always attack my Elves in round 2. I noticed it depends on how you place your troops around the Angel in round 1 (Dragons in front, the other melees attacking from the hexes behind). However I did have it that a couple of times the Angels froze after retaliating against the Dwarves, which may be the actual cause of the bug itself. After the Angels froze, again the mouse cursor was lost. I couldn’t even close the game interface from the upper right cross button (maybe if I would have waited after clicking on it?). I was able to close it from the Console, getting an error message afterwards. You’ll probably be able to reproduce it, otherwise see if the logs are of some help.

#73 : AI doesn’t recognize the front hex of a 2-hex creature (or so it seems). During my attempts to reproduce the above bugs, the Angels were sometimes flying just in front of my Dragons (like in the screenshot), but were never attacking them. It’s not easy to reproduce, as the AI moved the Angels there in only 3 of my 15 replays of the battle, but in those 3 cases, the 8 Angels flew there without killing my 2 Dragons (which should have been the logic choice for the AI: the only reachable enemy, and not a large stack of shooters, to make sense that they go there for blocking purpose):


#74 : Enemy creatures should have their hex shaded if they are within the attack range of the active creature (melee+range). This is just a detail, but if we want to implement this exactly like in the original H3, the Angel in the screenshot above should have its hex shaded, same as the Gold Dragons and Pixies have it in the H3 screenshot below.

*As a reminder, in the screenshot above we can see again the misplaced stack numbers reported as 0.7#71 (in Aidis’s post they were under the wrong creature, here they are overlapping - but basically it’s the same problem). Please find below the rules regarding the correct placement of these stack number boxes, explained in all necessary details I believe:

  1. The creatures in the attacking army (left side of the battlefield) have the default position of the stack number box in the lower part of the hex in front of them, attached to the line separating their (front) hex and the hex in front containing the box (see Monks, Pikemen, etc in the screenshot below)

  2. The creatures in the defending army (right side of the battlefield) have the default position of the stack number box in the upper part of the hex in front of them, attached to the line separating their (front) hex and the hex in front containing the box. The purpose of that is that when there’s an empty hex between a friendly and an enemy creature, both boxes can be displayed without overlapping (see 1 Archangel facing 2 Gold Dragons in the upper right side of the screenshot below)

  3. When the hex in front of a creature is occupied by any type of obstacle (other creature, war machine or terrain obstacle), the stack number box moves inside the hex of the creature, centered (see Paladin below). For 2-hex creatures, it is placed in the front hex of that creature, but again centered (see 1 Archangel facing 2 Diamond Dragons below)


  • If a creature is in one of the hexes on the opposite side of the battlefield, the end of the battlefield is not considered as an “obstacle”, hence their stack number box is still shown in front of them (out of the hexed area, still attached to the side of creature’s hex).
  • Dead creatures are also ignored, so we may have a stack number box in the hex of a dead stack
  • Castle Walls are considered an obstacle, but moats (or similar) are not.
    (I forgot to include these 3 situations when I prepared the screenshot below)

[size=75](comments added to 0.7#71 on SourceForge as well)[/size]*
090711 - Crash when attacking monster at 33x22 on All4One.zip (105 KB)
090711 - Cursor lost after Dragon failed attack.zip (4.61 KB)