Windows version hangs with "Not Resonding". Same bug as on GitHub

Hi there people. Long time fan (amazing project you’re doing, TITANIC effort), finally decided to install again (after previous 2 tries it failed). Well, it fails this time too, but I decided to go online :slight_smile: . IIRC, I had the same “not responding” behavior as last time. You can go technical with explanations if you want, I’m a game developer/engineer :slight_smile:

Reported this on GitHub too, here (Windows) Client hangs on white screen on launch · Issue #1058 · vcmi/vcmi · GitHub (hopefully somebody will see it, because by default the list is not sorted by latest updated)

I installed VCMI extensions. The application starts, but hangs. It only produces about 388 KB of log, before dying, always at the same line of the log.

My log is also just 14 KB to begin with, but if I kill the process, the log actually increases to 388 KB. Same behavior every time.

DEBUG mod [7d70] - Converting specialty format for hero roland(castle)
TRACE mod [7d70] - “specialty” : {
“base” : {
“duration” : [ “PERMANENT” ],
“limiters” : { “type” : “CREATURE_TYPE_LIMITER” },
“source” : “HERO_SPECIAL”,
“sourceID” : 152
“bonuses” : {
“attack” : {
“limiters” : { “parameters” : [ “griffin”, false ] },
“subtype” : “primSkill.attack”,
“type” : “PRIMARY_SKILL”,
“updater” : {
“parameters” : [ 8, 3 ],
“attack2” : {
“limiters” : { “parameters” : [ “royalGriffin”, fal

I can only guess but it seems that something blocks client-server connections at some points. Maybe disabling some kind of windows protection apps (external or build-in) or add VCMI_client.exe/VCMI_server.exe to whitelists will help?

Hi there :). Guesses are welcome. I disabled Windows firewall. Same result. However, nobody told me that I have to start VCMI_server.exe. In any case, I started it, firewall off, and same result.

have you already tried changing video driver via editing settings.json? in the beginning of the client log all available drivers are written.

My settings.json (from \Documents\My games\vcmi is very, very short :). I can paste all of it here.

“video” : {
“screenRes” : {
“height” : 1080,
“width” : 1920

Ok, I looked in the file you indicated and inferred that I should be adding a “driver” entry in the JSON. I tried direct3d, direct3d11 and software. Neither worked.

Are you sure this is a driver issue? It seems very strange that it always stops at Roland’s config.

You don’t have to start VCMI_server.exe, game starts it itself. But sometimes firewalls block client-serwer architecture connections.

Another guess. Is it possible that your H3 assets can be broken somehow? Your H3 game starts normally when installed in diffirent folder?

Yup, I got Heroes 3 complete :slight_smile: , the one from GOG, as was recommended. I ran the game, up to the first fight in the campaign. No issues :frowning: . Would be interesting to play up until where Roland shows up, but I doubt that’ll show anything. Tried to add him with the Map Editor but apparently I can’t add special heroes. Can’t I enable some sort of verbose logging, to see exactly what’s going on with Roland’s data?

Another idea :slight_smile: Try to install in separate folder old vcmi 0.99 version and check if it started :slight_smile:

correct, “driver” field under “video”. at least it helped the OP of the GitHub issue.

as an alternative, you can use the classic map editor from original Heroes 3