VCMI - strasznie zacina, co zrobic?


#1

Zainstalowalem wczoraj VCMI i niestety strasznie mi zacina podczas gry.
Generalnie to klatkuje gierke(Podstawa to homm3 complete gog)

Nie mam zadnych modow wlaczonych nawet.
Gra wyglada jakby mi dzialala w 15 fpsach.
Jakies porady? Co mam podac.
Dodam ze czasami gra dostaje fatal errora i sie wylacza


#2

Skasuj plik open32.dll (czy coś podobnie) z głównego katalogu herosów.


#3

Usunalem i pomoglo czesciowo.
Obecnie od 20-40 fps wiec na pewno komfort duzo na plus.
Czy jakies inne porady ?
Dodam ze gram na niskiej rozdzialce w oknie.
*Jest to czysto zainstalowany VCMI.

  • Komputer obsluguje nowsze gry, wiec watpie ze to wina tego ze jest “za slaby”
  • No chyba ze wina jest to, ze ja ten caly folder VCMI skopiowalem do glownego folderu heroes ?

#4

Nie, zrobiłeś dobrze. Ja już nie mam innych porad. A spróbuj inne rozdzielczości. Jaki system? Podobno xp nie jest wspierany. I fakt, vcmi nie chodzi tak plynnie jak normalne herosy, ale na technikaliach się nie znam.


#5

Skąd pobrałeś vcmi? A może zbudowałeś włąsnoręcznie z kodu źródłowego?

Weź VCMI stąd: https://builds.vcmi.download/branch/develop/Windows/

Pobierz najnowszą wersję - to jest instalator.


#6

Jakiego FPS oczekujesz? Większość animacji w Herosach ma dosłownie kilka klatek na sekundę, więc nic się nie da tu poprawić.


#7

oczekuje zeby dzialalo tak jak normalny heroes 3 albo chociaz zeby lekko gorzej.
Problemem zaczyna sie pojawiac gdy rozgrywa przypomina klatkowanie i nie widac nawet jak postac idzie do jakiegos celu, tylko jest scina - pojawia sie obraz w polowie - scina - jest u celu.
Uprzedzam od razu ze ustawienie w opcjach aby postac pojawia sie do celu od razu tez nie pomaga.


#8

U mnie tak zdecydowanie nie jest - pobierz nowe vcmi z tego linka co wyżej dałem i sprobuj zrobić tak:

Jak sciągniesz to instalujesz do jakiegoś nowego folderu. Kopiujesz foldery “data”, “maps” i “mp3” z heroes 3 i wklejasz tam gdzie zainstalowales vcmi do glownego folderu tzn tak żeby foldery data, maps leżały obok folderów config, mods, AI.


#9

@Dydzio
Dzieki piekne, zainstalkwoalem najnowsze przez instalator i juz mi nie scina :slight_smile:

Naprawione !