Vcmi map editor looks strange in 4k resolution

In 4k resolution, system font size is often set to 200% or 300%. So some mapediton window look strage. Some window size only consider 100% case. It will be too small.


for a quick workaround please try editing and setting vcmieditor to CFBundleExecutable value (now it has vcmilauncher), after this launch the editor by opening
if this works, we’ll add proper fix

I run it in Windows, not Mac. In order to adjust high resolution like 3840x2160, Windows can set all display text size to 200% or even 300%. Other software like vcmi launcher text in it is OK. Only editor occurs this problem.

Oh sorry, I must have been blind :slight_smile:

Does launcher have the same issue or it looks correct?

For now I can only suggest to try workarounds described in High DPI | Qt 6.4 - Windows section

Launcher looks all OK. I think if the window become bigger. Make it twice in 200%, maybe can solved? I am not familiar with QT.

The document you provided seems can solve this problem.

could you share your exact solution? it would be helpful for others.

I dont know what should to do. My idea is only a guess(if a window is 200x200, in 300% it should be 600x600). I am not sure if it can help to solve this problem.

but why don’t you want to try solutions from the Qt document? it doesn’t require any programming, only creating/editing a text file and/or adjusting system environment variables.

sorry, I misunderstand the sulotion.
add qt.conf make everything right.
but add system environment variables make things worse.
so only add qt.conf seems can fix this problem.

1 Like

And I find a bug:
If I just start the map editor and not create a map. Some operation like clicking player setting in the menu will lead map editor crash.