VCMI_launcher działa przy wersji 0.95 a przy 0.96 już nie

#1

Jak w temacie, launcher działa w 0.95 a w 0.96 już nie.
Instalowalem paczki c++, netframework jest.
Przy 0.96 wyskakuje słynny “is not valid win32 application”

HOW TO FIX? :slight_smile:

#2

Wydaje mi się, że jak na razie jedynym sposobem jest kompilacja projektu własnoręcznie, bo uruchomienie Launchera na XP’ku jest niemożliwe (z powodu tego erroru). Na stronie wiki tego projektu Mixaill napisał świetny tutek, jak to zrobić za pomocą CMake’a. Ja na przykład pozbyłem się tego błędu w taki sposób, więc jakby były jakieś pytania (na które oczywiście będę w stanie odpowiedzieć) to wal śmiało.

#3

To dlatego, że wersję 0.96 kompilowałem ja, używając bibliotek, które nie są zgodne ze starszymi wersjami. Zostanie to naprawione w następnej wersji.

#4

Jeśli tak, to dobrze, bo jednak kompilacja za pomocą MinGW jest trochę niewygodna.