VCMI for macOS


#121

Warning: oops! they pretty much broken for anyone except me. Still require some work!

First new automatically created macOS build is available here:
builds.vcmi.download/PR/362/mac … d0eb65.dmg
As soon as I finish my work on packaging it’s will be merged into upstream builds!

Keep in mind you need to manually extract “Data”, “mp3” and “Maps” folders into:

~/Library/Application\ Support/vcmi/

Also there are crashes I didn’t have time to look at yet, but it’s possible to play a bit, AI working, etc.

UPD: Tested Mac vs Mac multiplayer, works nicely so far.
Mac (Clang) + Windows (MSVC) + Linux (GCC) able to join lobby, but then freeze on start. :stuck_out_tongue:


#122

Ok now builds are fixed for sure and should soon appear here:
builds.vcmi.download/branch/develop/macOS/


#123

latest 0.99 nightly build on macOS 11.12.6
Unable to change resolution other than 800x600
And instruction? Thanks


#124

Yes, add vcmi essential files from here https://wiki.vcmi.eu/Mod_list#Utilities


#125

As @misiokles posted for now you need to download them manually and unpack them into:

~/Library/Application\ Support/vcmi/Mods/

In about a month it’s should become possible to install these mods from launcher.


#126

Thanks for the instruction, it works!


#127

Hello… Anyway to get work on OSX 10.10.4 (Yosemite)… or must be complie on Yosemite… and If I complie it should work on Yosemite? and dipendences?


#129

Hello. I figured out my old problem but now I got a new one so I edited this post.

I can’t cast damaging spells. It just says “Unknown problem with this spell. No more information available.”

No further information in the client. Any suggestions? Thanks.


#130

I am experiencing the same issue with spells (“Unknown problem with this spell. No more information available.”) using build VCMI-branch-develop-b2faf30.dmg (05-Mar-2018 19:28).

Neither direct damage spells work (magic arrow) nor indirect (fire wall). Other spells seem to work just fine.


#131

You are not using any mods? Right?

I’ll test it in my macOS VM as soon as I get some free time.


#132

No, no mods.


#133

Thanks for report. I can confirm problem actually exists. and added bug report here:

I’ll able to work on problem for sure in about a week since running xcode / qt creator in VM on my laptop might be little too slow.


#134

Ok just in case we find out why exactly problem occur and it’s should be possible to resolve it fairly soon.

UPD: Fixed: