VCMI for macOS

#114

Hello everyone. If there are any MacOS users who wish to help me with new builds testing please join our Slack:
slack.vcmi.eu/

I already setup automatic build uploading from Travis CI, but Mac builds are broken here and my ability to test them limited since I only have MacOS in VM and I sadly don’t have any Mac compatible GPU to passthrough here.

#115

Ran into the following error on OS/X 10.10.5:

– Found PkgConfig: /usr/local/bin/pkg-config (found version “0.29.2”)
– Checking for module ‘libavcodec’
– No package ‘libavcodec’ found
– Checking for module ‘libavformat’
– No package ‘libavformat’ found
– Checking for module ‘libavdevice’
– No package ‘libavdevice’ found
– Checking for module ‘libavutil’
– No package ‘libavutil’ found
– Checking for module ‘libswscale’
– No package ‘libswscale’ found
– Checking for module ‘libpostproc’
– No package ‘libpostproc’ found
CMake Error at /usr/local/Cellar/cmake/3.5.2/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:148 (message):
Could NOT find FFmpeg (missing: FFMPEG_INCLUDE_DIRS AVCODEC_LIBRARIES
AVCODEC_INCLUDE_DIRS AVFORMAT_LIBRARIES AVFORMAT_INCLUDE_DIRS
AVUTIL_LIBRARIES AVUTIL_INCLUDE_DIRS SWSCALE_LIBRARIES
SWSCALE_INCLUDE_DIRS)

Fixed with (probably - installed a few other libs in the process):

brew install ffmpeg

may want to add this to the install instructions. Also the link to sparkle download is outdated (no longer exists).

#116

I almost fixed DMG build, but there is something seriously wrong with Qt magic that make it possible to avoid system libraries usage instead of one bundled with DMG. Though this shouldn’t be a problem for players who don’t have Qt installed system-wide with brew.

I really can’t find out whatever it’s fixed in 5.9.1 or not:
bugreports.qt.io/browse/QTBUG-56814

Also I have weird time with CMake FIXUP_BUNDLE due to one of Boost libraries, but I guess this one would be easier to solve.

#117

Ok problem with Boost library were caused by fact that none of our executables now use “boost-test”, but it’s dependency was still put into the bundle while CMake failed to find what executable need that library. Fixed it by removing it:
github.com/vcmi/vcmi/commit/1b9 … feb27d7757

#118

Sadly can’t fix problem with CMake and BundleUtilities, not many answers are there:
stackoverflow.com/questions/356 … pplication

All I can find is “don’t use bundle utility for Qt” :slight_smile:

UPD: Nice guy @l2y on #qt IRC pointed me to this Kitware project:
github.com/OpenChemistry/avogadroapp
I’ll try to reuse their Qt deployment for VCMI.

#119

Okay all other comments will be on github:
github.com/vcmi/vcmi/pull/351

#120

Starting of game still crashing because of some issues with AI, but builds should have all needed deps for client ans sever bundles:
builds.vcmi.download/PR/351/macOS/

#121

Warning: oops! they pretty much broken for anyone except me. Still require some work!

First new automatically created macOS build is available here:
builds.vcmi.download/PR/362/mac … d0eb65.dmg
As soon as I finish my work on packaging it’s will be merged into upstream builds!

Keep in mind you need to manually extract “Data”, “mp3” and “Maps” folders into:

~/Library/Application\ Support/vcmi/

Also there are crashes I didn’t have time to look at yet, but it’s possible to play a bit, AI working, etc.

UPD: Tested Mac vs Mac multiplayer, works nicely so far.
Mac (Clang) + Windows (MSVC) + Linux (GCC) able to join lobby, but then freeze on start. :stuck_out_tongue:

#122

Ok now builds are fixed for sure and should soon appear here:
builds.vcmi.download/branch/develop/macOS/

#123

latest 0.99 nightly build on macOS 11.12.6
Unable to change resolution other than 800x600
And instruction? Thanks

#124

Yes, add vcmi essential files from here https://wiki.vcmi.eu/Mod_list#Utilities

#125

As @misiokles posted for now you need to download them manually and unpack them into:

~/Library/Application\ Support/vcmi/Mods/

In about a month it’s should become possible to install these mods from launcher.

#126

Thanks for the instruction, it works!

#127

Hello… Anyway to get work on OSX 10.10.4 (Yosemite)… or must be complie on Yosemite… and If I complie it should work on Yosemite? and dipendences?

#129

Hello. I figured out my old problem but now I got a new one so I edited this post.

I can’t cast damaging spells. It just says “Unknown problem with this spell. No more information available.”

No further information in the client. Any suggestions? Thanks.

#130

I am experiencing the same issue with spells (“Unknown problem with this spell. No more information available.”) using build VCMI-branch-develop-b2faf30.dmg (05-Mar-2018 19:28).

Neither direct damage spells work (magic arrow) nor indirect (fire wall). Other spells seem to work just fine.

#131

You are not using any mods? Right?

I’ll test it in my macOS VM as soon as I get some free time.

#132

No, no mods.

#133

Thanks for report. I can confirm problem actually exists. and added bug report here:

I’ll able to work on problem for sure in about a week since running xcode / qt creator in VM on my laptop might be little too slow.

#134

Ok just in case we find out why exactly problem occur and it’s should be possible to resolve it fairly soon.

UPD: Fixed: