VCMI essential files problem

I have the lastest version from the daily builds PPA: 0.99+git20170613.4676~ubuntu14.04.1

However, it seems the VCMI essential files are from 0.98.

First, I tried to update them from the launcher, but it gives me this errors:

Encountered errors:
vcmi: Mod must be disabled first
vcmi: Mod is already installed
vcmi: Mod is already enabled

I tried to disable it and to unistall it. And then I got the following error

Encountered errors:
vcmi: Failed to delete mod data

I came here to post about the issue and I encountered this topic ([ where Tooandorisu says that the essential files aren’t suposed to be updated. Now I’m confused, because the client tells me they are updatable and the version shown is 0.98.

What should I do?

As Tooandorisu said you should not update them, ever. Problem is that automated builds doesn’t contain some things like extra resolution, but unfortunately they are not in mod repository anyway.

So our core mods is a mess at moment and all you can do is just wait until we fix them. Though game should be fully functional even without those additional mods.

Thank you for the quick response.

Still, I have a doubt. I have the lastest build from the PPA (0.99) but the client says the essential files are from 0.98. I’m not sure I have indeed the lastest version or not and if I should report bugs or not. If I have indeed the 0.98 version effectively, maybe those bugs don’t happen in the 0.99 version.

Our core mod file can’t really affect anything other than icons in menu and some UI backgrounds. Additional sub-modes from core mod include extra map templates as well as high resolution support files, but game can work without them.

If you want to be sure you running with latest core mod just remove extra files from:


Ok The game run well I just wasn’t confident of reporting bugs for not being sure if I had it really up to date or not.

Thank you.