VCMI does not work even if I do everything correct way

#1

Installed latest daily build
Installed Gog version
Followed instructions
Infinite Connecting error
Please help I want to play very much

#2

Check if your antivirus/firewall software doesn’t block vcmi_server and/or vcmi_client module.

#3

In case it does not. What else can I do. When I red client logs I noticed the path was in red and likely not found. I will send screenshot if needed.

Also why it even connects to a server?

#4

Please send some screens. And connecting to server doesn’t means that game tries to connect external server. It means connecting with in game built server.

#5

#6

Probably problem is in your filepath - it contains russian letters. Try to instal h3 and vcmi in directory only with english characters…

#7

C:\Program Files (x86)\GOG Galaxy\Games\HoMM 3 Complete

Changed path. Same thing.

#8

I have no idea :frowning:
Can you upload all txt files from: c:\users\sasik\Documents\My Games\VCMI folder?

#9

There is no vcmi folder there…

#10


and in this folder?

#11

There is no folder with those simbols, when I checked I found my games there was no vcmi

#12

I guess OneDrive (which is shared, I think) folder causes these problems. VCMI should create some files in Documents/My Games/VCMI folder - but I don’t have any idea, why OneDrive directory is involved in this :frowning:

#13

Please help me I want to play like other people.

#14

Try to create another windows user and do not integrate it with onedrive anyhow. Create usual user with username/password, not via microsoft account. I think the issue relates somehow to https://support.office.com/en-us/article/files-save-to-onedrive-by-default-in-windows-10-33da0077-770c-4bda-b61e-8c8e8ca70ac7

#15

I installed build 0.99 and some mods, it worked. Now I see there lots more towns and daily builds. Do you need to find specific daily build for each town? I will try your methood later today. Is it normal that some towns don’t work like imperium?

#16

No, it’s not VCMI works. VCMI is open projects and sometimes vcmi devs and contibutors write new, additional code (for example bug fixes, new features, improvements). When this code is reviewed and good - it is added to the main code. Every addition generates new daily build. So, basically, the latest daily build contains all previous daily builds patches.

#17

Somehow only 0.99 works for me. I tried builds on friends pc and it is not working. Can someone walk me through the process maybe? On discord or something?
I feel missing out not be able to play mods.

#18

You can try to install appveyor builds. For instance this one https://ci.appveyor.com/project/vcmi/vcmi/builds/31146973/job/7y3p59ptst49n3pm/artifacts

and replace smpeg2.dll with smpeg2.zip (89.0 KB)

#19

If it will not start post here error message. You can also join slack

#20

Sorry for long reply. Solution: create new profile unrelated in any way to windows or onedrive. Thanks!