VCMI and placements of heroes3 complete and mod

I tried to search the forum for answers but could not find it, been trying to search for a while, but gave up in the end.

I have heros 3 complete from GoG.

I have unpacked the VCMI in a own folder called VCMI.

As I gathered I am suppose to put heroes 3 files into the same folder?

or did I do something wrong?

I got WoG to work on heros 3 without using VCMI, but I want to add new stuff also and VCMI is the only option for that.

Is there anyone who have the time to explain me where to put it?

I have tried many different things but game doesnt start so I am doing something wrong.

Hope someone has the patience with a heroes3 fan but mod noob. ^^

[ul]]Make copy of folder with installed H3 complete./:m]
]Download and unpack VCMI somewhere./:m]
]Copy all VCMI files right into your H3 complete directory.
VCMI_client.exe must be in same directory where Heroes3.exe is./
]If you want WoG or other mods run “VCMI_Launcher.exe”, download and activate them.
WoG downloaded from elsewhere won’t work as VCMI has special adoption./
Hope it’s helps. :wink:

Thank you for the help it worked … kinda…

  • grove town works but random maps cannot be larger than medium
  • preserve town did not work at all
  • wog worked but only at random map of medium size

not sure if I did something wrong…

if someone tried to do bigger maps and got it to work I would be happy to learn how I can make it work.
I only play random maps as campagin is of no interest.

What exactly VCMI version you running?
Did you tried very recent development build?

Also VCMI may crash during random map generation (at least for me on Linux) as there few unfixed bugs. So it’s worth to try it few times.

You cna configure available map templates via launcher ->VCI essential files->templates.

Only mods from our Launcher are supported, 3rd party mods are mostly incomplete or untested.

I use VCMI 0.98

Also only used the links to mods provided on this site as I think those are most likely to work with VCMI properly. ^^

I will do exploring with the launcher.

thanks again for the help, much appriciated.

Make sure to test latest development build “0.98e” I linked instead of “0.98” from front page. RMG only started to support objects from most few months ago and it’s not in stable release yet.

Last development build has broken RMG, crashing most of times.
I propose using 0.98d instead.

There were no changes in RMG as far as I know.