VCMI 0.99 crashes on start


Actually, there is a new version, even lots of them. You can download daily builds from here: Those are much better, than old 0.99.


Yea I’ve tried the last version, it is the one tat keeps crashing after a few turns :smile:
For me at least


It’s vcmi thing. More mods you enable, more random crashes you get.


Nice to see newer versions. Unfortunately not for Linux. My vcmi still crashes (with memory access violation and core dump) when i enable the new Courtyard faction.


Attach all logs after crash please!


Well, there’s much log :slight_smile:
VCMI_Client_log.txt (416.6 KB)
VCMI_Launcher_log.txt (23.7 KB)
VCMI_Server_log.txt (1.1 MB)


The more interesting part is what is displayed on the console when i start the client from the console:
[email protected]:~/Schreibtisch$ vcmiclient
Creating console and configuring logger: 10 ms
The log file will be saved to “/home/siegfried/.cache/vcmi/VCMI_Client_log.txt”
Initialization: 345 ms
Data loading: 150 ms
Mod handler: 0 ms
Mod filesystems: 264 ms
Basic initialization: 761 ms
Initialized logging system based on settings successfully.
[log level] ai => not set
[log level] animation => not set
[log level] bonus => not set
[log level] global => trace
[log level] mod => not set
[log level] network => not set
Loading settings: 774 ms
Found 3 render drivers
opengl (active)
Check display mode: requested 1280 x 960; available up to 1680 x 1050
Created renderer opengl
Initializing screen: 131 ms
Initializing video: 0 ms
Initializing screen and sound handling: 5 ms
Bonus type handler: 8 ms
General text handler: 16 ms
Hero handler: 6 ms
Artifact handler: 0 ms
Creature handler: 0 ms
Town handler: 0 ms
Object handler: 0 ms
Object types information handler: 0 ms
Spell handler: 0 ms
Skill handler: 0 ms
Terrain view pattern handler: 2 ms
Template handler: 0 ms
Initializing handlers: 35 ms
Initializing content handler: 0 ms
[b1c10a9d]Original game files
[adc6d99b]Andruids Expansion Mods
[994e5d35]Axolotl Creatures Pack
[bd5e49a0]Boost Core
[3dde7aaf]Courtyard town
[5789aa2f]H2 Artifacts mod
[f8302ff3]H3 for VCMI englisation
[6f4e30ac]H4 artifacts - regular
[3fdfc75e]Hidden H3 Graphics
[5c4b3f3b]Kurek Creatures
[f3d79d28]Man at Arms
[4c461a00]Necropolis creatures
[4dda668e]New Skills
[9e4c5c95]New Old Spells+
[d6323bcc]Resourceful AI
[4e46a6c5]Alternative shooting Centaurs
[1e143d29]Small ERA II mods
[8647b0b8]Unlucky ones
[c7d97f8d]VCMI essential files
[57ca1cef]Witchking artifacts
[3b4210b0]In The Wake of Gods
[2ec926ca]Damned Utopia
[e1023a38]Minotaur Warlock
[e3f190ea]Plague Tent
[b8e10e82]Power Bond
[c8720a31]Evil trees
[745e43af]Bubble Arrows
[826b864c]Darkened players
[40355f2c]New difficulty buttons
[b5adc3c7]New Flags
[c9e04325]No flashing trees
[f27f0625]Tavern videos
[b611ce43]Creature bonus icons
[c7957b5b]Default templates
[6a79065d]Extra resolutions
[a3d1ebe7]Stack Artifacts
[6da5bf63]Stack Experience
[4487699d]Sullivan, the Minotaur Warlock
[4a41b930]New Commanders
[3006deb9]Clash of Dragons
[73326f4b]Coldshadow’s Fantasy
[23a01266]Golden Ring
[6dc9dc6c]HD Mod RMGs
At line 1, position 0 error: Not a valid UTF-8 file

	[ddcb8c0d]Jebus Cross
	[1715ea3c]OH3 RMGs
Parsing mod data: 438 ms

no original data in loadMod(neutral) at index 9
[DONE] Original game files
[SKIP] Andruids Expansion Mods
[SKIP] Axolotl Creatures Pack
[SKIP] Boost Core
Error: invalid ability type GARGOYLE.
Speicherzugriffsfehler (Speicherabzug geschrieben)


GARGOYLE bonus is relatively new and that’s why older vcmi builds don’t recognise it and maybe that’s why game crashes.Builds should be never than 7 May 2020.


Not for Linux?
Last builds are from July…


Well, i did this. I added the ppa. Now if i want to upgrade my vcmi, it says this:

[email protected]:~/Schreibtisch$ sudo apt-get upgrade vcmi
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
vcmi ist schon die neueste Version (0.99+dfsg+git20190113.f06c8a87-1).
Paketaktualisierung (Upgrade) wird berechnet… Fertig

That is in english: vcmi is already at latest version. But as far as i can see this is not the latest version. So how do i upgrade to latest version?


I found something with apt-get update:

Fehl:5 focal Release
404 Not Found [IP: 2001:67c:1560:8008::15 80]

That’s why.


I’m only windows user, so I can’t help you more :frowning:


I’m trying to find a cure. I have now added the IP address to /etc/hosts, so that i do not get the “not found”.

The basic problem is, that i have Ubuntu 20.04.1 LTS, codename “focal”. The list of supported versions contains:

[DIR] artful/ 2018-07-19 21:28 -
[DIR] bionic/ 2020-07-05 10:26 -
[DIR] devel/ 2020-03-18 02:49 -
[DIR] disco/ 2020-03-18 02:49 -
[DIR] oneiric/ 2013-02-18 04:58 -
[DIR] precise/ 2013-02-17 04:03 -
[DIR] quantal/ 2013-02-18 04:58 -
[DIR] raring/ 2013-02-18 04:58 -
[DIR] saucy/ 2013-09-08 00:18 -
[DIR] trusty/ 2020-07-05 10:26 -
[DIR] utopic/ 2014-06-22 15:39 -
[DIR] vivid/ 2017-10-11 15:52 -
[DIR] wily/ 2016-12-12 01:36 -
[DIR] xenial/ 2020-07-05 10:26 -
[DIR] yakkety/ 2017-07-19 22:01 -
[DIR] zesty/ 2018-01-14 21:30 -

There is no focal. So as a result there is no “Release” file. So for security reasons apt blocks downloading from this repository. I do not know all the code names, but i think there is no ppa for the current ubuntu version, only for older versions.
An alternative would be offering a .deb file to download and then install manually. But i have not yet found such a .deb file.

Ok, i found the .deb files. But they depend on some libs i don’t have and which are not available. Mostly older versions of ffmpeg libs.


Ok, i compiled it myself. That seems to work.

Anyone interested in a big map with many “random” towns to play with the new factions?


Well, it still crashes after some time playing. The log files do not contain anything interesting, they just end in the middle of the line. More interesting is the console output:
Battle AI best: hota.cove:cannon -> northerners:ntarcher at 100 from -1, affects 1 units: 30 0 0 0
Battle AI best: northerners:ntSnowCat -> northerners:ntarcher at 100 from 82, affects 1 units: 36 41 0 1
Battle AI best: northerners:ntVotary -> northerners:ntarcher at 100 from -1, affects 1 units: 16 0 0 0
Battle AI best: northerners:ntarcher -> northerners:ntSnowCat at 81 from 64, affects 1 units: 31 30 0 0
Battle AI best: underworld:unPreacher -> northerners:ntarcher at 64 from -1, affects 1 units: 6 0 0 0
Battle AI best: northerners:ntsentry -> northerners:ntarcher at 64 from 46, affects 1 units: 55 0 0 0
Failed string substitution with type 8 because index 1042 is out of bounds!
Player 6 (teal) ends turn
Player 6 (teal) ended turn
Player 7 (pink) starting turn, day 19
There is no known way to clear the way to tile (111 36 0)
There is no known way to clear the way to tile (111 36 0)
There is no known way to clear the way to tile (111 36 0)
Failed string substitution with type 8 because index 1051 is out of bounds!
Failed string substitution with type 8 because index 1051 is out of bounds!
Segmentation fault (core dumped)

Just for info: Player pink was Ruins faction, and the tile 111 36 0 is indeed within reach of pink. But it is not blocked.


VCMI is full of bugs. It’s common knowledge. You can’t do anything with it.


You can try my branch nullkiller-ai. Probably it will even load original save.


Interesting. Where can i find it?


If you built VCMI yourself just checkout branch nullkiller-ai


ok, good idea. Next month i’ll have more time, i’ll try it then. Until then, if anyone wants to test is with a huge map, here it is:
C01b.h3m (124.4 KB)
It is designed so that it is possible to play it with several of the new factions. And it is huge, so it is a stress test for vcmi. I replaced the ruins faction with courtyard, and that worked better. Still i got a core dump, much later in the game and not related to any of the new factions. But it worked for quite some hours.
Map faction list:
red: Inferno. Your main enemy. Should stay at inferno.
blue: Castle. Your ally. Mostly there for the story.
orange: A swamp faction. I mostly play it with Cove.
green: Underground faction. Tried it with Underworld.
tan: Necro faction.
pink: Mixed grass and dirt terrain. I tried it now with courtyard.
teal: Snow faction. Tried with Northerners.
purple: Human player. Dirt terrain. Designed to be played as Cathedral.

Till now i was able to complete it sometimes, but quite often it crashes.