VCMI 0.98 Problem z portretami herosów i filmikami


#1

Siemanko mam Windows 10 i Heroes 3 Złotą Edycję. Zainstalowałem wczoraj VCMI 0.98 i mam następujący problem:

  • w grze zamiast portretów bohaterów jest pomarańczowe kółko z czerwonym przekreśleniem (prawie wszystkie poza portretami Tarnuma i HOTA, te wyświetlają się normalnie)
  • filmiki kampanii nie wyświetlają się i nie ma w nich dźwięku tylko czarne tło i napisy

Nie mogę tego zobrazować, bo gdy wciskam print screen to robi mi screenshota pulpitu a nie gry. :open_mouth: Jednak mam screenshota z konsoli gdzie jest cała masa błędów. Może to wam coś powie jak można mi pomóc.


#2

No dobra mam jeszcze jeden problem po dokładniejszym zbadaniu. Nie mogę walczyć. Zawsze gdy rozpoczynam walkę nieważne na jakiej mapie i jakim zamkiem to crashuje mi grę i wywala do pulpitu.


#3

Wygląda na to, że brakuje plików -> niepoprawna instalacja. VCMI_Client.exe musi znajdować się w tym samym folderze, co plik .exe oryginalnej gry.


#4

I tak właśnie jest, a mimo to jak widzisz sam pełno błędów. Zainstalować jeszcze raz? Czy może, któreś z dodatków się ze sobą gryzą? Na przykład Hota i WoG? Albo jakieś inne. A może to przez to że to windows 10?


#5

Najlepiej zainstalować kopię Heroes 3 Complete w nowym katalogu a potem na czystą instalającję VCMI. HoTa, WoG niech mają swoją odrębną instalację.


#6

No dobra ponowna instalacja pomogła gra już działa i nie crashuje (tylko sporadycznie zdarza się crash), ale za to zdarza się że po rozpoczęciu walki jakieś zielone napisy z błędami, gra się nie wyłącza, ale coś jest nadal źle czy to jeszcze niedopracowanie czy znowu to ja coś zwaliłem? :smiley:

A i filmiki kampanii w dalszym ciągu nie mają dźwięku i obrazu tylko napisy i czarne tło. Czy ktoś ma podobnie?

No i komputer prawie nic nie robi. Zamku nie rozbudowuje, po mapie nie chodzi i nie zajmuje siedlisk, kopalni, nie pokonuje potworów. Tylko rekrutuje wojska te co ma już w mieście zbudowane.


#7

Też to mam. Wydaje się nie mieć znaczenia, więc olewam.

Tak, wszyscy tak mają. W dużym projekcie, jakim jest odtworzenie Heroes3, to tak naprawdę… pierdółka w zalewie poważniejszych rzeczy, które czekają w kolejce do odtworzenia.

Jak włączasz VCMI launcher to po lewej stronie masz dwa przyciski: Mods i Settings. Klikasz Settings i tam szukasz zakładki AI Settings. W opcji Neutral AI zmieniasz ustawienie StupidAI na BattleAI.
Niestety nie oczekuj cudów. AI jest wciąż GŁUPIE na obecną chwilę i często się gra crashuje podczas tury komputera. No obecną chwilę VCMI jest fajne by sobie pograć modami - wyzwań taktycznych jeszcze długo nie uświadczysz.


#8

No to z tym AI mnie nie pocieszyłeś. Chyba będę musiał po prostu grać w normalnego WoGa, bo tam działa chociaż AI z oryginalnego herosa. Takie coś jak jest w VCMI to niestety nie jest gra jakiej oczekuję. Muszę uzbroić się w cierpliwość. :stuck_out_tongue:


#9

Jednak polecam granie w VCMI od czasu do czasu i zgłaszanie błędów na bugtrackerze. Wówczas czas do doskonałości będzie krótszy! Granie nowymi zamkami daje mimo wszystko powiew świeżości!


#10

Tak nowe zamki to to co mnie zachęciło do instalacji VCMI. Jest tych zamków chyba z 7 nowych, ale niestety 4 z nich są do starszych wersji VCMI a z tych czterech dwa wygasły linki.


#11

Najnowszą wersję Abyss Town (stale lekko szlifowaną) możesz znaleźć w pierwszym poście:
[forum.vcmi.eu/t/abyss-town-revived/1010/1)

Grove Town pobierasz stąd: vcmi.acidcave.net/inne_modyf … _town.html
Nie przejmuj się wersją 0.96 - jest tam przystosowana do 0.98e. Aczkolwiek podczas bitry przeciwko Treebirds nie radzę klikać prawym przyciskiem myszy na tę jednostkę aby sprawdzić jej parametry. Czasami dochodzi w tym momencie do niezrozumiałego crashu.

Resztę miast pobierasz np, stąd: vcmi.acidcave.net/
Nowa wersja Bastionu jest w trakcie tworzenia, ale ta dostępna hula bez większych błędów.
Poprawki nad Forge też trwają, na własny użytek poprawiłem w niej to, co umiałem. Jak chcesz, to jest tu: www86.zippyshare.com/v/ZLOK3yaw/file.html
Cove mam nadzieję, że VCMI Team szybko zaktualizuje vcmową wersję o pewne rzeczy, które wyszły niedawno w oryginalnym dodatku.
Preserve odbugowałem do działania pod 0.98, ale w tym modzie są skopane dźwięki. Jak poszukam na necie za innymi, to podzielę się linkiem.

W każdym razie każdym miastem da się grać, aczkolwiek odradzam włączanie ich wszystkich na raz - gra ma za dużo dobrego na raz i lubi się crashować jakby zarządzanie modami ją przerastało.


#12

Bzdura. Można używać dowolnej ilości modów na raz.
Mody te jednak nie znalazły się na Launcherze, bo są niedopracowane i to one mogą ewentualnie zawierać błędy.


#13

No dobra miasta już mam. Powiedz mi jeszcze gdzie są zapisy? Chciałem usunąć niektóre i nie mogę ich znaleźć.


#14

W teorii tak. Nie mam na to twardych dowodów, by to zgłosić ale coraz częściej obserwuję pewne ‘błędy’, które występują w przypadku dołączenia do gry większej ilości miast. Znaczy, dana sytuacja nie ma miejsca w przypadku podpięcia dwóch miast, ale w przypadku podpięcia pięciu już ma. I nie jest to wina modów - mody zawierają wszystkie potrzebne linie komend. Tak jakby zarządzanie “zmiennymi” i “pamięcią” w przypadku dostarczania danych przez większą ilość modów zaczęło szwankować. Nie znam się na informatycznych rzeczach - ot, to tylko moje odczucia. Dla przykładu - w przypadku sześciu miast niekiedy Dowódcy nie ma na pasku inicjatywy, w przypadku podłączenia dwóch miast - jest za każdym razem.

U mnie są na dysku C: w katalogu C:/Users/[user]/Documents/My Games/vcmi/saves.


#15

Nie ma takiej gwarancji. Mogą zawierać również wiele niepotrzebnych danych. Było już kilka przypadków, gdy mody dobierały się do dowódców i innych zasobów, do których nie miały prawa.


#16

Bastion mi nie działa. Przy używaniu tego miasta wywala mnie z gry. To tylko u mnie czy Tobie też nie działa?

EDIT: Faktycznie gdy wyłączyłem jedno z miast to Bastion zaczął działać. A konkretnie to Bastion żre się z Abyss. I jeszcze jedno Twój Forge jest jakiś inny. Są inne stworzenia i niektórzy bohaterowie są inni.

EDIT2: Co ciekawe żre się z nowy Abyss, a ze starym nie. :smiley:


#17

Czasami wywala, czasami nie wywala. Zależy od nastroju. Próbuj do skutku, za którymś razem załapie. Dobrze też wyłączyć i włączyć mod ponownie.
A “moje” Forge jest… normalne. Coś mi się zdaje, że wczesne wersje Forge wyglądały inaczej, ale oficjalna, stabilna wersja wygląda tak: vcmi.acidcave.net/mdt_forge.html


#18

Jaggernaut był robotem smokiem, a nie jakimś mutantem, pierwszym wojskiem był zombie z piłami maszynowymi zamiast rąk. Brakuje nag na gąsiennicach jako szóste wojsko, minotaur był piąty, a stinger czwarty. Nie było brain suckerów. Tak więc bardzo się różni. :slight_smile:

Odnośnie bastionu to kłóci się z nowym abyss, a jak wgrałem starszą wersję abyss to bastion działa bez zarzutu.