VCMI 0.72b - development version

As I promised, new development build is ready.
It brings many bugfixes and several new features.


Few remarks:

  • Hero meeting window is only partially done. It’s not possible to exchange artifacts between heroes.
  • Support for creature dwellings on adventure map is also not finished. There are known problems with “immortal” guardians. Golem factory and elemental conflux are not supported and terrible things can happen.

Many 0.72 issues remain unresolved.
That’s my list:

Please check if I missed something.
And enjoy a new build :slight_smile:
vcmi_072b.7z (1.79 MB)

[size=75]#1 I think something must be wrong with the package, as I can’t get it to work.

I copied it over 0.72 with overwrite, but first time when I tried to open it I got this:

I copied the Smackw32.dll from the WoG folder, but then I got a similar error mentioning the Binkw32.dll. I copied that one as well to my VCMI folder, but then I got this:

No need to attach other logs, as only the Client log got updated with what you see in the screenshot above. The Server log was unchanged after the crash (in case it should?). Let me know if it’s the archive, or am I missing something?

In case it’s something else missing from my VCMI folder (though it’s already strange I didn’t have issues in 0.72 with those .dll files), here’s a screenshot of the contents in the rood directory of the game:

EDIT: I thought of also trying the VCMI_Server.exe, but even though I didn’t get a crash, it got stuck during loading (see attached file)

EDIT2: If I read the Changelog above correctly, issue #49 & 69 should not be in the list of unresolved bugs.[/size]

EDIT3: Please ignore the above. As explained by Tow below, it was because the video.vid file was not copied to the Data folder. You can consider as bug #1 the one reported by Boulie below.
090713 - After Binkw32 was (511 Bytes)

Have you put video.vid file in the /Data folder?
Since we’ve added support for videos, it’s necessary :slight_smile:
(and original video .dlls like Smackw32 and Binkw32 as well)

Oh yeh… that was it :smiley:

Thanks! :slight_smile:

**#01. ** Game crashes if you want to get into Castle. I’m not sure what caused the problem. It was ok, and I think after I’ve changed the resolution I can not get into the castle even in old saves. (see attached save)

Some other thing I’ve noticed but these are not errors - some features/defects/difference between vcmi and Homm:

  • can not exchange the artifacts in meeting window
  • in meeting window heroes who meets other should be on the left side.
  • new secondary skill after heroes gain the level should appear on the right side of the window (not left), maybe one feature thing that the old/left skill could be chosen as default (less click->faster game->better game :wink:

[size=75]Thanks for the report. However please use this thread to report bugs for the 0.72b Development Version. Bugs for development versions are to be reported in the threads created by devs here in the “Help & Bugs” section. Only for public releases one of us may create the bug thread, as those are published by the devs in the “News and Announcements” section.


I’ve moved the post to appropriate thread :slight_smile:

No problem. I’ve not noticed the difference between development ver. and public release.
Thanks Zamolxis for explantion and Tow for moving the post to right thread.[/size] (121 KB)

I’ve tested events a bit. Found some bugs:

**#2 **- “take mana points”: UI glitch: double minus sign, mana points can become negative;

#3 - take resources - UI is ok, but resources can become negative as well;

**#4 **- “give artifact” - after receiving art, another empty message box appears, large number of artifacts should be splitted on several pages;

#5 - Same empty message box appears before event-battle. In H3 we have message kinda “You have been attacked” (for all events, not just battle), in VCMI we have not them yet;

**#6 **- I’ve got a crash when pikeman attacked griffin (screenshot) and VCMI crashed just before griffin retaliates. At the same time I’ve switched to my working media player. Probably some sound conflict. I tried attack from different position, switching to something else - all OK except first one;

EDIT: I’ve added a map where I’ve tested all of stuff mentioned above
Arrogance-events.h3m (11.6 KB) (3.88 KB)

#7 - If we attack with multiple creatures on the same target, after any attack, we have to move the mouse cursor away, then back on the target to get the correct sword/arrow pointer. In H3 the pointer was updated automatically, depending on the default attack type of the next creature which had its turn.

#8 - Combat Animation Speed should not impact “passive” creatures. It should only impact the moving/attacking creature, the attacked creature and the spell animations. This was also reported some time ago in the 0.63b bug thread:

EDIT: I just noticed, I also reported this as 0.7#30, though the behavior changed a bit ever since: I see you’ve reduced the frequency of these static animations, but this only solves half the problem - the remaining issue is that when they do occur, the animations are still impacted by the Animation Speed chosen, which should not happen.

EDIT2: Thanks to the discussion at the end of the 0.7 thread, I realized that actually there are 2 animation types that should always be Slow:

  • The “breathing” of all creatures, which occurs every couple of seconds, as implemented in VCMI (not in WoG)
  • The special animations, customized for each creature, which happen when we hover over them in battle and - in WoG - they were also randomly occurring (about every 10 seconds) instead of the breathing.

#9 - Lost nice new functionality (introduced in 0.63b) that allowed us to see in the background the enabled/disabled View Hex Grid & Movement Shadow, while we were in the Combat Options screen: :frowning:


#10 - When a Scholar gives us +1 to a Primary Skill (because the Secondary Skill they wanted to boost is already at Expert) the subtitle mentions a +4 boost: (I had the same for Attack; probably it’s the same for all of them)

Please see the map attached below, to reproduce the following issues.

#11 Event message windows still don’t support large texts correctly (but I can see it has been improved considerably).

The solutions would be smaller fonts and/or scroll bar, as described in detail in the 0.71b thread:

#12 The Event messages in the attached map are set to appear daily, however we only get them in the 1st day.

#13 The layout of the message when picking up Santinel’s Shield seems a bit strange. Not really a bug - I’m not sure if it’s maybe not meant as a feature, to have at least 5 rows filled, otherwise I don’t see why either “hiss,” could not fit on the 3rd row, or else why 2nd row doesn’t end at “When”.

#14 This is however more of a bug than the previous: the text we get when picking up Titan’s Cuirass contains double quotations. It’s possible this may impact all similar message windows, when the text contains a quote.

A Terrible Rumor edit.h3m (11.3 KB)

#15 Game crashes at first action taken after we press F4. We had F4 issues before, first in 0.68 (#4 - solved) and then 0.71#47 (which reported F4 issues when VCMI was running in parallel with H3, but this time we have issues even when only VCMI is running).

#16 Game crash (system freeze) when I tried to start the custom “Just testing” map attached. It’s not reproducible, so I’m attaching the logs as well.

The only thing I did before, was to open the “settings.txt” for editing (I wanted to change resolutions), but I actually closed it without saving. I know I closed it while Main Menu was already open, I just don’t remember if the application was already started when I opened the file. It can be that I was opening it while the Client was loading (but again, no saving between the moment I opened it and the crash). Another (maybe) particular detail is that the game was 1st in the list by default due to the space I put in front of its name, and so I started it by clicking on BEGIN without even opening the list of available scenarios. A moment later the system froze completely: I couldn’t access any icons, the Start button, even CTRL+ALT+DEL didn’t work anymore to kill the application. Needless to say I also couldn’t access the SRip.exe application I use to take screenshots (I’m thinking now I should have tried PrintScrn, but if Start & Ctrl+Alt+Del didn’t work, I doubt that would have).

Though, in spite of a dead keyboard and unclickable icons (i.e.: Show Desktop, etc), the mouse pointer could still move. And while moving it around, I noticed that the Client Close button was still accessible (i.e.: the cross in the red box button, in the upper right corner of the Client window). And only clicking on it killed the Client and unfroze my system. The Console was still on, so I managed to take this screeshot:

More info hopefully in the attached logs.
090714 - Crash after trying to open Just (6.32 KB)

Refer to crash #01
I think it is always if you load saved game. And there is no matter if it is Fort Citadel or Castle. I hope it is not only in my vcmi version.
Attached 2 more saves.

#17 In the Cave of Gerfrex.h3m map (attached) from the beginning I cannot get into tavern.

#18 In the map Noahs Ark.h3m (Arka Noego) cannot see the hero in the castle. It happens if you have other hero in garrison.
Ok. It happens in all maps.

#19 If you want to buy upgraded creature there is chosen by default not upgraded creature.
Cave of (35.2 KB) (134 KB) (74.6 KB)

Nope, it’s not only yours. I could reproduce it as well.

And same goes for the other bugs you reported (#17-19). Though #17 may have something to do with the fact that Cave of Gerfrex is a WoG map, so some of its elements might not be fully supported by VCMI.

#20 Mouse click in the scroll area in the list of available Scenarios, does not work as page up/down like in H3 but it really takes us to that part of the whole list. It’s not really a bug, just different behavior. I’m not sure if it needs changing or not.

#21 ‘H’ key on Adventure map centers on the 1st hero in the list (even if he’s out of movement points). Instead, it should select/center the next hero in the list with movement points left. That also means that if no hero has movement points left, H should do nothing.

[size=75]FYI - For centering on the currently selected hero, there’s another hotkey - Spacebar - which however has “revisit location” as primary function (so it just centers only when hero is not at any location that can be visited). That’s already implemented and working fine. For pure “center hero” purposes H3 had no dedicated shortcut, that’s why I suggested in the “Missing features” thread to assign NumPad “5” for it - when the other NumPad keys will be implemented for hero movement.[/size]

#22 Leave Guards window graphic glitch :
[size=75](luckily the above bug had me testing ‘revisit locations’ hotkey:)[/size]

#23 Hero screen: Hovering over unselected creatures displays subtitle “Select xxx (in garrison)”. It should only say “Select xxx”

#24 Stone Golems make the Iron Golem sound when walking in battle, and vice-versa.

#25 Also Split Creature Stack button is missing from the window (though probably you already knew that) :->

#26 ‘T’ hotkey opens now Marketplace window, however Trading Post doesn’t work anymore.

These two are related, and a bit annoying (makes me hope we’ll get a new development version soon):

#27 Visiting creature dwellings after Loading a saved game does not work anymore. See the attached saved game. Before exiting the client for the 1st time, I could visit the Parapet next to Torosar to recruit Gargoyles. However after I closed/reopened the Client and Loaded the latest Autosave, I could not visit the dwelling anymore.

#28 End Turn on Day 7 of any week, after the game has been loaded, generates a crash:

Unlike other crashes lately, closing the Windows error message (‘Don’t Send’) does not close the Console+Client as well. The game is frozen however, so there’s nothing else to do than terminate it manually.

This basically means we cannot play much with saved games anymore, as the game will crash at the end of the week. Plus, if there are other bugs similar to #27, it also means that after loading a saved game, some features might not work the same. This makes me hope we’ll get a new dev release soon fixing this problem, otherwise it’ll be quite frustrating not being able to save & load anymore.
090715 - Revisit dwelling after Load with Torosar + Crash (104 KB)

That’s one bug (not putting available creatures info to the save) that causes all those crashes.


Sounds like yet another occurrence of “crash on attacking two-hex creature from back” bug.



Not a bug. There is limit of characters per line. Moving “hiss” to the third line will make it longer than second line (by two chars - second line has 39 chars while limit is 40 in this case).

It’s easier to se when using font with constant char width:

You find a large box that seems to be 
made from some unknown metal.  When you 
touch it, the box opens with a loud 
hiss, revealing a gleaming shield 

vs                            limit => |

You find a large box that seems to be 
made from some unknown metal.  When you 
touch it, the box opens with a loud hiss, 
revealing a gleaming shield within.

Probably fixed. (same for glitch in hero window)


It never had… (if you mean trading post object on adventure map)

Will be soon.

[size=59]Small edit to give correct credit for #2-#5 to Ivan i/o myself (Zamolxis) :slight_smile:[/size]

Thanks for the clarification. It’s because of all those m’s and the W that made me have the feeling 2nd row had like 10 characters more than 3rd. My bad. :stuck_out_tongue:

My bad again. :confused: I know I’ve used the Trading Post a couple of times quite recently, but it must have been while playing WoG, not VCMI (though it’s like 2-3 weeks since I played WoG, and I had the feeling I’ve used the Trading Post more recently - obviously I was mistaken:).

Great! Thanks. :slight_smile:

#69 - indeed.
The #49 is bit more complex - Tow Dragon made changes that limits number of possible characters to 5 but it’s still too much (it needs to be limited more or we need a smaller font).



I’m not sure about that one. I’ve added little more diagnostics. Please re-check this issue in the next build.


I’ve checked it in 0.72c - they’re not fixed yet. #22 even extended to the Town interface as well now.

Other items reported as fixed seem fixed though (I retested most of them, except #2-5 from Ivan)

Could it be this: Warning: SDL says that 24bpp is wrong and suggests 32 ?

Anyway, I’m attaching here the logs (they’re from 0.72c, but crash behavior is identical):
090716 - F4 (1.9 KB)

It’s limited to 4 characters for positive integers (I hope nobody wants negative amounts of creatures :)). And that’s enough.

Fixed / Duplicate to 0.72#13.


Probably dupliacate to many 0.72 bugs with two-hex creatures.