Vcmi 0.71 bug seeking thread

Maybe this already known, but I don’t see them in this thread.

In battle -
**59)**move cursor to your own unit, then move cursor to enemy unit (your unit must be inactive and be close to enemy unit ) - you will still have “question” cursor instead of sword

**60)**when two-tile centaur attacked my skeleton from top (see screenshot) VCMI crashed.

**61)**VCMI crashes on startup. Removing map (user-made, WOG, no ERM) “Isles of Illusion” (see attachment) solved this issue.

**62)**Scenario selection menu - browsing by up/down keyboard key did not change screen position when end of screen reached

**63)**After withdraw from battle - hero does not appears in the tavern

**64)**Events are invisible but right click show a popup “event” and there is a problems with movement - event needs to be 100% passable (I know - events are not functioning yet, but movement makes some map unplayable)
Isles of Illusion.h3m (186 KB)





Implemented by Tow Dragon. Spell can be cancelled by pressing escape or right-click.

Fixed and added support for Corpse as well.

Fixed by Ubuntux.


Fixed by Ubuntux.


Thanks for all the reports, soon more fixes / comments!

Bug with pathfinder is fixed also.

#65 Unreproducible bug: The mouse cursor disappeared from the game interface at the end of a battle.

I was playing in 1024x768 resolution. After a battle with some Serpent Flies, when the window with battle casualties opened, the mouse cursor disappeared from the game interface: both the arrow and the functionality (as I tried left/right clicks and nothing was happening). Alt-Tabbing did not bring it back. Also the game interface was not accessible anymore also via keyboard: I could now use the Enter key to close the Battlefield Casualties window box. The only area of the VCMI client interface that was still accessible with the mouse was the upper window bar - the one that can be used for moving/minimizing/closing the window.

Unfortunately I rushed to reproduce the error afterwards, forgetting to save a copy of the client log, in case that might have been of help. But trying to reproduce the error failed. I even tried with same creature moves, and same casualties from my side (1 Basilisk), but no “success”.

I doubt that it’s gonna be of any use, but I’m attaching here the saved game before the battle (file might be of more use for the below bug actually).

#66 Reproducible bug: As can be tested in the attached file, switching Armor of the Damned with Titan’s Cuirass on Gerwolf does not really work. If we reopen hero interface after artifact switch, he has Armor of the Damned again. By the way, I don’t actually remember picking Armor of the Damned earlier in the game, so this may have another bug behind (but I’m not sure about this - it’s a game I started almost 1 month ago, and only now reloaded the saved file to play further).
Titan’s Cuirass switch artifact (69.4 KB)

#67 Right-clicking a creature on the battlefield keeps the mouse pointers and left-click functionalities regardless of the info box opened (as long as we keep the right-click pressed):

a. It was ballista’s turn. Right-clicking on the target enemy unit opened the info box, but mouse cursor remained an arrow:

b. Following the above, I kept the right-click pressed and moved the mouse in different directions. The cursor was changing into the “not available” icon when I was not above the creature hex behind the info window:

c. While holding the right-click, I also tested if I can move on with the battle while having the info box opened. This is what I got:

When the pointer was in “not available” status (not above the target hex) I could not shoot with the ballista
When the pointer was an arrow (above target) I could shoot
During the shot, the info box was disappearing for a moment to show me the shooting animation, and then appearing again
The bad part here is that when it reappeared after the shot, the Health loss of the target was not yet displayed
After the above shot, Ballista got a morale boost so I shot again
Again, the info window disappeared for a moment for me to see the animation, and again the info reappeared, without registering the 2nd Health loss
After that I removed my finger from the right button of the mouse for the first time, and right-clicked again - only now I could see the correct health loss after 2 Ballista shots

So basically we have the following:

  • After right-click in H3 we cannot move on with the battle while the info box is open, while in VCMI we can
  • While this is a behavior different than H3, is not a bug in itself, just a difference in functionality which does not impact the gameplay
  • However we do have a bug with this behavior, namely the fact that the Health losses are not registered when the info box reappears after the hit/shot, is we keep the right-click pressed on a target creature while moving on with the battle.

#68 Garrisoned heroes cannot buy spell book.

#69 Not sure if this was reported before: When we don’t have enough spell points left for certain spells, the spell book still displays them as “available”. We can also still select them. Only when we try to cast them on the target creature nothing happens.

EDIT: See difference in H3 screenshot:

#70 On Day 1 of Week 2 of Month 2, one of the 2 heroes which were offered at the Fortress Tavern in the beginning of the week was Jenova, Level 1 Ranger, with only 1 Centaur in the army. This should not happen unless we already purchased a hero or if she would be a retreating hero, which was not the case.

If it is of any use, this happened on the same map as the saved game attached two posts above (the save was from day 1 of the previous week). However it seems not reproducible: I also reloaded the above game and played until Day 1, Week 2, Month 2, but this time both heroes in the Tavern had normal stacks.

if u accidently press “spacebar” when it is enemie turn client crashes :-/

when hero has no spellbook and he is garrisoned in town, event u go to magic guild, it still doesn’t show that u need to buy book. and for original h3 it pops up :slight_smile: or it just opens magic guild, but no pop up about buying magic book

I tried to reproduce that while fighting some fliers (Archangels), which take long time to cross the battlefield, and I got a pretty funny behavior actually. Here’s the full bug description, and I’m also giving it a log number:

#71 Pressing spacebar in battle during enemy’s turn may cause duplication of enemy animation, and always ends up in game crash. In my case, I pressed spacebar about 20 times while the Archangel flew across the battlefield to get to my Pikemen. The result was that after striking the Pikemen down, the animation was repeated fully about 20 more times (I guess as many as I previously pressed Spacebar): Archangel reappearing in original hex, Pikemen “alive” again, flying across, striking Pikemen down, and again same cycle over and over again. Eventually the game crashed, freezing the battle while Archangel was striking the Pikemen.

I’m attaching the logs in case they might be of use.
Spacebar on enemy turn (3.53 KB)

Interesting… we just didn’t think anybody would press spacebar while it’s supposed to do nothing.

I agree with the “interesting” part. :slight_smile:

This “Action replay” bug might actually be quite a cool feature, if only it wouldn’t lead to a crash. :slight_smile:

I’ve investigated that replay “feature”, but it’s not reproducible in the newest version - although I’ve encountered and fixed another bug while testing ;]. Anyway thanks for report.

#72 Garrisoning or Un-garrisoning a hero causes all other heroes on the Adventure Map to loose their preset paths (always).

This may be related to the same “Spacebar” bug, but as it’s not really matching your bug description above, I’m gonna report it just in case:

#73 Spacebar to enter town crashes the game (always).

#73 seems to have been fixed.

Tow, I think it’s time to release a new version. A lot of these bugs have been fixed already.

If everything goes fine, I’ll post development build on Sunday. If no giant and disastrous bugs are find, the “big” release will go on 1 June.
All features I wanted to implement (artifact support system, map events) are done enough. Tow Dragon’s stack bonus system seems to be mostly functionable.
There still is a crashbug probably related to playing music that bothers me. I’ll soon post info on it in the sounds thread.

Uhm… it works… but not exactly in the way I’d like it to work. I’d like to move spell effects to this system. And then implementing many new spells and creature abilities would be trivial. I think I could finish most of it in one week. I hope it won’t introduce new bugs.

Tow Dragon, the ranged attacks don’t work anymore.

Fixed hopefully.

This behaviour has been changed due to other changes.

I’m not sure if I understood correctly but it should be fine now.

Seems to be fixed.


Seems to be fixed.

well it DOES in h3 :wink: it “defends” when you are in battle :wink: that why i used it there also.

I was talking about it’s behaviour while it’s opponent’s turn. I don’t think defending next to be moved stack would be good.