Vcmi 0.71 bug seeking thread

#38 The Corpse is not accessible from above.

#39 The Info text should not only give the name of the object (i.e.:“Corpse”), but also the (Not visited)/(Visited) text next to it.

So hi everyone!
i ve been looking on project since 0.6 and now i want to share bugs )))))
i ve passed almost all bugreport topics and havent seen those bugs i ve found
so check it out:
40__foolproof loadgame-single(no saves)-mapsizebuttons > crash(console too)
41__foolproof loadgame-single(no saves)-load > crash (console"Error: cannot open to read .vlgm1")
42__customap timed event (and maybe other “up to 8 pictures dialog” shows pictures out_of_border) with resourses taking makes resourses count negative
43__advmap outofmap picture is greater horizontally unlike h3, its hint to left and to up is cool (small square-dialog), but no hints to right and to down
44__advmap up_hero_selector_button calls upper hero dialog, same for town
45__advmap notbug , maybe feature - when system options menu(SOM) opened, the map is scrollable, map animation is present, doesn’t close with esc, closes with enter(in h3 closes with esc, enter-nothing)
46__advmap goes out of #6 - if hero and SOM are active and stands on terrain with space hero centeres, but if stands in object > crash (log:“remote host broke the connection”-translation from russian, because it was russian, i think its h3textres)
47__system notbug, when h3sod and vcmi71 running some strange system hangs with F4 pressed in vcmi, after that vcmi and h3 like fighting(if alt-tabbed) but some F4s in h3 and vcmi restores both games(log and console - tell nothing about it)
48__herodlg ballista, ammocart, FAtent, catapult could be taken from their slots and placed to backpack, console says “system message from server:you are not allowed to perform this action!”, but i see all in backpack, reopening herodlg puts them on hero, such message appears in cases of sorting arttifacts in backpack, misc slots and 2 rings, so just disable taking warmachine-“arttifacts” from hero screen
49__battle ballista has morale, it shouldn’t, maybe FAtent and catapult have it too, originally ballista can have only luck, and other warmachines no luck, no morale
50__battle mouse hover on non-current unit makes the “special hoveranimation” , but small quick mouse moving makes the anim start and start again - unit like mad, u need to make it finish or even start again after rehovering mouse
51__battle mouse cursor with direction of attack doesn’t change direction , u need move it FROM direction u want to attack, but i think u know this )))
52_advmap hero in subter gate going up/down with space loses movement points, and game could crash, i think works after hero sleeps 1 night in subter gate, and on the next day i get a cloned hero, who has the same direction as original,but stands in subter gate, also if i use space and “move hero” button with existing path but when hero is other level then path it causes crash, so check all space procedures, cause it crashes in town and i think in lots of places
53_gamedata hero with intelligence from start of the game has not “intelligent” amount of mana, only basic(10*knowledge)
54_townview nice crash )))) click any army then shiftclick a hero, like we trying to send ahero to army and unit to be a hero
55_townview seems that tavern in conflux doesn’t work or simpply )) crashes the game

and thats only few hours of testing after i downloaded 0.71, and i’ll find much more, anyway


This behaviour was just more simple to implement. I hope nobody wants me to fix it instead of focusing on ranged spells (that’s what I’m implementing right now). I’m going to fix it anyway, but later.

55 bugs in two weeks. Thanks! I love you :wink:
Now I’m focused on adding several new features (including artifacts and map events) and I still need several more days. Then I’ll move to the solving reported issues. So please, don’t be impatient if we are not responding quickly on your reports. Every bug will be eventually inspected, so keep doing good job :slight_smile:

Tested this since i haven’t had that problem and it’s actually a resolution bug. I’ve been playing in 800x600 and it’s been working fine. Changing to 1024x768 is always causing the obstacles and the related blockmaps to be placed on different places on the battlefield. same with 1024x600 of course.

#36 Another problem with obstacles which I don’t think is caused by obstacle.txt either (Quite likely the same resolution problem) is that objects seems to not be placed correctly inside the hexes. They’re like pushed outside the hex. Sometimes to the right sometimes to the left (Not whole hexes either it’s like a third of a hex, which makes me think it’s not a blockmap problem). The problem is probably that only the blockmap gets placed at certain hexes while the actual obstacles doesn’t get “locked” to those hexes.

As you can see here: H3C obstacles is always placed perfectly inside each hex in the grid while VCMI obstacles is placed in between hexes and pushed outside hexes and such. This pic was taken when playing in resolution 800x600.

I’m currently checking obstacles.txt from time to time and actually I don’t think it’s that much to fix. If the bug that caused obstacles to appear on wrong terrains was fixed in changeset 789 (stating: “* possibly fixed problems with handling obstacles info”) Then I think most of obstacle.txt is correct. There’s one bug with blockmaps which can be seen in the image above and that is that the ribs there (ID:#1 in ERM help and obstacle.txt) should have one more blocked hex in the top right but that’s actually wrong even in the ERM help files. I’ll keep checking it for bugs tho.

Log number added (Zamolxis)

Yes, you’re right. I’ve fixed that.

As I see that it cannot be solved easily. Each obstacle needs its own shift… the only method that cames to my mind is to put all those shifts in obstacles.txt and use them later for correct placement.

Btw, thanks for checking it. :slight_smile:

No problems :slight_smile:

#56 Strange path: should obviously follow the road. (Both pics from vcmi)

Is this different from H3 behaviour?
Diagonal road is present both on upper and lower tiles, it’ internally stored like that:


when I tested it in Heroes 3 Complete it always picked to go straight on top of the road (lower tile), it’s possible that it’s the same amount of movement cost, maybe it just picks the lower tile first if possible in Heroes 3. This is not that important to fix if this is the case.

Edit: yup you’re right it costs the same, so i guess the only thing that’s different is that Heroes 3 chooses the lower tiles on the way down while vcmi chooses the upper (not that important to fix if it has to be be fixed at all) also noticed that if i stand on the diagonal road (lower tile) and walks up to where the hero stands in the pictures above, then Heroes 3 chooses the upper tiles also (same as vcmi). So I think Heroes 3 chooses lower tiles on the way down and upper tiles on the way up, vcmi chooses upper tiles in both cases (always?).

Edit2: This seems to be the case most of the time but dno if it’s acting that way always… so i guess you could just ignore this post :unamused:

One of my 2 favorite games (another one is Morrowind :stuck_out_tongue: ) and going to become open-source too! Great work!
I don’t know did this stuff implemented already or not, so probably an issue:

#57 if you build a lookout tower (in tower) it will not increase visible zone

#58 when right-clicking on a town near obstacles (trees for example) message says “trees” (heroes 3 will show town info - difficult to select town itself) - tested on map Carpe Diem, red player, but i doubt that this one is exception.

As far as I see there is not allies yet? At least I don’t see them on the map…

The H3 & VCMI paths may indeed be equally cost effective now, but on top of that, I believe NWC had a more “complicated” formula, in order to have the chosen path look as realistic as possible. Indeed, if we look at Aidis’ first screenshot above, it looks like the hero will make his 4th “step” on the side, through the snow, avoiding the path in the 2nd turn. So although the road makes only a right-turn, it looks like the hero actually makes a left-turn, in order to get back on the road.

So, by combining the most cost effective movement, with the realistic path choice, in H3 we have the following:

Path1: Hero will need to leave the diagonal path to the right (our left), so he “chooses” the road tiles which for us seem to be on the side of the road (already a bit in the snow)
Path2: Hero does not need to leave the diagonal path, so he “chooses” the road tiles which give us the feeling he really took the road
Path3: Hero will need to leave the diagonal path to the left, so he “chooses” the road tiles which seem to be the main road again (because there are no tiles still belonging to the diagonal road, which would actually seem like they are on the left side of the road, as we had for Path1)

Path1: Path2: Path3:

VCMI instead - judging by Aidis’ screenshot - seems to have a different principle, of always choosing the upper/right (left for us) tile, as long as the next step is still along the diagonal road. And this might give the players who don’t know that “technically” that’s also the road, the feeling that their hero is quite often going on the side of the road, which might cost them movement points.

So my guess is that the H3 priority order goes as follows:


  • If the road is on the down/left → up/right diagonal, hero will choose the down/right diagonal (**bolded **above), unless their destination is somewhere on the upper/left side of the road, in which case he chooses the up/left diagonal (*italicized *above). Note that he chooses this (let’s call it) secondary diagonal, also if the road makes a turn towards the upper/left side of the axis of the diagonal road, if he remains on the road until after the turn (I’ve tested that as well)

  • And the contrary, if the road is on the up/left → down/right diagonal, he’ll choose the down/left (bolded) tiles, unless the destination is somewhere on the upper/right side of the road, or if a turn in that direction will follow (and his path is set until after the turn of course).

Maybe we just need to change the sequence of checking directions? Curently it’s 42167538 (in the format described in code box). I’ll investigate it later, but I think that moving direction 7 to front should help (then the pathfinder will look for a path going down as much as possible with respect to the condition of the least cost).

1 2 3
4   5
6 7 8

That’s it! :slight_smile: Why didn’t I think of it (and spent so much time writing all that post)? :stuck_out_tongue:

It’s indeed as simple as that: if a hero is going down on the diagonal road, he prefers the down tile rather than the side tile, while if he goes up, he prefers the side tile rather than the up tile (because “down” is the priority).

And the only case in which he would choose the “upper” tile, would be if his destination point is somewhere upper as compared to the diagonal road (and that includes the road itself making a turn in an “upper” direction).

Maybe this already known, but I don’t see them in this thread.

In battle -
**59)**move cursor to your own unit, then move cursor to enemy unit (your unit must be inactive and be close to enemy unit ) - you will still have “question” cursor instead of sword

**60)**when two-tile centaur attacked my skeleton from top (see screenshot) VCMI crashed.

**61)**VCMI crashes on startup. Removing map (user-made, WOG, no ERM) “Isles of Illusion” (see attachment) solved this issue.

**62)**Scenario selection menu - browsing by up/down keyboard key did not change screen position when end of screen reached

**63)**After withdraw from battle - hero does not appears in the tavern

**64)**Events are invisible but right click show a popup “event” and there is a problems with movement - event needs to be 100% passable (I know - events are not functioning yet, but movement makes some map unplayable)
Isles of Illusion.h3m (186 KB)





Implemented by Tow Dragon. Spell can be cancelled by pressing escape or right-click.

Fixed and added support for Corpse as well.

Fixed by Ubuntux.


Fixed by Ubuntux.


Thanks for all the reports, soon more fixes / comments!

Bug with pathfinder is fixed also.

#65 Unreproducible bug: The mouse cursor disappeared from the game interface at the end of a battle.

I was playing in 1024x768 resolution. After a battle with some Serpent Flies, when the window with battle casualties opened, the mouse cursor disappeared from the game interface: both the arrow and the functionality (as I tried left/right clicks and nothing was happening). Alt-Tabbing did not bring it back. Also the game interface was not accessible anymore also via keyboard: I could now use the Enter key to close the Battlefield Casualties window box. The only area of the VCMI client interface that was still accessible with the mouse was the upper window bar - the one that can be used for moving/minimizing/closing the window.

Unfortunately I rushed to reproduce the error afterwards, forgetting to save a copy of the client log, in case that might have been of help. But trying to reproduce the error failed. I even tried with same creature moves, and same casualties from my side (1 Basilisk), but no “success”.

I doubt that it’s gonna be of any use, but I’m attaching here the saved game before the battle (file might be of more use for the below bug actually).

#66 Reproducible bug: As can be tested in the attached file, switching Armor of the Damned with Titan’s Cuirass on Gerwolf does not really work. If we reopen hero interface after artifact switch, he has Armor of the Damned again. By the way, I don’t actually remember picking Armor of the Damned earlier in the game, so this may have another bug behind (but I’m not sure about this - it’s a game I started almost 1 month ago, and only now reloaded the saved file to play further).
Titan’s Cuirass switch artifact (69.4 KB)

#67 Right-clicking a creature on the battlefield keeps the mouse pointers and left-click functionalities regardless of the info box opened (as long as we keep the right-click pressed):

a. It was ballista’s turn. Right-clicking on the target enemy unit opened the info box, but mouse cursor remained an arrow:

b. Following the above, I kept the right-click pressed and moved the mouse in different directions. The cursor was changing into the “not available” icon when I was not above the creature hex behind the info window:

c. While holding the right-click, I also tested if I can move on with the battle while having the info box opened. This is what I got:

When the pointer was in “not available” status (not above the target hex) I could not shoot with the ballista
When the pointer was an arrow (above target) I could shoot
During the shot, the info box was disappearing for a moment to show me the shooting animation, and then appearing again
The bad part here is that when it reappeared after the shot, the Health loss of the target was not yet displayed
After the above shot, Ballista got a morale boost so I shot again
Again, the info window disappeared for a moment for me to see the animation, and again the info reappeared, without registering the 2nd Health loss
After that I removed my finger from the right button of the mouse for the first time, and right-clicked again - only now I could see the correct health loss after 2 Ballista shots

So basically we have the following:

  • After right-click in H3 we cannot move on with the battle while the info box is open, while in VCMI we can
  • While this is a behavior different than H3, is not a bug in itself, just a difference in functionality which does not impact the gameplay
  • However we do have a bug with this behavior, namely the fact that the Health losses are not registered when the info box reappears after the hit/shot, is we keep the right-click pressed on a target creature while moving on with the battle.

#68 Garrisoned heroes cannot buy spell book.

#69 Not sure if this was reported before: When we don’t have enough spell points left for certain spells, the spell book still displays them as “available”. We can also still select them. Only when we try to cast them on the target creature nothing happens.

EDIT: See difference in H3 screenshot:

#70 On Day 1 of Week 2 of Month 2, one of the 2 heroes which were offered at the Fortress Tavern in the beginning of the week was Jenova, Level 1 Ranger, with only 1 Centaur in the army. This should not happen unless we already purchased a hero or if she would be a retreating hero, which was not the case.

If it is of any use, this happened on the same map as the saved game attached two posts above (the save was from day 1 of the previous week). However it seems not reproducible: I also reloaded the above game and played until Day 1, Week 2, Month 2, but this time both heroes in the Tavern had normal stacks.