Vcmi 0.71 bug seeking thread

Hehe… you got me this time. :slight_smile:

But I’m actually happy I’m finally wrong about spotting a pathfinder issue. I’ve kinda got bored as well of reporting one after every release. :stuck_out_tongue:

You mean Garrison is the name of the in-game Mutare Drake in the game files? (I’m curious what is Mutare’s then…) :smiley:

Anyway, I agree that she shouldn’t have showed up in that Tavern because she’s a campaign hero only (introduced in AB I think). But I thought she’s first of all a Dungeon hero, so which should have Dungeon troops. The fact that she was in the Tavern was less suspicious for me, but I guess that’s because of all the user made maps I’ve played, where often campaign heroes are allowed at Tavern (and I guess we should foresee this case as well, for the future VCMI map editor). :stuck_out_tongue_winking_eye:

Personally I don’t have any experience with bug trackers. I only used a bug report tool when I was testing for Ubisoft, but I assume that’s sth different. I didn’t like it anyway (it was much more fun on the forum, where one gets to see and comment on the bugs reported by others :->).

That doesn’t mean I’ll mind using the bug tracker. It does sound like sth that can be of great help for the devs, now that we seem to find like 50-100 bugs at every release. After I’ll get the hang of it, I’ll prolly love it and prefer to the forum. But a bug tracker will always leave out the new/occasional testers, for which bug threads should always be there (and the let’s say “regulars” could help logging all bugs to the tracker).

[size=75]So, to go back to the bugs: :stuck_out_tongue: [/size]

#23 When I close VCMI using the window close button, I get the typical Windows error: “VCMI_client.exe has encountered a problem and needs to close. We are sorry for the inconvenience.”

Doesn’t bother much, as it’s only when I exit the application. I’m not sure though if I had this the previous days as well, but now I have it every single time I close VCMI. I’ll let you know tomorrow (after a PC restart) if I still have it. I’m thinking it could be a tiny conflict with Winamp: I noticed that first time I opened VCMI today it took like 30 secs to get to the Main Menu screen. And except for Winamp, there was no important application running in the background that may cause a conflict in resources.

For the record, closing VCMI from the in-game dedicated button (Quit to Desktop) does not generate the error.

I’m attaching the Client Logs for one and the other types of application exit - maybe it helps.

I’m attaching the
VCMI_Client_log after (1.29 KB) (1.38 KB)

Fireballs used by Gogs aren’t flying in straight line - instead they are doing something like curve.

Tested on Arrogance3. In HoMM III, the number of creatures at the beggining is their base upkeep - for example, 1 Behemot. In VCMI, with Grail and Castle, you can buy 3 instead.

#26 Reproducible crash: on the map “A Warm and Familiar Place”, going down right from your castle, pass the scholar, sulfur mine and windmill. Pick up then the closest Mercury. If you try to access the Alchemist Lab after that, the game crashes (every time):

#27 Unreproducible crash: I had a crash similar with the one above, when trying to access a Seer’s Hut (from a similar angle as I had above, and also when hero was 2 movement tiles away from destination). A retry on the same map and from the same angle failed. I’ll try using the same alignment, heroes, and maybe even order of movements (if I remember well) to reproduce it. I’ll get back on this if I succeed.
UPDATE: I tried a couple of times to reproduce it (same map, hero), but it doesn’t occur again.

#28 Garrisoning, then removing from Garrison of a hero, does not move him/her at the bottom of the hero list.

#29 Just a feature actually: I see Redwood Observatory functionality has been implemented. The same functionality (same radius) should then be associated with the underground Pillar of Fire as well.

#30 Heroes are still walking over each other on pre-defined paths sometimes (hardly reproducible - had it happening only twice in the last hour)

#31 Nothing happens if I pick up a scroll: the bottom right status box window does not show anything and no scroll appears on the hero…

#32 We cannot cancel a selected spell in any way: not by pressing ESC, not by right-clicking and also not by selecting a different spell from the book instead

#33 We can open the spell book at any time, even after we’ve cast the spell for the turn. The button should be grayed out and unaccessible until the beginning of the next turn.

#34 After playing al lot with opening the spell book numerous times during one battle, and also trying to cancel a spell in different ways, during the next battle I couldn’t cast any spell anymore. I was opening the spell book, selecting a spell, but then nothing was happening when I was clicking the target creature. Note that I’ve had the bug for 1 battle only. The battle after (so 3rd let’s say) could again be carried out also by using spells.

#35 Game crashed again during hero movement. And again (for the 3rd time!) it happened two tiles away from the pre-set destination on his parth:

s[/s] This is most probably related to bug #18. The visible obstacles are ignored, while “invisible obstacles” seem to prevent the creatures to access some hexes which are completely free:

Edited because #36 was indeed same as #18. #36 used for another related bug reported by Aidis below.

No, by “Garrison” I meant her starting army. Sorry for that mental abbreviation.





It’s probably caused by the 1024x768 resolution and walking nearby bottom end of the map.
Border is to small and it apparently causes the crashes. I hope it will be fixed soon.

Apart from that I’ve added support for Schools of Magic/War that were requested in another thread. Additionally I’ve added autosave which wasn’t requested but I thought it will be definitely good to have it, especially when VCMI is still rather unstable :wink:

While trying to reproduce this bug, I also ran into a crash:

#37 I gave one hero a pre-defined path (destination was the town gate, about 10-15 movement arrows away). Then I moved 2 other heroes in 2 different places on that path. Then I hit End turn. In the beginning of the next turn, I tried to move the 1st hero. He did start his movement, but got stuck just before the first “obstacle hero” on his path, also causing VCMI to crash.

I believe you’re right. I tried to reproduce bug #26 on 800x600 and couldn’t (while in 1024x768 it always crashes).

Autosave is indeed a very good idea. VCMI is lately always crashing before I even complete the first week (with so many heroes exploring different areas in the same time). So it’s a bit frustrating I never manage to get far on any map. :stuck_out_tongue: Plus autosave might help in better reproducing some situations leading to crashes.

Thanks for all the other bug fixes and implemented features. :slight_smile:

I think it’s because of wrong blockmaps in obstacles.txt… I still hope someone else will fix it.

I’ll try to implement it soon.

Yes, it’s because of too narrow border.

#38 The Corpse is not accessible from above.

#39 The Info text should not only give the name of the object (i.e.:“Corpse”), but also the (Not visited)/(Visited) text next to it.

So hi everyone!
i ve been looking on project since 0.6 and now i want to share bugs )))))
i ve passed almost all bugreport topics and havent seen those bugs i ve found
so check it out:
40__foolproof loadgame-single(no saves)-mapsizebuttons > crash(console too)
41__foolproof loadgame-single(no saves)-load > crash (console"Error: cannot open to read .vlgm1")
42__customap timed event (and maybe other “up to 8 pictures dialog” shows pictures out_of_border) with resourses taking makes resourses count negative
43__advmap outofmap picture is greater horizontally unlike h3, its hint to left and to up is cool (small square-dialog), but no hints to right and to down
44__advmap up_hero_selector_button calls upper hero dialog, same for town
45__advmap notbug , maybe feature - when system options menu(SOM) opened, the map is scrollable, map animation is present, doesn’t close with esc, closes with enter(in h3 closes with esc, enter-nothing)
46__advmap goes out of #6 - if hero and SOM are active and stands on terrain with space hero centeres, but if stands in object > crash (log:“remote host broke the connection”-translation from russian, because it was russian, i think its h3textres)
47__system notbug, when h3sod and vcmi71 running some strange system hangs with F4 pressed in vcmi, after that vcmi and h3 like fighting(if alt-tabbed) but some F4s in h3 and vcmi restores both games(log and console - tell nothing about it)
48__herodlg ballista, ammocart, FAtent, catapult could be taken from their slots and placed to backpack, console says “system message from server:you are not allowed to perform this action!”, but i see all in backpack, reopening herodlg puts them on hero, such message appears in cases of sorting arttifacts in backpack, misc slots and 2 rings, so just disable taking warmachine-“arttifacts” from hero screen
49__battle ballista has morale, it shouldn’t, maybe FAtent and catapult have it too, originally ballista can have only luck, and other warmachines no luck, no morale
50__battle mouse hover on non-current unit makes the “special hoveranimation” , but small quick mouse moving makes the anim start and start again - unit like mad, u need to make it finish or even start again after rehovering mouse
51__battle mouse cursor with direction of attack doesn’t change direction , u need move it FROM direction u want to attack, but i think u know this )))
52_advmap hero in subter gate going up/down with space loses movement points, and game could crash, i think works after hero sleeps 1 night in subter gate, and on the next day i get a cloned hero, who has the same direction as original,but stands in subter gate, also if i use space and “move hero” button with existing path but when hero is other level then path it causes crash, so check all space procedures, cause it crashes in town and i think in lots of places
53_gamedata hero with intelligence from start of the game has not “intelligent” amount of mana, only basic(10*knowledge)
54_townview nice crash )))) click any army then shiftclick a hero, like we trying to send ahero to army and unit to be a hero
55_townview seems that tavern in conflux doesn’t work or simpply )) crashes the game

and thats only few hours of testing after i downloaded 0.71, and i’ll find much more, anyway


This behaviour was just more simple to implement. I hope nobody wants me to fix it instead of focusing on ranged spells (that’s what I’m implementing right now). I’m going to fix it anyway, but later.

55 bugs in two weeks. Thanks! I love you :wink:
Now I’m focused on adding several new features (including artifacts and map events) and I still need several more days. Then I’ll move to the solving reported issues. So please, don’t be impatient if we are not responding quickly on your reports. Every bug will be eventually inspected, so keep doing good job :slight_smile:

Tested this since i haven’t had that problem and it’s actually a resolution bug. I’ve been playing in 800x600 and it’s been working fine. Changing to 1024x768 is always causing the obstacles and the related blockmaps to be placed on different places on the battlefield. same with 1024x600 of course.

#36 Another problem with obstacles which I don’t think is caused by obstacle.txt either (Quite likely the same resolution problem) is that objects seems to not be placed correctly inside the hexes. They’re like pushed outside the hex. Sometimes to the right sometimes to the left (Not whole hexes either it’s like a third of a hex, which makes me think it’s not a blockmap problem). The problem is probably that only the blockmap gets placed at certain hexes while the actual obstacles doesn’t get “locked” to those hexes.

As you can see here: H3C obstacles is always placed perfectly inside each hex in the grid while VCMI obstacles is placed in between hexes and pushed outside hexes and such. This pic was taken when playing in resolution 800x600.

I’m currently checking obstacles.txt from time to time and actually I don’t think it’s that much to fix. If the bug that caused obstacles to appear on wrong terrains was fixed in changeset 789 (stating: “* possibly fixed problems with handling obstacles info”) Then I think most of obstacle.txt is correct. There’s one bug with blockmaps which can be seen in the image above and that is that the ribs there (ID:#1 in ERM help and obstacle.txt) should have one more blocked hex in the top right but that’s actually wrong even in the ERM help files. I’ll keep checking it for bugs tho.

Log number added (Zamolxis)

Yes, you’re right. I’ve fixed that.

As I see that it cannot be solved easily. Each obstacle needs its own shift… the only method that cames to my mind is to put all those shifts in obstacles.txt and use them later for correct placement.

Btw, thanks for checking it. :slight_smile:

No problems :slight_smile:

#56 Strange path: should obviously follow the road. (Both pics from vcmi)

Is this different from H3 behaviour?
Diagonal road is present both on upper and lower tiles, it’ internally stored like that:


when I tested it in Heroes 3 Complete it always picked to go straight on top of the road (lower tile), it’s possible that it’s the same amount of movement cost, maybe it just picks the lower tile first if possible in Heroes 3. This is not that important to fix if this is the case.

Edit: yup you’re right it costs the same, so i guess the only thing that’s different is that Heroes 3 chooses the lower tiles on the way down while vcmi chooses the upper (not that important to fix if it has to be be fixed at all) also noticed that if i stand on the diagonal road (lower tile) and walks up to where the hero stands in the pictures above, then Heroes 3 chooses the upper tiles also (same as vcmi). So I think Heroes 3 chooses lower tiles on the way down and upper tiles on the way up, vcmi chooses upper tiles in both cases (always?).

Edit2: This seems to be the case most of the time but dno if it’s acting that way always… so i guess you could just ignore this post :unamused:

One of my 2 favorite games (another one is Morrowind :stuck_out_tongue: ) and going to become open-source too! Great work!
I don’t know did this stuff implemented already or not, so probably an issue:

#57 if you build a lookout tower (in tower) it will not increase visible zone

#58 when right-clicking on a town near obstacles (trees for example) message says “trees” (heroes 3 will show town info - difficult to select town itself) - tested on map Carpe Diem, red player, but i doubt that this one is exception.

As far as I see there is not allies yet? At least I don’t see them on the map…