Unable to launch the game


I tried to edit the xml file in order to give the application all files permission but ended up going nowhere,this error have been bugging me off for a long time now, someone, please give me a hand?

What version is it? From Google Play or from our daily builds?

It’s from daily builds

Bad news. What is Android version? Does it crash right after you start it?

I have the same error message. It occurs on android 11 & android 12 with the latest daily builds when trying to use the vcmi-files from external drive.
The crash is directly after hitting start vcmi.
The problem doesn’t occur with the old GoogleStore version.

You can work around that problem by packing the necessary folders (maps, mp3, data) in vcmi-files.zip and use the import function.

Android 11, it crashes when i launch the game, not the launcher

That’s what i did but this still happens :stuck_out_tongue:

This is more or less known issue. There is no Android developers to fix it. Google does not want apps to access storage in uncontrollable way so they changed storage mechanics. I implemented Internal storage where you can import a zip archive with required data but this is still not the best way to do this. Take into account that Import button does not do things immediately. Try to clean storage and reimport. Also remove video.vid from zip file

So it worked, but there’s no vcmi-data file so sadly i can’t put in mods or custom maps, better than the HD edition i guess¯_(ツ)_/¯

Try to pack Mods folder in zip and use Import on it. But take into account that old saves might break.