Ubuntu 20.04 undefined symbol

Hello, I installed vcmi in UBuntu 20.04 from the multiverse repository. When I run it I get this error:

vcmiclient: symbol lookup error: /usr/lib/x86_64-linux-gnu/libSDL2_image-2.0.so.0: undefined symbol: SDL_RWseek

I’d try the ppa with the daily builds, but when adding that ppa I get this error:

E: The repository 'http://ppa.launchpad.net/vcmi/ppa/ubuntu focal Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.

I tried building from source and vcmilauncher, vcmiserver and vcmitest actually built succesfully but vcmiclient failed with an Error 2 I’m not able to understand.

Expanding on my issue, I found these two interesting errors when building:

/home/tony/src/VCMI/vcmi/client/gui/Fonts.cpp:13:10: fatal error: SDL_ttf.h: No such file or directory
...
/home/tony/src/VCMI/vcmi/client/gui/CAnimation.cpp:13:10: fatal error: SDL_image.h: No such file or directory

but I have the relevant packages installed as per instructions and those header files are in fact in my system:

/usr/include/SDL2/SDL_ttf.h
/usr/include/SDL2/SDL_image.h

Anyone trying to build VCMI under Ubuntu 20.04?

I built it myself and no not remember this kind of error. In most cases this is an error in the Makefile or on the cmake input file (don’t remember the exact name). The problem is the include path. If you take a look at the compiler output just before the error message, there should be the compiler call. It has tons of switches. One of them is -I, which is the include path. It should contain the path to these files.

Another option would be: Add the path manually to the files where this error pops up. So there should be a line like this near the beginning of the file:
#include <SDL_ttf.h>
Change that to:
#include <SDL2/SDL_ttf.h>

Hosting provided by DigitalOcean