Problem with starting the game [error in JsonNode.cpp]

Hello

Today I tried to compile and run VCMI. I followed this instruction wiki.vcmi.eu/index.php?title=Installation_on_Linux. Compilation was sucessful, but when I tried to run it, I got following error. Does anyone know where the problem is?

[[email protected] client]$ ./vcmiclient 
Starting... 
Creating console and logfile: 0
         Initialization: 10
         Data loading: 150
                Found mod filesystem: ALL/MODS/VCMI/FILESYSTEM
                Found mod filesystem: ALL/MODS/WOG/FILESYSTEM
         Mod filesystems: 10
File system handler: 170
Failed to open file 
Last system error was : No such file or directory
Loading settings: 170
VCMI 0.9 (client)
Note: SDL suggests to use 32 bpp instead of24 bpp 
New screen flags: 0
        Initializing screen: 80
        Initializing video: 0
        Initializing minors: 0
        Initializing sound: 20
Initializing screen and sound handling: 20
        Mod handler: 0
[smk @ 0x1f86ca0] max_analyze_duration 5000000 reached at 5066160
        General text handler: 10
        Hero handler: 20
vcmiclient: /home/adamus/dane/git/trunk/src/lib/JsonNode.cpp:223: const JsonMap& JsonNode::Struct() const: Assertion `type == DATA_STRUCT' failed.
Przerwane

I’m using Archlinux.

Make sure that DATA_DIR/config (usually /usr/share/vcmi/config) is identical to SOURCE_DIR/config.
Copy it or make a symlink to be sure.

Have you installed vcmi from 0.9 source package or from current svn?

I’m using SVN version. You was right. My DATA_DIR/config and SOURCE_DIR/config was different. Now everything works fine.
Thanks for help.