Problem installing VCMI in Ubuntu

Hello and thanks in advance for any assistance! I’m not too good at Ubuntu but I’ve searched for answers on this forum and the internet without success.

I’m trying to install VCMI in Ubuntu 16.10 following the VCMI Wiki guide.

I added, updated and installed the VCMI repository on Ubuntu.

My problem I believe is installing the HoMM3 data files.

I started by attempting an automated installation. When I try

vcmibuilder --cd1 /path/to/iso/or/cd --cd2 /path/to/second/cd

it looks like this

vcmibuilder --cd1 /home/andrew/Desktop/setup_homm_3_complete_4.0_(10665).exe

or I also tried this as it was unclear to me if I needed the second cd (in which case I used the same thing twice)

vcmibuilder --cd1 /home/andrew/Desktop/setup_homm_3_complete_4.0_(10665).exe --cd2 /home/andrew/Desktop/setup_homm_3_complete_4.0_(10665).exe

Setup_homm_3_complete_4.0_(10665).exe is the HoMM3 file (purchased from, but the problem is I receive the following in response:

bash: syntax error near unexpected token `('

I don’t have the installer and it seems complicated to install the installer, so I then attempted:

vcmibuilder --data /path/to/h3/data 

I had previously installed HoMM3 via Playonlinux so I copied the Playonlinux HoMM3 directory to the desktop in a folder called “HoMM 3 Complete” and did:

vcmibuilder --data /home/andrew/Desktop/HoMM 3 Complete

but I received this in response:

VCMI data builder utility
Usage: vcmibuilder <options>
 --cd1 DIRECTORY   Path to mounted first CD with Heroes 3 install files
                   Requires unshield

 --cd2 DIRECTORY   Path to second CD with Heroes 3 data files.

 --gog EXECUTABLE  Path to executable
                   Requires innoextract ( )

 --data DIRECTORY  Path to installed Heroes 3 data

 --convertMP3      Convert all mp3 files into ogg/vorbis
                   Requires ffmpeg or avconv

 --dest DIRECTORY  Path where resulting data will be placed. Default is ~/.local/share/vcmi

 --validate        Run basic validness checks

Perhaps this is good, or perhaps it’s not, but I certainly don’t know how to proceed with it in order to install and play the game.

I finally tried to manually intall the HoMM3 data files, but when I type vcmilauncher in the console I receive:

Failed to open file /home/andrew/.config/vcmi/modSettings.json
process 7062: arguments to dbus_connection_ref() were incorrect, assertion "connection->generation == _dbus_current_generation" failed in file ../../../dbus/dbus-connection.c line 2686.
This is normally a bug in some application using the D-Bus library.
process 7062: arguments to dbus_message_unref() were incorrect, assertion "message->generation == _dbus_current_generation" failed in file ../../../dbus/dbus-message.c line 1718.

followed by countless repetitions of the same message:

This is normally a bug in some application using the D-Bus library.
process 7062: arguments to dbus_connection_unref() were incorrect, assertion "connection->generation == _dbus_current_generation" failed in file ../../../dbus/dbus-connection.c line 2822.

and subsequently typing vcmiclient -v into the console as the Wiki guide appears to indicate in order to determine the data directory doesn’t have any effect at all, just nothing happens.

So you see, I feel sort of like twelve pikemen up against five lizard warriors, eight minotaur kings and a dancing wombat: the odds are daunting. Please, this is a great game, I played it before on an older Ubuntu version… help me emerge victorious!

This was basically tell you that you need to escape “( )” characters in bash.

I sadly not sure what’s wrong with dbus on Ubuntu because I run it on both Kubuntu 16.04 and 17.04 and there no issues. Though it’s not only problem for you:

I’ll certainly try to investigate it, but there is long list of other things before that.

BTW I just tried to extract latest GOG installed on Kubuntu 17.04 and it’s working fine:

./vcmibuilder --gog Heroes\ of\ Might\ and\ Magic\ III\ Complete\ GOG/setup_homm_3_complete_4.0_\(10665\).exe

So if it’s not working for someone then problem is with older innoextract version.

OK thanks!

I managed to install it on Ubuntu 14.10 using an ISO downloaded and mounted from … ii-review/

Also once you get that going, be sure to download the Windows version of VCMI, extract the vcmi mod and copy it manually into ~/.local/share/vcmi/Mods.