No sound in VCMI

I managed to get vcmi runningon my KUbuntu 12.04 x64 system, though the directories described by

vcmiclient -v

weren’t made automatically, so I made a ‘/usr/share/vcmi’ manually. I didn’t see anything about the other 2 directories so I didn’t worry about them.
VCMIclient runs, but I get these errors in the console:

Warning: Cannot open /usr/share/vcmi/Mp3/MAINMENU.MP3: Couldn't read from '/usr/share/vcmi/Mp3/MAINMENU.MP3'


sudo chmod -R a+r /usr/share/vcmi

so that files could be opened, and that allowed vcmi to start, but I still have this issue. Amarock can play the MP3s from this directory so I don’t understand the problem.

Version 0.89 from .deb packages?

If so - this may be case-sensivity issue. Make sure that you have this file with exactly same name.
Most possibly directory name is “MP3” - it must be Mp3 instead. Same goes to file name - make sure that name is exactly as you see it in console.

Should be fixed in next release.


That was it! Thanks!

One other quick question: In the menu for a new scenario, there’s a button next to ‘Random Map’ that says ‘WoG Options’, is that not yet implemented? There’s no ‘depression’ animation if I click on it and it doesn’t do anything that I can see, and I couldn’t find a manual for 8.9 (only 8.7) so I’m not sure if something is broken there or just work in progress.

Wog options are not implemented. Same goes to random maps, network multiplayer and campaigns. These are most notable things.

Okay, thanks. Looking forward to the next release!