Main bug thread

If VCMI crashes, we would like to know about it to resolve that problem. In this thread you can post information about your problem - please write about:

  • installed mods (ie. H3 WoG 3.58f + Acid Dragon’s New Updates)
  • language version (ie. English)
  • when crash happens (while loading, after map has been chosen, after specific action when map is loaded - in last two cases please give us map’s name)

Thank you in andvance for your feedback - we cannot test our program on any configuration. Your help will make future releases better.

Game won’t start.

Game: WoG 3.58f - english


Initializing screen, fonts and sound handling: 134
Loading .lod files: 78
Scanning Data/: 0
Preparing first handlers: 0
Preparing players’ colours: 16
Preparing more handlers: 500
Initializing colours and flags: 500
CPreGame: loading txts: 15
CPreGame: main menu initialization: 94
CPreGame: newgame menu initialization: 94

After that,starting game crashes.

Which map causes that crash? Did you try that one distributed with VCMI? If it works on some maps, please send me names of maps which crash VCMI…

If I see correctly that isn’t bug with map loading, but with preparing scenario selection list.
Probably you have a map with unsupported feature affecting the map file header (Hero Placeholder?). There was also a bug in reading victory condition in 0.54, but it wasn’t critical (for map header handling).

It is now OK!

I was created new clean install and instaled wog 3.58f english version, and for now everything working fine.

Just to mention that I’m playing heroes 3 more than 5 years, - now, it is only game i’m playing at all. I trayed Heroes 4, then Heroes 5, but nothing is more fun and enjoyable than heroes 3, especialy with WOG. So projects like this are for me very valuable and I’m supporting them with all my heart.


on Linux/Wine the latest version just shows a black window with title “SDL App” and does not respond to closing.

Just informational :slight_smile: Since this project is in an early stage and there will be a native linux version, which should make wine obsolete.

Addons: WoG 3.58f
System Language: Russian
Game Language: Russian

not understandable symbols instead of the russian characters

Probably it’s encoding problem, cyryllic alphabet isn’t supported yet.
You may extract English language files into Data/ folder, then everything should work fine.

Hi :slight_smile:

H3 + wog 3.58f. Nothing else.

Appreciate that some still use time on H3, loved the game for years , and still love it ^^.

Anyway, i ALWAYS play random games now when i play h3, but it seems that i cant make random games with VCMI… dunno if its a bug, or someting with my install… or if its upposed to be this way.

When i press random map, it comes the same page as on show avaible scenarios…

Edit: Could be that something is with my install… much stuff dont work properly, cant press on my town hall, or can sleep/wake hero or look on kingdom overview+++

And whats the deal with the screen when a hero walks? Its just weird…

VCMI is a work in progress.[/size] The goal is to first support all standard H3 RoE/AB/SoD/WoG features, then seek well described proposals to add to the standard H3 features. So the random maps ability will undoubtedly be added to VCMI.

Best regards,

Hello…i have major problem here with WOG…well actually my version is…but anyhow i wanna play it.The problem is in that game crushes allways when i m trying to upgrade commandero f army with new abillities.Does somebody knows why is this happening?

there are several messages on screen before crush into window.I ll write it now:

exception(trace detaila)_
###reason:“manage a pop up window”
###reason:“any object visiting automation”
###reason:“commander:check 4 add exp.”
###reason:“commander:add exp.”

eip=0x7c81eb33,unhandled exception

If can someone tell me where is problem i would be grateful…Thanx in advance…best regards…

the problem is this: i run VCMI.exe, the black dos window appears, then a SDL_app window pops out, then some text is shown in DOS window and program quits. I was unable to read what it says. my windows is XP SP1,
is it possible that it crashes because of no sound card in my pc?

Yes, it’s possible. Description of your error should be written to console so you can run VCMI using command line (I know that it’s ancient method of runnign apps, but currently there is no other way).

Yes, the sound is initialized between creating window and setting window title to VCMI (as the fonts). Check for “Mix_OpenAudio” error message on the output.
Currently VCMI crashes if unable to properly open audio, it should be changed in the next release (especially while there are hardly any sounds).

what do you mean command line? start menu->run? there happens the same…

No, not exactly menu->run. You should type there ‘cmd’ (without apostrophes) and run VCMI using the window that appears then. You can read about it here: .

I kind of like the fact that you can currently unequip the catapult. Trying to imagine the hero take the catapult and cram it in his backpack is great! :laughing:

Plus, I’m sure you know already that the ballista appears in the troop list instead of the war machine list.

If you have an artifact selected and you make a pop up appear, the selection box will show through the pop up window. The selection box flickers a little.

IIRC this bug has been fixed in trunk version.

I have weird weird bug on my VCMI 0.61 Install
I Have heroes 3 polish modded to english and wog 3.58f + script update
well not really clean, 'cos i tried to install samagossa scripts, which is out of work (it’s for future wog 3.59), but i think it’s not greater affecting on what i describe

When i try to load arrogance3 which comes with VCMI (wog format) it desires to crash

BUT if i run standard RoE map, the first in row “Arka Noego”, which is the polish one
it goes great, such as forum describes.

With a clean instal, I tried opening a first set of 18 RoE maps to start with. One of them crashed.

When I tried to open Free for All, I got the following messege:

As you can notice, I have Zone Alarm firewall. If I choose “Deny” in the ZA window, both VCMI windows disappear. If I choose “Allow”, then I get a Windows error:

I have shut down Zone Alarm and tried again, and got the same error, so IMO cannot be related to Zone Alarm. I have also attached the map for you to check if there is anything wrong with my file.

For the record, here are the RoE maps which loaded correctly:

  1. Overthrow Thy Neighbours
  2. Key to Victory
  3. Noah’s Ark
  4. All for One
  5. Xanthra’s Prize
  6. Serpent’s Treasure
  7. Search For The Grail
  8. Rumble in the Bogs (Allies)
  9. Ascension
  10. Good to Go
  11. Wings of War
  12. Barbarian Breakout
  13. Barbarian Breakout (Allies)
  14. When Dragons Clash
  15. Warmongers
  16. Rumble in the Bogs
  17. Rebellion

I’ll test some more tomorrow. Cheers!
Free for All.h3m (44.3 KB)