Launcher/Mod manager

Huh… on my system it was libEGL that caused that behaviour. It seems to vary from machine to machine. Bad. :frowning:

Could you check exactly which DLL is that you need to run launcher? Try “binary search” on non-debug DLL-s. I really would like to avoid packaging the whole Qt binaries with VCMI.

I meant, copied all .dll libraries that were already in game package: … uncher.rar
It may indicate some issue with version.

Didn’t add anything on my own.

Not very reliable test but still - I managed to run launcher via wine. It seems that /platforms/qwindows.dll is missing. It can be found in /msvc2012/plugins/platforms/qwindows.dll

BTW - I noticed that there are a huge icu.dll’s. Is there a way to remove them? According to this it is needed only for webkit. Which we don’t use anyway: … pendencies

I also noticed libflac (just 300 kb but unused AFAIK) and two versions of msvc dll’s - msvcp100.dll and msvcp110.dll. First one seems to be unused.

Mods/witchking-arts should be removed (leftover from launcher test I assume)

Are the binaries you linked any different from the ones I packaged in the 0.93b package?

I have used “Qt 5.1.1 for Windows 32-bit (VS 2012, 511 MB)” package.

I’ll check it.

QtCore depends on it, I would have to recompile the whole Qt.

Right, it seems that VCMI doesn’t recognise .flac as music. Perhaps we could, if we already have flac plugin for SDL?

Some libraries depend on msvcp100 because I built them with VC 2010.
I’ll recompile all libraries with VC2013 when it is released (~1 month).

Right, thanks for pointing this out. :slight_smile:

The fun this is I use just same package. Installer is named

Still, for now I can tell that dlls from pack didn’t work, while mine do, so something must be wrong here. I can replace one with another at any time to break or fix launcher.

Could you have by any chance copies also qtenv2.bat file from Qt bin/ directory? Apparently it is used to append to PATH you Qt installation dir, so that could explain why it suddenly started working.

If not… does extracting the 0.93b package overwriting your launcher DLLs stops launcher from working? From what I see the Qt binaries we have in out packages are the same.

Yes, exactly that. I can switch back and forth by extracting one package or the other.
Adding qwindows.dll to the mix doesn’t change anything.

It is in bin/ directory and only there.

Also, I used enviromental variable editor to set QTDIR - without it wouldn’t even be able to compile project.

I diff’ed out DLLs. Apparently Qt installer embeds the absolute path to install directory in the DLLs.

Please try using my package + qwindows.dll in the platforms/ subfolder.

It worked ^^

Kuririn also reported it worked for him.

That’s great, we have this working. I’ll make sure to correct this in the next package. Thanks for help.

Pretty trivial thing… However I just haven’t conceived that Qt installer might be altering Qt binaries to add developer-specific search paths.

Great job Ivan! :slight_smile:

Some questions & comments:

  1. With WoG mod enabled, I still can’t figure out how to enable the WoG Commanders/Artifacts/Experience modules. Either I’m missing something, or they just don’t work in 0.93c?

  2. Mods/witchking-arts seems to be still there, while on the previous page you said it should be removed. Unless what you meant was that it was coming as installed by default? But if you meant it should be removed from the launcher as well, I wonder why that is? I didn’t know it before, and I find it brings in pretty cool artifacts, so I prefer keeping it if possible.

  3. Just a detail: it would be nicer if the left/right panels could be adjusted in width individually AND keep the interface size settings for next time. Personally I prefer a left panel wider view which shows all columns, while the right panel could do with half of that width (i.e.: the one it has after I enlarge the left one as much as I want). If you could make it that we can use the middle bar to distribute the width between panels (AND keep setting), it would be great. But if it’s too much hassle, don’t bother.

  4. Not related to the launcher itself, but didn’t want to open a separate topic: is the True Type mod there because of the Russian mods (I saw a mention of it here), or for a different reason? I installed it to give it a try — it looks good in game windows, but it’s too big in stack size boxes in battles (I think 1 pixel higher & wider than the H3 fonts), which is not very practical and even a bit harder to read sometimes given the overlap of the upper pixels with the box frame. Just thought of mentioning it in case something can be done about it.

  1. Configuration of wog (or any other mod) is not present yet.

  2. It should be available in launcher for installation but it should not be installed by default. So everything is OK at the moment.

  3. After quick search I haven’t found how to do this. Not a bad idea but right now I don’t know how to do this with Qt.

  4. Actually at this point true type fonts are incompatible with any localization mods due to lack of unicode support.

In its current state this mod is more like experiment/proof of concept - still needs some fine-tuning to fix such cases like stack sizes as well as some coding to implement unicode (needed to make them work with localizations)

Hi. Latest CMake distribution (2.8.11) for OS X knows only about Qt3 and Qt5. Why there is no FindQt5.cmake in cmake_modules folder?

Hi. On my system all Qt5<->cmake integration files come from Qt5 package - with qt5 installed cmake work as it without any workarounds like specifying any locations manually.

Perhaps you need something like this? … on-windows

Did something change with Launcher or mod repository? I can’t make NewOldSpells mod install, even though it works normally in my game.

Just one feature request:

Personally I would like to avoid manual disabling and enabling of mods before and after updating. All these cases should be automatically handled by launcher itself:

  1. When mod (and/or submods) active, then Update button should temporarily disable mod/submod and after successful update enable it again.

  2. When mod inactive, then update button should just update mod but not enable it again.

If this is not the expected behavior, please disable Update button for active mods, as people tend to forget about the necessity of disabling and therefore creating useless server load.

Actually that’s already proposed in this thread and I’m already working on it.

And I completely forgot about that bug reported by Warmonger here… Will check what’s wrong there.

Warmonger, that mod should be working now. Temporary fix - use ONLY lower case for mod names in repository.json file. I’ve already made proper fix for Launcher, will upload it later.

I tried to upload new mods, inluding fixed WoG. None of them can be correctly downloaded from repo :confused:

This is what I see on my side:

Tortofoid -> works for me.
Evil trees -> ID in mod.json is “evil trees” while archive contains mod “evilTree”. Renaming data in repository.json to “evilTree” (case insensetive) should fix this.
WoG -> update bug confirmed, will try to fix today.

Oh - and there are two typos in repo.json as well:

At line 50, position 1 warning: Comma expected!
At line 217, position 1 warning: Comma expected!

Update on WoG - actually archive is corrupted - it must have directory named “WoG” as only top-level file:
        <all files for WoG mod>

Fixing that should also fix broken updates.

Warmonger, can you do all these changes? I won’t be available till late evening so I can’t fix all of these ATM.

Okay, fixed all but WoG.