Language

#1

Hi,

just installed VCMI and its in russian. how can I change it to english?

#2

disable “WoG russian translation” mod

#3

Hello,

I am having the same issue, however I disabled and then uninstalled the “WoG russian translation” mod with no results. What else can I do?

#4

As far as I understand if you have old installtion of VCMI there might be two “WoG russian translation” mods:
[ul]
]One as dedicated mod/:m]
]Other as submod of “In The Wake of Gods”/:m][/ul]
Are you sure you disabled both of them?

If yes I’ll also suggest try to run Heroes.exe and check what language your game data is using. :wink:

#5

I have the same problem. Installed everything new in a clean folder and all the text is in russian. if i start heroes3.exe everything is in english but if i use the launcher its russian. I have installed some mods and tried to disable them. I couldn’t disable WOG after i had installed it.

#6

I might have fixed it. When i remove C:\Users\Zautos’\Documents\My Games\vcmi\Mods\WoG Rus folder. it turns to English again. Is that folder only for language or do i need to disable something in configs

#7

You can do that just via Launcher.

#8

Hello, I have the exact same problem but I don’t know why the launcher is a non win32 application. Even if the client works. What went wrong after the installation of 0.97 from 0.94? Without the launcher I cannot turn back my vcmi from polish to english again since I installed bastion to try it out via launcher when it was on version 0.94.

#9

Launcher is somehow incompatible with Windows XP.

#10

There must be some explanation why. The launcher was compatible under my XP when version 0.94 installed, that was my fault installed polish bastion through launcher. I thought that won’t take affect on the entire interface and in-game description just the town. I was wrong. Till now, I could delete a russian folder found in my documents and settings folder and in “My games/vcmi” directory. I have reinstalled vcmi’s 0.94 version and the launcher works well now under XP just like before, but the client itself now does not cause of an error code 0x40000015. What now?

#11

Launcher for earlier versions was compiled by someone else, iirc with MinGW. I don’t use that, in fact not many developers use Windows at all.

#12

That explains everything. So there won’t be any modification available for vcmi what are 0.94 or 0.96b compatible or under Win XP. If some of the new town classes or others for the newest ones work with earlier versions of vcmi, then I should stay with those. The language problem of mine actually solved now and the client works well. I will find out what systems are compatible with future vcmi versions.