Installing WoG

So, here’s my situation. I installed H3 Complete. Then I installed the WoG+Era 2 package. I tried that out, wogification and everything worked fine. So then I installed VCMI over that, and while there were some signs of WoG, like the Commander button on the hero interface, nothing worked. None of the WoG features were working. Then I noticed in the VCMI launcher, the WoG mod’s version was stated as 0.0.0. I figured there was some problem and that I’d just reinstall it. I uninstalled WoG from the VCMI launcher, but it completely disappeared from the list. There was no way to install WoG via the VCMI launcher. And now I’m completely lost as to how tto install WoG. All I can find online is the 3.58f patch, and since in VCMI and Era it’s a mod, I’m sure that would just mess things up further. Halp?

Ouch. You were not supposed to uninstall WoG via launcher. One piece of mod system that never got finished. Here is complete wog archive, including bits for vcmi integration: … ds/
(will upload to repository a bit later)
Download it and unpack into C:\Users<username>\vcmi\Mods\

As for WoG features - check file \config\defaultMods.json, modules section to be precise.

Thank you, I faced the same problem and I found that some modules were disabled (set to “false”) in “/usr/share/vcmi/config/defaultMods.json”. WoG features began to work after I had made a a file “~/.config/vcmi/defaultMods.json” with the following contents:

		"COMMANDERS": true,
		"MITHRIL": true //so far unused

I hope it will be useful for people who meet the same problem.