Installation on Linux Mint

#1

Hey,
im trying to install heroes3 on laptop with Linux Mint 19.1 Cinnamon.
I ran VCMI building commands and it went well, then i loaded first cd:
vcmibuilder --cd1 /media/ondrej/HEROES3/

that went well too

then second one: (changed the discs in cd-rom from “disc 1- installation” to “disc 2- game disc”)
vcmibuilder --cd2 /media/ondrej/H3_disk2/

got response: cp: cannot create regular file ‘/home/ondrej/.local/share/vcmi/Data/Heroes3.vid’: Permission denied

tried: sudo vcmibuilder --cd2 /media/ondrej/H3_disk2/
typed the password
got: sudo: vcmibuilder: command not found

also tried the same thing as root, but it didnt help.

I own Playman exclusive Heroes III complete cd roms from Ubisoft. Also im new to linux, so take that in mind please :smiley:

Thanks a lot to everybody, i would love to play Heroes 3 on my linux laptop.

#2

The “Permission denied” message suggests that your current user (probably “ondrej” but you can find out using the command “whoami”) does not have the right privileges to create files inside ‘/home/ondrej/.local/share/vcmi/Data/Heroes3.vid’. This should happen because it’s the home directory of the “ondrej” user. You can find out about the directory permissions using “ls -lha /home/ondrej/.local/share/vcmi/Data/”.

The second message “command not found” suggests that the command “vcmibuilder” is not in the “$PATH” that sudo knows about. But this is not important because you should not need to use sudo to write files into your home directory.

#3

That means the I, as “ondrej” , cant write in my own home directory?

#4

I doubt that you cannot write in your own home directory but it seems that you cannot write into this specific subdirectory of your home directory. You didn’t run the commands yet that I suggested you run so I cannot tell you more. But your question does not seem vcmi specific but more a general question of how to use GNU/Linux.