Install VCMI in other Linuxes than Ubuntu/Debian

As the title suggests, there is no possibility to make VCMI work on other Linuxes than Ubuntu and Debian. I’ve tried with 3 different distros Sabayon (which is rather Gentoo, so count this also), Arch and OpenSuse. On Sabayon I’ve tried on my own machine

gcc-4.6.2, compiled successfully, the source is good. But the requirements are too tough, with all the WOG installs I’ve tried, on all types of Heroes 3 (Sod to Wog, Armageddon’s Blade to Wog, RoE to Wog, even Linux Heroes 3 to Wog ), neither worked, same message appeared. I even tried your, didn’t work either (which is the pastebin I just shown).

So the my personal opinion is to keep supporting Ubuntu and Debian alone, it seems for other distros it just fails. Or is it the problem caused rather by Heroes 3 install ? Who knows ? :-s

The only difference for Ubuntu\Debian is presence of precompiled packages. VCMI should work on any SoD + WoG install on any distro.

This. Unpack this package: … .88.tar.gz in your data directory (/home/blacknoxis/Downloads/vcmi/)

Error messages aren’t much descriptive right now :frowning:

Ivan… YOU be da MAN ! Totally works, I will feedback with much as I can. Being involved actively in Sabayon linux, I can make a gentoo-way of installing vcmi.
Once I finish the tutorial, I will report back to you guys.
If you need any help regarding Gentoo / Sabayon stuff, you can pm/mail me. Oh and by the way, I love the smoothness of the game :smiley:

One else question remains : How to activate the Wog Options ? (tried to click it, but doesn’t work).

WoG Options haven’t been implemented yet. Still on our “TO DO” list. :slight_smile:

It’s ok, the good thing is that it works :D. Thing is that I’m curious of the guys who made WOG can make a opensource linux code for the linux version of heroes 3 :confused: Could be worth it

  • We’re not the guys who made WoG :slight_smile:
  • It’s unlikely that Linux version will work at some point. VCMI heavily uses data from SoD and WoG which is unavailable in Linux version - only RoE was released here.

Yeah, only RoE was released on Linux, I know. Too bad …

Well H3SOD installs properly on wine, but there are problem with wog installer.
Since guys in this topic are using linux, I know proposing piracy would be a fail, but it easiest way to gather data to pleasure VCMI.
So I vote for a feature for supporting directory structure from era installer (which contain all wog data).
Era installer is pretty compared to oryginal wog one, and wog is already free of charge.
So then people with linuxes can buy heroes gold/complete on some or elsewhere for 5$ and install it through wine (already possible), and install era through wine (which would allow using VCMI after feature implemented).
If there are no people interested in implementing this feature, i may volounteer as i believe roughtest way to implement this takes less than a page of code diff.
I want the feature for non linux means. If I have time and project keepers allow, I may implement full era-like mod support (which is just sophisticated file override system). If I’m also allowed to expose some yet-constants to JSON file, we can have preliminary (experimental) scriptless mod support, which have no huge advantages for VCMI project itself (and has cons since target mod support would be extremally different), but allow some people concentrted on era side, to wander here, easily move from era enviroment and test features not yet availible in era (as adding new artifacts, units and towns without replacing existing). If I have to advocate the somewhat controversal changes I want (and may provide most of code for) I’ll call this a promotion in context which already have H3 modders.

Last time I checked WoG installer worked fine. However ERA installer hangs at the end of install for me (something in batch files IIRC).

ERA-like directory structure is part of system beegee has been working on - ask him if you want to help. Supporting ERA filesystem should be quite easy.

The only reason why WoG is free of charge is because no-one cares.

well there’s many things I want to do, and I’ll possibly do but it seems the time is too short.
not on my top of priority list, and if beege is already working on it i firstly try to not disturb until my help is really needed and apppreciated.

well my priorities are somewhat twisted, as i work on some script for era which mostly will replace enchanced comanders one which resort to some hacks and makes actions disabled by hacks actually work by some part of the work. code is pretty huge and hardly redable for non-me which made me break in work of compability fixes on my trial to integrate era script fixes with script update (on which project the commander script may depend), which both made me huge break at work on my semestral project, and on monday/tuesday I have a few studies which need me to prepare for it.

Wanted to say, vcmi fails to compile on a boost-1.49 version, but works good on the 1.46 version one. Just wanted to feedback this :D. Arch users cannot compile vcmi

i can confirm that for arch on r 2601, it fails with:

Client.cpp: In member function ‘void CServerHandler::waitForServer()’:
Client.cpp:669:54: error: variable ‘boost::interprocess::scoped_lock<boost::interprocess::interprocess_mutex> slock’ has initializer but incomplete type
make[2]: *** [vcmiclient-Client.o] Error 1
make[2]: Leaving directory `/home/sega/my_pkg/vcmi-svn/src/vcmi/client'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/sega/my_pkg/vcmi-svn/src/vcmi/client'
make: *** [all-recursive] Error 1

Try this: open file vcmi/lib/Interprocess.h and add this line into it:

#include <boost/interprocess/sync/scoped_lock.hpp>

builds on 2603 and Ivan’s fix

Works on Fedora, and I even have music! :slight_smile:

My full trials and tribulations are described in this thread, but basically I followed all the instructions in the wiki (to install the game data) and in the README.linux file to confi+compile the sources.

But I agree that it is a much bigger pain in the behind, compared to installing a binary package… There’s several crucial steps, which, if not done properly will screw up your install (as it happened initially in my case) and the game will start crashing…

I’ve successfully installed vcmi(both 0.89 and the svn one) on gentoo.

I’ve even composed ebuild files for it.

I found for vcmi to be compiled on my gentoo system. Just need to do a little adjusting.

First, it seems the gcc(4.5.3-r2 with boost 1.48.0-r2) on my system does not support std::begin and std::end yet.

Second, in some places NULL cannot be converted to pointer type, just need to revised them to corresponding void pointer type.

Third, when running vcmi, some files cannot be found because of case sensitive problem. In my ebuild file I compared the file from the H3 path with the name vcmi needed and changed them automatically, it works.

VCMI should work with gcc-4.5. I’ll check this out but can you post exact locations for these issues or submit a patch?

Which ones? There are some known issues like Mp3 vs MP3 folders but usually VCMI can handle different case.

EDIT: current svn should work with gcc-4.5

I have some problem with my network. I can only browse but can’t post here after I post my last post. Thank you so much Ivan. It works great now.