I need help with battle


I love VCMI and me and my friends can finely enjoy Homm again. One thing i cant figure out is how do i change the attack in battle with my minions? For example, my acient treants wants to cast a spell Rage of Forest instead of attacking and it makes all my ranged units to not be able to use their ranged attacks for 3 turns. How do i turn that off?

thanks in advance!

Try to pres ‘F’ button.

I have the same problem. If a unit has “cast a spell” skills, I must use all spells first, before I may attack melee. I tried not only “f” button, but also all kinds of F, like F1,2,3,4 etc, alt, ctrl, shift, and it all doesn’t work.

I tried and F did not work. This is making Preserv town un-playable since you can’t really use the units properly. I hope someone comes with a solution soon.

best regards

I don’t have time to check it today, but try to add this bonus to unit’s. json
for example:

			"noCastDefault" :

Uhh, I don’t think we should mix GUI or UX preferences with Bonus system.


i added this to the the units . json file and now i can attack melee. thanks alot :slight_smile: