How to get my downloaded mods to be playable


#1

hello guys im really new to all of this (downloaded it today)
well iv replayed heroes 3 for awhile now so i got bored and started to search for new towns to play then ran into the pirate cove that was amazing and then i started to look for more.
i downloaded era 2 and all i could find till i ran into this place and all of the new towns and stuff people keep on devaloping.
i started the game and everything is fine but i noticed it didnt show all the new mod towns iv added to the mod folder and i dont know how to active them so i can play and enjoy them.
the only new map i see is cove.

if anyone can help me i would really appricate it.
thank you in advance :slight_smile:


#2

This is forum about VCMI platform and VCMI mods. So VCMI is definitelly not ERA2 platform, that’s why VCMI mods are not compatible with ERA2 mods and vice versa.


#3

i know as i sied i might sied it a bit wrong iv downloaded the vcmi platform and tried the mods in that i didnt try to work it on era 2 :slight_smile:


#4

So, you’ve installed VCMI into clean h3 directory. Great! Which version? From where?
Now, create Mods folder into your h3/vcmi directory.
Copy your vcmi mods into Mods folder.
Run vcmi_client.exe or vcmi_launcher.exe


#5

i have h3 hd edition and it sied to install the vcmi into a new folder and just copy the date,map and mp3 folders into this have i done it wrong?
its vcmi 0.99 i bileve the version i downloaded.
the mods iv downloaded are in a folder and inside i see few things one will be a file and another folder whice contain more data and other staff do i need to extrace it all out of those folders just into the first mod folder or its okey to just put the all folder and just leave it like that?


#6

okey so i redownload the hd edition for a clean verstion then extracted vcmi into it, then i created Mods folder for both h3 and vcmi directory and copy the content on the vcmi mods into those Mods folders after i put inside the modded towns.

after i ran the luncher it crashed in in like 1 sec when the intro starts.
in the black coding box it says in red:
Error: campaign movies was not found
Error: campaign music was not found

after that it keep on loading then says in red:
Error: video VIDEO/3DOLOGO was not found

then keep going saying in red:
Disaster happened.
Reason: 0xe06d7363 - UNKNOWN EXCEPTION at 0023 : 76 ,9DD,DC2
Tread ID: 6176 [6176]
Crash info will be put in VCMI_client.exe_crashinfo.dmp

idk what that problem is tho if you could help me with that please? :slight_smile:


#7

If it crashes at launch, it’s incorrectly installed and cannot find neccessary files.


#8

i will try to reinstall then thank you


#9

Some mods are incompatible with old 0.99 version, so I recommend after re-installinh 0.99 update vcmi with lasted daily builds: https://builds.vcmi.download/branch/develop/Windows/


#10

should i download them all? after that where to i put them? into the vcmi directory?


#11

No. VCMI project is in constant development. So every new code/feature added to the ‘base’ is created as new ‘daily build’. This is automatic process, so package at the top of the list is always ‘fresh’ (sometimes buggy, but it is other thing). This is self-ectracting package so install it in your hereos3vcmi folder.