well… i don’t really understand how to use vcmi? as i copied it to folder and i don’t see any changes to game… :S or i have to run server? or what? :s help :slight_smile: ?

Yeah if you extracted package to heroes folder (you should have latest version of wog) vcmi_client.exe should work fine it doesn’t affect original game (i think:P) ,and also remember that vcmi is a rewrite of h3 so for now there aren’t any many new things… yet :wink:

but why, i don’t see anything like this? that new button column.


Yes, VCMI does not affect any version of Heroes III (RoE, AB, SoD or WoG). It’s an implementation of engine and as for now it’s not playable.

Ehm… what? Everything’s fine on your screenshot - you’ve run VCMI with 1024x768 resolution. That’s how it looks like. You can run it in 800x600 resolution (it has standard button column) or 1024x600 too.

and i have to run vcmi_client.exe or wog.exe when i have extracted all stuff?

the point is that its your screenshot not mines lol :slight_smile: and in h3 there are 2 rows of buttons(castle, underground, quest and so on) and on this screenshot i see only 1 row :S how to make like that :smiley: ?

You run VCMI by vcmi_client.exe.

Sorry, I didn’t notice :slight_smile: .

You need to change line

resolution=800x600; // format: WxH

in your config/settings.txt file to

resolution=1024x768; // format: WxH

to make the change permanent or type ‘resolution’ and then ‘3’ in console when you run vcmi_client.exe (but before starting any game) if you want to try it for one game.

i see… ehm… but why when i run client it just runs for few seconds and turns off :S it supposed to be like that ? or not? :S

Well, let’s start from the beginning then… What version of Heroes you had on your system before you unpacked VCMI:

  • RoE, AB, SoD or WoG?
  • In which language?
  • What other mods have you installed previously over it?

Turns off without any prompt window or anything? That’s really strange. Answers for the questions that Zamolxis posted could help. Additionaly you could post here VCMI_client_log.txt and VCMI_server_log.txt files from the directory where you have vcmi_client.exe (just attach them to your next post).

i hava SoD+WoG installed :wink: tho… i just reinstalled them both and now client seems to work! :wink: thnx for help anyways! :wink:

Glad to hear it worked out in the end! :slight_smile: